]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- 1.3.2; thanks to Michal Kochanowicz
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 %bcond_without  esd     # disable esound support
6 #
7
8 %define         _state          stable
9 %define         _kdever         3.3.2
10
11 Summary:        aRts sound server
12 Summary(pl):    Serwer d¼wiêku
13 Summary(pt_BR): Servidor de sons usado pelo KDE
14 Name:           arts
15 Version:        1.3.2
16 Release:        1
17 Epoch:          13
18 License:        LGPL
19 Group:          Libraries
20 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{_kdever}/src/%{name}-%{version}.tar.bz2
21 # Source0-md5:  a3d22f7cc5c641204a28d3f77e441a84
22 URL:            http://www.arts-project.org/
23 %{?with_alsa:BuildRequires:     alsa-lib-devel}
24 BuildRequires:  audiofile-devel
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  docbook-dtd41-sgml
28 BuildRequires:  docbook-utils >= 0.6.13-3
29 %{?with_esd:BuildRequires:      esound-devel}
30 BuildRequires:  glib2-devel >= 2.0.0
31 BuildRequires:  jack-audio-connection-kit-devel
32 BuildRequires:  libmad-devel
33 BuildRequires:  libtool >= 2:1.5-2
34 BuildRequires:  libvorbis-devel
35 %{?with_nas:BuildRequires:      nas-devel}
36 BuildRequires:  pkgconfig
37 BuildRequires:  qt-devel >= 6:3.2.1-4
38 BuildRequires:  unsermake >= 040805-1
39 Obsoletes:      arts-glib
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 The Analog Real-Time Synthesizer, or aRts, is a modular system for
44 synthesizing sound and music on a digital computer. Using small
45 building blocks called modules, the user can easily build complex
46 audio processing tools. Modules typically provide functions such as
47 sound waveform generators, filters, audio effects, mixing, and
48 playback of digital audio in different file formats. The artsd sound
49 server mixes audio from several sources in real time, allowing
50 multiple sound applications to transparently share access to sound
51 hardware.
52
53 %description -l pl
54 Analog Real-Time Synthesizer (w skrócie aRts) to modularny system do
55 obs³ugi d¼wiêku i muzyki na komputerze. Za pomoc± modu³ów u¿ytkownik
56 mo¿e z powodzeniem budowaæ kompleksowe narzêdzia przetwarzania
57 d¼wiêku. Modu³y umo¿liwiaj± generacjê kszta³tu fali, filtrowanie,
58 efekty audio, miksowanie oraz odtwarzanie d¼wiêku cyfrowego w ró¿nych
59 formatach. Serwer d¼wiêku artsd umo¿liwia równie¿ jednoczesne
60 odtwarzanie d¼wiêku z wielu ¼róde³.
61
62 %description -l pt_BR
63 O aRts é um sintetizador analógico em tempo real que é completamente
64 modular. Você pode criar sons e músicas (síntese em tempo real de
65 midi) usando pequenos módulos como oscilador para criar waveforms,
66 vários filtros, mixers, faders, etc. Você pode configurar tudo através
67 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
68 design foi escolhido para permitir que outras aplicações usem o aRts
69 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
70 outros.
71
72 %package devel
73 Summary:        Sound server - header files
74 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
75 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
76 Group:          Development/Libraries
77 Requires:       %{name} = %{epoch}:%{version}-%{release}
78 # not necessary for all libs (e.g. mcop), but propagated by artsflow
79 %{?with_alsa:Requires:  alsa-lib-devel}
80 Requires:       audiofile-devel
81 Requires:       esound-devel
82 Requires:       glib2-devel >= 2.0.0
83 Requires:       jack-audio-connection-kit-devel
84 Requires:       libmad-devel
85 Requires:       libvorbis-devel
86 %{?with_nas:Requires:   nas-devel}
87
88 %description devel
89 Header files required to compile programs using arts.
90
91 %description devel -l pl
92 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
93 arts.
94
95 %description devel -l pt_BR
96 Arquivos para desenvolvimento com o o aRts.
97
98 # separate from arts-devel because they are mostly independent and have very
99 # different deps
100 # there is no artsc base - it would be small and would require arts - so
101 # there is no reason to separate
102 %package -n artsc-devel
103 Summary:        Development files for artsc libraries
104 Summary(pl):    Pliki programistyczne bibliotek artsc
105 Group:          Development/Libraries
106 Requires:       %{name} = %{epoch}:%{version}-%{release}
107 Requires:       glib2-devel >= 2.0.0
108 Conflicts:      arts-devel < 12:1.2.0.031126-2
109
110 %description -n artsc-devel
111 Development files for artsc libraries (C interface to aRts sound
112 system).
113
114 %description -n artsc-devel -l pl
115 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
116 d¼wiêku aRts).
117
118 %package X11
119 Summary:        X11 dependent part of aRts
120 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
121 Group:          X11/Libraries
122 Requires:       %{name} = %{epoch}:%{version}-%{release}
123
124 %description X11
125 X11 dependent part of aRts (x11globalcomm module).
126
127 %description X11 -l pl
128 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
129
130 %package qt
131 Summary:        Qt dependend part of aRts
132 Summary(pl):    Czê¶æ aRts wymagaj±ca Qt
133 Group:          X11/Libraries
134 Requires:       %{name} = %{epoch}:%{version}-%{release}
135 Requires:       qt >= 6:3.2.1-4
136
137 %description qt
138 Qt dependend part of aRts (qtmcop library).
139
140 %description qt -l pl
141 Czê¶æ aRts wymagaj±ca Qt (biblioteka qtmcop).
142
143 %package qt-devel
144 Summary:        Development files for qtmcop library
145 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
146 Group:          X11/Development/Libraries
147 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
148 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
149 Requires:       qt-devel >= 6:3.2.1-4
150
151 %description qt-devel
152 Development files for qtmcop library.
153
154 %description qt-devel -l pl
155 Pliki programistyczne dla biblioteki qtmcop.
156
157 %prep
158 %setup -q
159
160 %build
161 cp -f /usr/share/automake/config.sub admin
162
163 export UNSERMAKE=/usr/share/unsermake/unsermake
164
165 %{__make} -f admin/Makefile.common cvs
166
167 %configure \
168         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
169 %if "%{_lib}" == "lib64"
170         --enable-libsuffix=64 \
171 %endif
172         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
173         %{!?debug:--disable-rpath} \
174         --enable-final \
175         --with-qt-libraries=%{_libdir} \
176         --with%{!?with_alsa:out}-alsa
177
178 %{__make}
179
180 %install
181 rm -rf $RPM_BUILD_ROOT
182
183 %{__make} install \
184         DESTDIR=$RPM_BUILD_ROOT
185
186 # Debian manpages
187 install -d $RPM_BUILD_ROOT%{_mandir}/man1
188 cd debian/man
189 for f in *.sgml ; do
190         base="$(basename $f .sgml)"
191         upper="$(echo ${base} | tr a-z A-Z)"
192         db2man $f
193         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
194 done
195
196 %clean
197 rm -rf $RPM_BUILD_ROOT
198
199 %post   -p /sbin/ldconfig
200 %postun -p /sbin/ldconfig
201
202 %post   X11 -p /sbin/ldconfig
203 %postun X11 -p /sbin/ldconfig
204
205 %post   qt -p /sbin/ldconfig
206 %postun qt -p /sbin/ldconfig
207
208 %files
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_bindir}/artscat
211 %attr(755,root,root) %{_bindir}/artsd
212 %attr(755,root,root) %{_bindir}/artsdsp
213 %attr(755,root,root) %{_bindir}/artsplay
214 %attr(755,root,root) %{_bindir}/artsrec
215 %attr(755,root,root) %{_bindir}/artsshell
216 %attr(755,root,root) %{_bindir}/artswrapper
217 # shared libraries
218 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
219 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
220 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
221 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
222 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
223 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
224 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
225 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
226 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
227 # lt_dlopened modules (*.la needed)
228 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
229 %{_libdir}/libartscbackend.la
230 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
231 %{_libdir}/libartsdsp.la
232 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
233 %{_libdir}/libartsdsp_st.la
234 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
235 %{_libdir}/libartsgslplayobject.la
236 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
237 %{_libdir}/libartswavplayobject.la
238 #
239 %{_libdir}/mcop
240 %{_mandir}/man1/artscat.1*
241 %{_mandir}/man1/artsd.1*
242 %{_mandir}/man1/artsdsp.1*
243 %{_mandir}/man1/artsplay.1*
244 %{_mandir}/man1/artsrec.1*
245 %{_mandir}/man1/artsshell.1*
246 %{_mandir}/man1/artswrapper.1*
247
248 %files devel
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{_bindir}/mcopidl
251 %attr(755,root,root) %{_libdir}/libartsflow.so
252 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
253 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
254 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
255 %attr(755,root,root) %{_libdir}/libgmcop.so
256 %attr(755,root,root) %{_libdir}/libkmedia2.so
257 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
258 %attr(755,root,root) %{_libdir}/libmcop.so
259 %attr(755,root,root) %{_libdir}/libmcop_mt.so
260 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
261 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
262 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
263 # shared libraries
264 %{_libdir}/libartsflow.la
265 %{_libdir}/libartsflow_idl.la
266 %{_libdir}/libgmcop.la
267 %{_libdir}/libkmedia2.la
268 %{_libdir}/libkmedia2_idl.la
269 %{_libdir}/libmcop.la
270 %{_libdir}/libmcop_mt.la
271 %{_libdir}/libsoundserver_idl.la
272 #
273 %{_includedir}/arts
274 %exclude %{_includedir}/arts/qiomanager.h
275 %{_mandir}/man1/mcopidl.1*
276
277 %files -n artsc-devel
278 %defattr(644,root,root,755)
279 %attr(755,root,root) %{_bindir}/artsc-config
280 %attr(755,root,root) %{_libdir}/libartsc.so
281 %attr(755,root,root) %{_libdir}/libartscbackend.so
282 %attr(755,root,root) %{_libdir}/libartsdsp.so
283 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
284 %{_libdir}/libartsc.la
285 %{_includedir}/artsc
286 %{_mandir}/man1/artsc-config.1*
287
288 %files X11
289 %defattr(644,root,root,755)
290 # lt_dlopened module (.la needed)
291 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
292 %{_libdir}/libx11globalcomm.la
293
294 %files qt
295 %defattr(644,root,root,755)
296 # shared library
297 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
298
299 %files qt-devel
300 %defattr(644,root,root,755)
301 %attr(755,root,root) %{_libdir}/libqtmcop.so
302 %{_libdir}/libqtmcop.la
303 %{_includedir}/arts/qiomanager.h
This page took 0.052679 seconds and 4 git commands to generate.