]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- BR+R: jack-audio-connection-kit-devel (used by default)
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 %bcond_without  esd     # disable esound support
6 #
7
8 %define         _state          stable
9 %define         _kdever         3.3
10 %define         _ver            1.3.0
11
12 Summary:        aRts sound server
13 Summary(pl):    Serwer d¼wiêku
14 Summary(pt_BR): Servidor de sons usado pelo KDE
15 Name:           arts
16 Version:        %{_ver}
17 Release:        1
18 Epoch:          13
19 License:        LGPL
20 Group:          Libraries
21 #Source0:       http://download.kde.org/%{_state}/%{_kdever}/src/%{name}-%{_ver}.tar.bz2
22 Source0:        http://ftp.man.szczecin.pl/pub/kde/%{_state}/%{_kdever}/src/%{name}-%{_ver}.tar.bz2
23 # Source0-md5:  6a0a03c24a20c43a8e443a5484bb9fef
24 URL:            http://www.kde.org/
25 %{?with_alsa:BuildRequires:     alsa-lib-devel}
26 BuildRequires:  audiofile-devel
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  docbook-dtd41-sgml
30 BuildRequires:  docbook-utils >= 0.6.13-3
31 %{?with_esd:BuildRequires:      esound-devel}
32 BuildRequires:  glib2-devel >= 2.0.0
33 BuildRequires:  jack-audio-connection-kit-devel
34 BuildRequires:  libmad-devel
35 BuildRequires:  libtool >= 2:1.5-2
36 BuildRequires:  libvorbis-devel
37 %{?with_nas:BuildRequires:      nas-devel}
38 BuildRequires:  pkgconfig
39 BuildRequires:  qt-devel >= 6:3.2.1-4
40 BuildRequires:  unsermake >= 040805-1
41 Obsoletes:      arts-glib
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 The Analog Real-Time Synthesizer, or aRts, is a modular system for
46 synthesizing sound and music on a digital computer. Using small
47 building blocks called modules, the user can easily build complex
48 audio processing tools. Modules typically provide functions such as
49 sound waveform generators, filters, audio effects, mixing, and
50 playback of digital audio in different file formats. The artsd sound
51 server mixes audio from several sources in real time, allowing
52 multiple sound applications to transparently share access to sound
53 hardware.
54
55 %description -l pl
56 Analog Real-Time Synthesizer (w skrócie aRts) to modularny system do
57 obs³ugi d¼wiêku i muzyki na komputerze. Za pomoc± modu³ów u¿ytkownik
58 mo¿e z powodzeniem budowaæ kompleksowe narzêdzia przetwarzania
59 d¼wiêku. Modu³y umo¿liwiaj± generacjê kstza³tu fali, filtrowanie,
60 efekty audio, miksowanie oraz odtwarzanie d¼wiêku cyfrowego w ró¿nych
61 formatach. Serwer d¼wiêku artsd umo¿liwia równie¿ jednoczesne
62 odtwarzanie d¼wiêku z wielu ¼róde³.
63
64 %description -l pt_BR
65 O aRts é um sintetizador analógico em tempo real que é completamente
66 modular. Você pode criar sons e músicas (síntese em tempo real de
67 midi) usando pequenos módulos como oscilador para criar waveforms,
68 vários filtros, mixers, faders, etc. Você pode configurar tudo através
69 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
70 design foi escolhido para permitir que outras aplicações usem o aRts
71 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
72 outros.
73
74 %package devel
75 Summary:        Sound server - header files
76 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
77 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
78 Group:          Development/Libraries
79 Requires:       %{name} = %{epoch}:%{version}-%{release}
80 # not necessary for all libs (e.g. mcop), but propagated by artsflow
81 %{?with_alsa:Requires:  alsa-lib-devel}
82 Requires:       audiofile-devel
83 Requires:       esound-devel
84 Requires:       glib2-devel >= 2.0.0
85 Requires:       jack-audio-connection-kit-devel
86 Requires:       libmad-devel
87 Requires:       libvorbis-devel
88 %{?with_nas:Requires:   nas-devel}
89
90 %description devel
91 Header files required to compile programs using arts.
92
93 %description devel -l pl
94 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
95 arts.
96
97 %description devel -l pt_BR
98 Arquivos para desenvolvimento com o o aRts.
99
100 # separate from arts-devel because they are mostly independent and have very
101 # different deps
102 # there is no artsc base - it would be small and would require arts - so
103 # there is no reason to separate
104 %package -n artsc-devel
105 Summary:        Development files for artsc libraries
106 Summary(pl):    Pliki programistyczne bibliotek artsc
107 Group:          Development/Libraries
108 Requires:       %{name} = %{epoch}:%{version}-%{release}
109 Requires:       glib2-devel >= 2.0.0
110 Conflicts:      arts-devel < 12:1.2.0.031126-2
111
112 %description -n artsc-devel
113 Development files for artsc libraries (C interface to aRts sound
114 system).
115
116 %description -n artsc-devel -l pl
117 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
118 d¼wiêku aRts).
119
120 %package X11
121 Summary:        X11 dependent part of aRts
122 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
123 Group:          X11/Libraries
124 Requires:       %{name} = %{epoch}:%{version}-%{release}
125
126 %description X11
127 X11 dependent part of aRts (x11globalcomm module).
128
129 %description X11 -l pl
130 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
131
132 %package qt
133 Summary:        QT dependend part of aRts
134 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
135 Group:          X11/Libraries
136 Requires:       %{name} = %{epoch}:%{version}-%{release}
137 Requires:       qt >= 6:3.2.1-4
138
139 %description qt
140 QT dependend part of aRts (qtmcop library).
141
142 %description qt -l pl
143 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
144
145 %package qt-devel
146 Summary:        Development files for qtmcop library
147 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
148 Group:          X11/Development/Libraries
149 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
150 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
151 Requires:       qt-devel >= 6:3.2.1-4
152
153 %description qt-devel
154 Development files for qtmcop library.
155
156 %description qt-devel -l pl
157 Pliki programistyczne dla biblioteki qtmcop.
158
159 %prep
160 %setup -q
161
162 %build
163 cp -f /usr/share/automake/config.sub admin
164
165 export UNSERMAKE=/usr/share/unsermake/unsermake
166
167 %{__make} -f admin/Makefile.common cvs
168
169 %configure \
170         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
171         --%{?debug:en}%{!?debug:dis}able-debug \
172         --disable-rpath \
173         --enable-final \
174         --with-qt-libraries=%{_libdir} \
175         --with%{!?with_alsa:out}-alsa
176
177 %{__make}
178
179 %install
180 rm -rf $RPM_BUILD_ROOT
181
182 %{__make} install \
183         DESTDIR=$RPM_BUILD_ROOT
184
185 # Debian manpages
186 install -d $RPM_BUILD_ROOT%{_mandir}/man1
187 cd debian/man
188 for f in *.sgml ; do
189         base="$(basename $f .sgml)"
190         upper="$(echo ${base} | tr a-z A-Z)"
191         db2man $f
192         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
193 done
194
195 %clean
196 rm -rf $RPM_BUILD_ROOT
197
198 %post   -p /sbin/ldconfig
199 %postun -p /sbin/ldconfig
200
201 %post   X11 -p /sbin/ldconfig
202 %postun X11 -p /sbin/ldconfig
203
204 %post   qt -p /sbin/ldconfig
205 %postun qt -p /sbin/ldconfig
206
207 %files
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_bindir}/artscat
210 %attr(755,root,root) %{_bindir}/artsd
211 %attr(755,root,root) %{_bindir}/artsdsp
212 %attr(755,root,root) %{_bindir}/artsplay
213 %attr(755,root,root) %{_bindir}/artsrec
214 %attr(755,root,root) %{_bindir}/artsshell
215 %attr(755,root,root) %{_bindir}/artswrapper
216 # shared libraries
217 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
218 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
219 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
220 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
221 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
222 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
223 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
224 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
225 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
226 # lt_dlopened modules (*.la needed)
227 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
228 %{_libdir}/libartscbackend.la
229 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
230 %{_libdir}/libartsdsp.la
231 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
232 %{_libdir}/libartsdsp_st.la
233 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
234 %{_libdir}/libartsgslplayobject.la
235 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
236 %{_libdir}/libartswavplayobject.la
237 #
238 %{_libdir}/mcop
239 %{_mandir}/man1/artscat.1*
240 %{_mandir}/man1/artsd.1*
241 %{_mandir}/man1/artsdsp.1*
242 %{_mandir}/man1/artsplay.1*
243 %{_mandir}/man1/artsrec.1*
244 %{_mandir}/man1/artsshell.1*
245 %{_mandir}/man1/artswrapper.1*
246
247 %files devel
248 %defattr(644,root,root,755)
249 %attr(755,root,root) %{_bindir}/mcopidl
250 %attr(755,root,root) %{_libdir}/libartsflow.so
251 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
252 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
253 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
254 %attr(755,root,root) %{_libdir}/libgmcop.so
255 %attr(755,root,root) %{_libdir}/libkmedia2.so
256 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
257 %attr(755,root,root) %{_libdir}/libmcop.so
258 %attr(755,root,root) %{_libdir}/libmcop_mt.so
259 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
260 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
261 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
262 # shared libraries
263 %{_libdir}/libartsflow.la
264 %{_libdir}/libartsflow_idl.la
265 %{_libdir}/libgmcop.la
266 %{_libdir}/libkmedia2.la
267 %{_libdir}/libkmedia2_idl.la
268 %{_libdir}/libmcop.la
269 %{_libdir}/libmcop_mt.la
270 %{_libdir}/libsoundserver_idl.la
271 #
272 %{_includedir}/arts
273 %exclude %{_includedir}/arts/qiomanager.h
274 %{_mandir}/man1/mcopidl.1*
275
276 %files -n artsc-devel
277 %defattr(644,root,root,755)
278 %attr(755,root,root) %{_bindir}/artsc-config
279 %attr(755,root,root) %{_libdir}/libartsc.so
280 %attr(755,root,root) %{_libdir}/libartscbackend.so
281 %attr(755,root,root) %{_libdir}/libartsdsp.so
282 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
283 %{_libdir}/libartsc.la
284 %{_includedir}/artsc
285 %{_mandir}/man1/artsc-config.1*
286
287 %files X11
288 %defattr(644,root,root,755)
289 # lt_dlopened module (.la needed)
290 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
291 %{_libdir}/libx11globalcomm.la
292
293 %files qt
294 %defattr(644,root,root,755)
295 # shared library
296 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
297
298 %files qt-devel
299 %defattr(644,root,root,755)
300 %attr(755,root,root) %{_libdir}/libqtmcop.so
301 %{_libdir}/libqtmcop.la
302 %{_includedir}/arts/qiomanager.h
This page took 0.161451 seconds and 4 git commands to generate.