]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- 3.3.0 rc2
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 %bcond_without  esd     # disable esound support
6 #bcond_with     cvs     # use cvs sources instead of source0
7 #
8
9 %define         _state          unstable
10 %define         _ver            1.3.0
11 #define         _snap           040724
12
13 Summary:        aRts sound server
14 Summary(pl):    Serwer d¼wiêku
15 Summary(pt_BR): Servidor de sons usado pelo KDE
16 Name:           arts
17 Version:        %{_ver}
18 Release:        0.rc2.1
19 Epoch:          13
20 License:        LGPL
21 Group:          Libraries
22 #Source0:       http://download.kde.org/%{_state}/%{_kdever}/src/%{name}-%{_ver}-rc2.tar.bz2
23 Source0:        ftp://ftp.pld-linux.org/software/kde/%{name}-%{version}-rc2.tar.bz2
24 # Source0-md5:  ca7710f1f18a0311e474c97f7037808e
25 #if ! %{with cvs}
26 #Source0:       ftp://ftp.pld-linux.org/software/kde/%{name}-%{version}rc1.tar.bz2
27 #else
28 #Source0:       kdesource.tar.gz
29 #endif
30 URL:            http://www.kde.org/
31 %{?with_alsa:BuildRequires:     alsa-lib-devel}
32 BuildRequires:  audiofile-devel
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  docbook-dtd41-sgml
36 BuildRequires:  docbook-utils >= 0.6.13-3
37 %{?with_esd:BuildRequires:      esound-devel}
38 BuildRequires:  glib2-devel >= 2.0.0
39 BuildRequires:  libmad-devel
40 BuildRequires:  libtool >= 2:1.5-2
41 BuildRequires:  libvorbis-devel
42 %{?with_nas:BuildRequires:      nas-devel}
43 BuildRequires:  pkgconfig
44 BuildRequires:  qt-devel >= 6:3.2.1-4
45 BuildRequires:  unsermake >= 040805-1
46 Obsoletes:      arts-glib
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 The Analog Real-Time Synthesizer, or aRts, is a modular system for
51 synthesizing sound and music on a digital computer. Using small
52 building blocks called modules, the user can easily build complex
53 audio processing tools. Modules typically provide functions such as
54 sound waveform generators, filters, audio effects, mixing, and
55 playback of digital audio in different file formats. The artsd sound
56 server mixes audio from several sources in real time, allowing
57 multiple sound applications to transparently share access to sound
58 hardware.
59
60 %description -l pl
61 Analog Real-Time Synthesizer (w skrócie aRts) to modularny system do
62 obs³ugi d¼wiêku i muzyki na komputerze. Za pomoc± modu³ów u¿ytkownik
63 mo¿e z powodzeniem budowaæ kompleksowe narzêdzia przetwarzania
64 d¼wiêku. Modu³y umo¿liwiaj± generacjê kstza³tu fali, filtrowanie,
65 efekty audio, miksowanie oraz odtwarzanie d¼wiêku cyfrowego w ró¿nych
66 formatach. Serwer d¼wiêku artsd umo¿liwia równie¿ jednoczesne
67 odtwarzanie d¼wiêku z wielu ¼róde³.
68
69 %description -l pt_BR
70 O aRts é um sintetizador analógico em tempo real que é completamente
71 modular. Você pode criar sons e músicas (síntese em tempo real de
72 midi) usando pequenos módulos como oscilador para criar waveforms,
73 vários filtros, mixers, faders, etc. Você pode configurar tudo através
74 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
75 design foi escolhido para permitir que outras aplicações usem o aRts
76 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
77 outros.
78
79 %package devel
80 Summary:        Sound server - header files
81 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
82 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
83 Group:          Development/Libraries
84 Requires:       %{name} = %{epoch}:%{version}-%{release}
85 # not necessary for all libs (e.g. mcop), but propagated by artsflow
86 %{?with_alsa:Requires:  alsa-lib-devel}
87 Requires:       audiofile-devel
88 Requires:       esound-devel
89 Requires:       glib2-devel >= 2.0.0
90 Requires:       libmad-devel
91 Requires:       libvorbis-devel
92 %{?with_nas:Requires:   nas-devel}
93
94 %description devel
95 Header files required to compile programs using arts.
96
97 %description devel -l pl
98 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
99 arts.
100
101 %description devel -l pt_BR
102 Arquivos para desenvolvimento com o o aRts.
103
104 # separate from arts-devel because they are mostly independent and
105 # have very # different deps  there is no artsc base - it would be
106 # small and would require arts - so there is no reason to separate
107 %package -n artsc-devel
108 Summary:        Development files for artsc libraries
109 Summary(pl):    Pliki programistyczne bibliotek artsc
110 Group:          Development/Libraries
111 Requires:       %{name} = %{epoch}:%{version}-%{release}
112 Requires:       glib2-devel >= 2.0.0
113 Conflicts:      arts-devel < 12:1.2.0.031126-2
114
115 %description -n artsc-devel
116 Development files for artsc libraries (C interface to aRts sound
117 system).
118
119 %description -n artsc-devel -l pl
120 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
121 d¼wiêku aRts).
122
123 %package X11
124 Summary:        X11 dependent part of aRts
125 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
126 Group:          X11/Libraries
127 Requires:       %{name} = %{epoch}:%{version}-%{release}
128
129 %description X11
130 X11 dependent part of aRts (x11globalcomm module).
131
132 %description X11 -l pl
133 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
134
135 %package qt
136 Summary:        QT dependend part of aRts
137 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
138 Group:          X11/Libraries
139 Requires:       %{name} = %{epoch}:%{version}-%{release}
140 Requires:       qt >= 6:3.2.1-4
141
142 %description qt
143 QT dependend part of aRts (qtmcop library).
144
145 %description qt -l pl
146 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
147
148 %package qt-devel
149 Summary:        Development files for qtmcop library
150 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
151 Group:          X11/Development/Libraries
152 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
153 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
154 Requires:       qt-devel >= 6:3.2.1-4
155
156 %description qt-devel
157 Development files for qtmcop library.
158
159 %description qt-devel -l pl
160 Pliki programistyczne dla biblioteki qtmcop.
161
162 %prep
163 #if ! %{with cvs}
164 %setup -q -n %{name}-%{version}
165 #else
166 #setup -q -n %{name} -D
167 #endif
168
169 %build
170
171 cp /usr/share/automake/config.sub admin
172
173 export UNSERMAKE=/usr/share/unsermake/unsermake
174
175 %{__make} -f admin/Makefile.common cvs
176
177 %configure \
178         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
179         --%{?debug:en}%{!?debug:dis}able-debug \
180         --disable-rpath \
181         --enable-final \
182         --with-qt-libraries=%{_libdir} \
183         --with%{!?with_alsa:out}-alsa
184
185 %{__make}
186
187 %install
188 rm -rf $RPM_BUILD_ROOT
189
190 %{__make} install \
191         DESTDIR=$RPM_BUILD_ROOT
192
193 # Debian manpages
194 install -d $RPM_BUILD_ROOT%{_mandir}/man1
195 cd debian/man
196 for f in *.sgml ; do
197         base="$(basename $f .sgml)"
198         upper="$(echo ${base} | tr a-z A-Z)"
199         db2man $f
200         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
201 done
202
203 %clean
204 rm -rf $RPM_BUILD_ROOT
205
206 %post   -p /sbin/ldconfig
207 %postun -p /sbin/ldconfig
208
209 %post   X11 -p /sbin/ldconfig
210 %postun X11 -p /sbin/ldconfig
211
212 %post   qt -p /sbin/ldconfig
213 %postun qt -p /sbin/ldconfig
214
215 %files
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_bindir}/artscat
218 %attr(755,root,root) %{_bindir}/artsd
219 %attr(755,root,root) %{_bindir}/artsdsp
220 %attr(755,root,root) %{_bindir}/artsplay
221 %attr(755,root,root) %{_bindir}/artsrec
222 %attr(755,root,root) %{_bindir}/artsshell
223 %attr(755,root,root) %{_bindir}/artswrapper
224 # shared libraries
225 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
226 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
227 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
228 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
229 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
230 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
231 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
232 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
233 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
234 # lt_dlopened modules (*.la needed)
235 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
236 %{_libdir}/libartscbackend.la
237 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
238 %{_libdir}/libartsdsp.la
239 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
240 %{_libdir}/libartsdsp_st.la
241 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
242 %{_libdir}/libartsgslplayobject.la
243 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
244 %{_libdir}/libartswavplayobject.la
245 #
246 %{_libdir}/mcop
247 %{_mandir}/man1/artscat.1*
248 %{_mandir}/man1/artsd.1*
249 %{_mandir}/man1/artsdsp.1*
250 %{_mandir}/man1/artsplay.1*
251 %{_mandir}/man1/artsrec.1*
252 %{_mandir}/man1/artsshell.1*
253 %{_mandir}/man1/artswrapper.1*
254
255 %files devel
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_bindir}/mcopidl
258 %attr(755,root,root) %{_libdir}/libartsflow.so
259 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
260 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
261 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
262 %attr(755,root,root) %{_libdir}/libgmcop.so
263 %attr(755,root,root) %{_libdir}/libkmedia2.so
264 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
265 %attr(755,root,root) %{_libdir}/libmcop.so
266 %attr(755,root,root) %{_libdir}/libmcop_mt.so
267 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
268 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
269 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
270 # shared libraries
271 %{_libdir}/libartsflow.la
272 %{_libdir}/libartsflow_idl.la
273 %{_libdir}/libgmcop.la
274 %{_libdir}/libkmedia2.la
275 %{_libdir}/libkmedia2_idl.la
276 %{_libdir}/libmcop.la
277 %{_libdir}/libmcop_mt.la
278 %{_libdir}/libsoundserver_idl.la
279 #
280 %{_includedir}/arts
281 %exclude %{_includedir}/arts/qiomanager.h
282 %{_mandir}/man1/mcopidl.1*
283
284 %files -n artsc-devel
285 %defattr(644,root,root,755)
286 %attr(755,root,root) %{_bindir}/artsc-config
287 %attr(755,root,root) %{_libdir}/libartsc.so
288 %attr(755,root,root) %{_libdir}/libartscbackend.so
289 %attr(755,root,root) %{_libdir}/libartsdsp.so
290 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
291 %{_libdir}/libartsc.la
292 %{_includedir}/artsc
293 %{_mandir}/man1/artsc-config.1*
294
295 %files X11
296 %defattr(644,root,root,755)
297 # lt_dlopened module (.la needed)
298 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
299 %{_libdir}/libx11globalcomm.la
300
301 %files qt
302 %defattr(644,root,root,755)
303 # shared library
304 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
305
306 %files qt-devel
307 %defattr(644,root,root,755)
308 %attr(755,root,root) %{_libdir}/libqtmcop.so
309 %{_libdir}/libqtmcop.la
310 %{_includedir}/arts/qiomanager.h
This page took 0.05596 seconds and 4 git commands to generate.