]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- little tk-like cosmetics
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 %bcond_without  esd     # disable esound support
6 #bcond_with     cvs     # use cvs sources instead of source0
7 #
8
9 %define         _state          unstable
10 %define         _ver            1.3.0
11 %define         _snap           rc2
12
13 Summary:        aRts sound server
14 Summary(pl):    Serwer d¼wiêku
15 Summary(pt_BR): Servidor de sons usado pelo KDE
16 Name:           arts
17 Version:        %{_ver}
18 Release:        0.%{_snap}.1
19 Epoch:          13
20 License:        LGPL
21 Group:          Libraries
22 #Source0:       http://download.kde.org/%{_state}/%{_kdever}/src/%{name}-%{_ver}.tar.bz2
23 Source0:        ftp://ftp.pld-linux.org/software/kde/%{name}-%{version}-%{_snap}.tar.bz2
24 # Source0-md5:  ca7710f1f18a0311e474c97f7037808e
25 URL:            http://www.kde.org/
26 %{?with_alsa:BuildRequires:     alsa-lib-devel}
27 BuildRequires:  audiofile-devel
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  docbook-dtd41-sgml
31 BuildRequires:  docbook-utils >= 0.6.13-3
32 %{?with_esd:BuildRequires:      esound-devel}
33 BuildRequires:  glib2-devel >= 2.0.0
34 BuildRequires:  libmad-devel
35 BuildRequires:  libtool >= 2:1.5-2
36 BuildRequires:  libvorbis-devel
37 %{?with_nas:BuildRequires:      nas-devel}
38 BuildRequires:  pkgconfig
39 BuildRequires:  qt-devel >= 6:3.2.1-4
40 BuildRequires:  unsermake >= 040805-1
41 Obsoletes:      arts-glib
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 The Analog Real-Time Synthesizer, or aRts, is a modular system for
46 synthesizing sound and music on a digital computer. Using small
47 building blocks called modules, the user can easily build complex
48 audio processing tools. Modules typically provide functions such as
49 sound waveform generators, filters, audio effects, mixing, and
50 playback of digital audio in different file formats. The artsd sound
51 server mixes audio from several sources in real time, allowing
52 multiple sound applications to transparently share access to sound
53 hardware.
54
55 %description -l pl
56 Analog Real-Time Synthesizer (w skrócie aRts) to modularny system do
57 obs³ugi d¼wiêku i muzyki na komputerze. Za pomoc± modu³ów u¿ytkownik
58 mo¿e z powodzeniem budowaæ kompleksowe narzêdzia przetwarzania
59 d¼wiêku. Modu³y umo¿liwiaj± generacjê kstza³tu fali, filtrowanie,
60 efekty audio, miksowanie oraz odtwarzanie d¼wiêku cyfrowego w ró¿nych
61 formatach. Serwer d¼wiêku artsd umo¿liwia równie¿ jednoczesne
62 odtwarzanie d¼wiêku z wielu ¼róde³.
63
64 %description -l pt_BR
65 O aRts é um sintetizador analógico em tempo real que é completamente
66 modular. Você pode criar sons e músicas (síntese em tempo real de
67 midi) usando pequenos módulos como oscilador para criar waveforms,
68 vários filtros, mixers, faders, etc. Você pode configurar tudo através
69 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
70 design foi escolhido para permitir que outras aplicações usem o aRts
71 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
72 outros.
73
74 %package devel
75 Summary:        Sound server - header files
76 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
77 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
78 Group:          Development/Libraries
79 Requires:       %{name} = %{epoch}:%{version}-%{release}
80 # not necessary for all libs (e.g. mcop), but propagated by artsflow
81 %{?with_alsa:Requires:  alsa-lib-devel}
82 Requires:       audiofile-devel
83 Requires:       esound-devel
84 Requires:       glib2-devel >= 2.0.0
85 Requires:       libmad-devel
86 Requires:       libvorbis-devel
87 %{?with_nas:Requires:   nas-devel}
88
89 %description devel
90 Header files required to compile programs using arts.
91
92 %description devel -l pl
93 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
94 arts.
95
96 %description devel -l pt_BR
97 Arquivos para desenvolvimento com o o aRts.
98
99 # separate from arts-devel because they are mostly independent and
100 # have very # different deps  there is no artsc base - it would be
101 # small and would require arts - so there is no reason to separate
102 %package -n artsc-devel
103 Summary:        Development files for artsc libraries
104 Summary(pl):    Pliki programistyczne bibliotek artsc
105 Group:          Development/Libraries
106 Requires:       %{name} = %{epoch}:%{version}-%{release}
107 Requires:       glib2-devel >= 2.0.0
108 Conflicts:      arts-devel < 12:1.2.0.031126-2
109
110 %description -n artsc-devel
111 Development files for artsc libraries (C interface to aRts sound
112 system).
113
114 %description -n artsc-devel -l pl
115 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
116 d¼wiêku aRts).
117
118 %package X11
119 Summary:        X11 dependent part of aRts
120 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
121 Group:          X11/Libraries
122 Requires:       %{name} = %{epoch}:%{version}-%{release}
123
124 %description X11
125 X11 dependent part of aRts (x11globalcomm module).
126
127 %description X11 -l pl
128 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
129
130 %package qt
131 Summary:        QT dependend part of aRts
132 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
133 Group:          X11/Libraries
134 Requires:       %{name} = %{epoch}:%{version}-%{release}
135 Requires:       qt >= 6:3.2.1-4
136
137 %description qt
138 QT dependend part of aRts (qtmcop library).
139
140 %description qt -l pl
141 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
142
143 %package qt-devel
144 Summary:        Development files for qtmcop library
145 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
146 Group:          X11/Development/Libraries
147 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
148 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
149 Requires:       qt-devel >= 6:3.2.1-4
150
151 %description qt-devel
152 Development files for qtmcop library.
153
154 %description qt-devel -l pl
155 Pliki programistyczne dla biblioteki qtmcop.
156
157 %prep
158 %setup -q -n %{name}-%{version}
159
160 %build
161 cp /usr/share/automake/config.sub admin
162
163 export UNSERMAKE=/usr/share/unsermake/unsermake
164
165 %{__make} -f admin/Makefile.common cvs
166
167 %configure \
168         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
169         --%{?debug:en}%{!?debug:dis}able-debug \
170         --disable-rpath \
171         --enable-final \
172         --with-qt-libraries=%{_libdir} \
173         --with%{!?with_alsa:out}-alsa
174
175 %{__make}
176
177 %install
178 rm -rf $RPM_BUILD_ROOT
179
180 %{__make} install \
181         DESTDIR=$RPM_BUILD_ROOT
182
183 # Debian manpages
184 install -d $RPM_BUILD_ROOT%{_mandir}/man1
185 cd debian/man
186 for f in *.sgml ; do
187         base="$(basename $f .sgml)"
188         upper="$(echo ${base} | tr a-z A-Z)"
189         db2man $f
190         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
191 done
192
193 %clean
194 rm -rf $RPM_BUILD_ROOT
195
196 %post   -p /sbin/ldconfig
197 %postun -p /sbin/ldconfig
198
199 %post   X11 -p /sbin/ldconfig
200 %postun X11 -p /sbin/ldconfig
201
202 %post   qt -p /sbin/ldconfig
203 %postun qt -p /sbin/ldconfig
204
205 %files
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_bindir}/artscat
208 %attr(755,root,root) %{_bindir}/artsd
209 %attr(755,root,root) %{_bindir}/artsdsp
210 %attr(755,root,root) %{_bindir}/artsplay
211 %attr(755,root,root) %{_bindir}/artsrec
212 %attr(755,root,root) %{_bindir}/artsshell
213 %attr(755,root,root) %{_bindir}/artswrapper
214 # shared libraries
215 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
216 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
217 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
218 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
219 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
220 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
221 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
222 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
223 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
224 # lt_dlopened modules (*.la needed)
225 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
226 %{_libdir}/libartscbackend.la
227 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
228 %{_libdir}/libartsdsp.la
229 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
230 %{_libdir}/libartsdsp_st.la
231 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
232 %{_libdir}/libartsgslplayobject.la
233 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
234 %{_libdir}/libartswavplayobject.la
235 #
236 %{_libdir}/mcop
237 %{_mandir}/man1/artscat.1*
238 %{_mandir}/man1/artsd.1*
239 %{_mandir}/man1/artsdsp.1*
240 %{_mandir}/man1/artsplay.1*
241 %{_mandir}/man1/artsrec.1*
242 %{_mandir}/man1/artsshell.1*
243 %{_mandir}/man1/artswrapper.1*
244
245 %files devel
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_bindir}/mcopidl
248 %attr(755,root,root) %{_libdir}/libartsflow.so
249 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
250 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
251 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
252 %attr(755,root,root) %{_libdir}/libgmcop.so
253 %attr(755,root,root) %{_libdir}/libkmedia2.so
254 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
255 %attr(755,root,root) %{_libdir}/libmcop.so
256 %attr(755,root,root) %{_libdir}/libmcop_mt.so
257 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
258 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
259 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
260 # shared libraries
261 %{_libdir}/libartsflow.la
262 %{_libdir}/libartsflow_idl.la
263 %{_libdir}/libgmcop.la
264 %{_libdir}/libkmedia2.la
265 %{_libdir}/libkmedia2_idl.la
266 %{_libdir}/libmcop.la
267 %{_libdir}/libmcop_mt.la
268 %{_libdir}/libsoundserver_idl.la
269 #
270 %{_includedir}/arts
271 %exclude %{_includedir}/arts/qiomanager.h
272 %{_mandir}/man1/mcopidl.1*
273
274 %files -n artsc-devel
275 %defattr(644,root,root,755)
276 %attr(755,root,root) %{_bindir}/artsc-config
277 %attr(755,root,root) %{_libdir}/libartsc.so
278 %attr(755,root,root) %{_libdir}/libartscbackend.so
279 %attr(755,root,root) %{_libdir}/libartsdsp.so
280 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
281 %{_libdir}/libartsc.la
282 %{_includedir}/artsc
283 %{_mandir}/man1/artsc-config.1*
284
285 %files X11
286 %defattr(644,root,root,755)
287 # lt_dlopened module (.la needed)
288 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
289 %{_libdir}/libx11globalcomm.la
290
291 %files qt
292 %defattr(644,root,root,755)
293 # shared library
294 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
295
296 %files qt-devel
297 %defattr(644,root,root,755)
298 %attr(755,root,root) %{_libdir}/libqtmcop.so
299 %{_libdir}/libqtmcop.la
300 %{_includedir}/arts/qiomanager.h
This page took 0.064832 seconds and 4 git commands to generate.