]> git.pld-linux.org Git - packages/arrayprobe.git/commitdiff
- don't use <linux/compiler.h> in userspace
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 14 Jun 2007 17:20:37 +0000 (17:20 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    arrayprobe-headers.patch -> 1.3

arrayprobe-headers.patch

index 22839b1501227022bbef012d0b471e778a1b05ca..5368f1cc562da9acbd7e8139c62c29cd58b26661 100644 (file)
@@ -1,14 +1,39 @@
---- cpqarrayd-2.2/configure.ac.orig    2005-07-28 16:33:41.000000000 +0200
-+++ cpqarrayd-2.2/configure.ac 2006-03-09 11:31:02.000000000 +0100
-@@ -19,7 +19,7 @@
- dnl Check for pathed kernel sources with ida_ioctl.h
- AC_MSG_CHECKING(for SmartArray header directories)
+--- arrayprobe-2.0/configure.ac.orig   2006-01-03 13:58:31.000000000 +0100
++++ arrayprobe-2.0/configure.ac        2007-06-14 19:13:36.361782087 +0200
+@@ -16,13 +16,10 @@
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS([arpa/inet.h fcntl.h netdb.h netinet/in.h stdlib.h string.h sys/ioctl.h sys/socket.h sys/time.h syslog.h unistd.h])
+-dnl Check for compile.h (2.6.x kernels only?
+-AC_CHECK_HEADERS(linux/compiler.h)
+-
+ dnl Check for kernel sources
+ AC_MSG_CHECKING(for kernel sources)
  found_kernel_dir=""
 -for kernel_dir in /usr/src/linux /usr/src/linux-2.4
 +for kernel_dir in .
  do
-   if test -d $kernel_dir ; then
+   if test -d $kernel_dir/drivers/block ; then
      CFLAGS="$CFLAGS -I$kernel_dir/include -I$kernel_dir/drivers/block"
+@@ -39,8 +36,7 @@
+ dnl Check Headers
+ AC_CHECK_HEADERS(ida_ioctl.h ida_cmd.h cpqarray.h,,
+-  AC_MSG_ERROR(You need to have the complete kernel sources.),[[#include <linux/compiler.h>
+-  #include <unistd.h>]])
++  AC_MSG_ERROR(You need to have the complete kernel sources.),[[#include <unistd.h>]])
+ dnl Check version of SmartArray driver
+ AC_MSG_CHECKING(SmartArray driver version)
+@@ -49,7 +45,7 @@
+                                                                        
+ dnl Check for CCISS header file
+ AC_CHECK_HEADERS(linux/cciss_ioctl.h,,
+-  AC_MSG_ERROR(You need to have the CCISS driver in the kernel.),[[#include <linux/compiler.h>]])
++  AC_MSG_ERROR(You need to have the CCISS driver in the kernel.))
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
 diff -Nur cpqarrayd-2.2/drivers.orig/block/cpqarray.h cpqarrayd-2.2/drivers/block/cpqarray.h
 --- cpqarrayd-2.2/drivers.orig/block/cpqarray.h        1970-01-01 01:00:00.000000000 +0100
 +++ cpqarrayd-2.2/drivers/block/cpqarray.h     2005-11-17 16:51:31.000000000 +0100
@@ -625,170 +650,13 @@ diff -Nur cpqarrayd-2.2/drivers.orig/block/ida_ioctl.h cpqarrayd-2.2/drivers/blo
 +} ida_big_ioctl_t;
 +
 +#endif /* IDA_IOCTL_H */
---- arrayprobe-2.0/include/linux/compiler.h_   1970-01-01 00:00:00.000000000 +0000
-+++ arrayprobe-2.0/include/linux/compiler.h    2007-04-26 03:08:32.000000000 +0000
-@@ -0,0 +1,164 @@
-+#ifndef __LINUX_COMPILER_H
-+#define __LINUX_COMPILER_H
-+
-+#ifndef __ASSEMBLY__
-+
-+#ifdef __CHECKER__
-+# define __user               __attribute__((noderef, address_space(1)))
-+# define __kernel     /* default address space */
-+# define __safe               __attribute__((safe))
-+# define __force      __attribute__((force))
-+# define __nocast     __attribute__((nocast))
-+# define __iomem      __attribute__((noderef, address_space(2)))
-+# define __acquires(x)        __attribute__((context(x,0,1)))
-+# define __releases(x)        __attribute__((context(x,1,0)))
-+# define __acquire(x) __context__(x,1)
-+# define __release(x) __context__(x,-1)
-+# define __cond_lock(x,c)     ((c) ? ({ __acquire(x); 1; }) : 0)
-+extern void __chk_user_ptr(const void __user *);
-+extern void __chk_io_ptr(const void __iomem *);
-+#else
-+# define __user
-+# define __kernel
-+# define __safe
-+# define __force
-+# define __nocast
-+# define __iomem
-+# define __chk_user_ptr(x) (void)0
-+# define __chk_io_ptr(x) (void)0
-+# define __builtin_warning(x, y...) (1)
-+# define __acquires(x)
-+# define __releases(x)
-+# define __acquire(x) (void)0
-+# define __release(x) (void)0
-+# define __cond_lock(x,c) (c)
-+#endif
-+
-+#ifdef __KERNEL__
-+
-+#if __GNUC__ > 4
-+#error no compiler-gcc.h file for this gcc version
-+#elif __GNUC__ == 4
-+# include <linux/compiler-gcc4.h>
-+#elif __GNUC__ == 3 && __GNUC_MINOR__ >= 2
-+# include <linux/compiler-gcc3.h>
-+#else
-+# error Sorry, your compiler is too old/not recognized.
-+#endif
-+
-+/* Intel compiler defines __GNUC__. So we will overwrite implementations
-+ * coming from above header files here
-+ */
-+#ifdef __INTEL_COMPILER
-+# include <linux/compiler-intel.h>
-+#endif
-+
-+/*
-+ * Generic compiler-dependent macros required for kernel
-+ * build go below this comment. Actual compiler/compiler version
-+ * specific implementations come from the above header files
-+ */
-+
-+#define likely(x)     __builtin_expect(!!(x), 1)
-+#define unlikely(x)   __builtin_expect(!!(x), 0)
-+
-+/* Optimization barrier */
-+#ifndef barrier
-+# define barrier() __memory_barrier()
-+#endif
-+
-+#ifndef RELOC_HIDE
-+# define RELOC_HIDE(ptr, off)                                 \
-+  ({ unsigned long __ptr;                                     \
-+     __ptr = (unsigned long) (ptr);                           \
-+    (typeof(ptr)) (__ptr + (off)); })
-+#endif
-+
-+#endif /* __KERNEL__ */
-+
-+#endif /* __ASSEMBLY__ */
-+
-+#ifdef __KERNEL__
-+/*
-+ * Allow us to mark functions as 'deprecated' and have gcc emit a nice
-+ * warning for each use, in hopes of speeding the functions removal.
-+ * Usage is:
-+ *            int __deprecated foo(void)
-+ */
-+#ifndef __deprecated
-+# define __deprecated         /* unimplemented */
-+#endif
-+
-+#ifdef MODULE
-+#define __deprecated_for_modules __deprecated
-+#else
-+#define __deprecated_for_modules
-+#endif
-+
-+#ifndef __must_check
-+#define __must_check
-+#endif
-+
-+#ifndef CONFIG_ENABLE_MUST_CHECK
-+#undef __must_check
-+#define __must_check
-+#endif
-+
-+/*
-+ * Allow us to avoid 'defined but not used' warnings on functions and data,
-+ * as well as force them to be emitted to the assembly file.
-+ *
-+ * As of gcc 3.3, static functions that are not marked with attribute((used))
-+ * may be elided from the assembly file.  As of gcc 3.3, static data not so
-+ * marked will not be elided, but this may change in a future gcc version.
-+ *
-+ * In prior versions of gcc, such functions and data would be emitted, but
-+ * would be warned about except with attribute((unused)).
-+ */
-+#ifndef __attribute_used__
-+# define __attribute_used__   /* unimplemented */
-+#endif
-+
-+/*
-+ * From the GCC manual:
-+ *
-+ * Many functions have no effects except the return value and their
-+ * return value depends only on the parameters and/or global
-+ * variables.  Such a function can be subject to common subexpression
-+ * elimination and loop optimization just as an arithmetic operator
-+ * would be.
-+ * [...]
-+ */
-+#ifndef __attribute_pure__
-+# define __attribute_pure__   /* unimplemented */
-+#endif
-+
-+#ifndef noinline
-+#define noinline
-+#endif
-+
-+#ifndef __always_inline
-+#define __always_inline inline
-+#endif
-+
-+#endif /* __KERNEL__ */
-+
-+/*
-+ * From the GCC manual:
-+ *
-+ * Many functions do not examine any values except their arguments,
-+ * and have no effects except the return value.  Basically this is
-+ * just slightly more strict class than the `pure' attribute above,
-+ * since function is not allowed to read global memory.
-+ *
-+ * Note that a function that has pointer arguments and examines the
-+ * data pointed to must _not_ be declared `const'.  Likewise, a
-+ * function that calls a non-`const' function usually must not be
-+ * `const'.  It does not make sense for a `const' function to return
-+ * `void'.
-+ */
-+#ifndef __attribute_const__
-+# define __attribute_const__  /* unimplemented */
-+#endif
-+
-+#endif /* __LINUX_COMPILER_H */
+--- arrayprobe-2.0/probe.c.orig        2006-01-03 14:11:17.000000000 +0100
++++ arrayprobe-2.0/probe.c     2007-06-14 19:17:32.393571925 +0200
+@@ -33,7 +33,6 @@
+ #include <getopt.h>
+ #include <errno.h>
+-#include <linux/compiler.h>
+ #include <linux/cciss_ioctl.h>
+ #include <ida_ioctl.h>
This page took 0.079386 seconds and 4 git commands to generate.