]> git.pld-linux.org Git - packages/arpd.git/blob - arpd.spec
- better description. stb
[packages/arpd.git] / arpd.spec
1 Summary:        User-space arp daemon
2 Summary(pl):    Demon arpd
3 Name:           arpd
4 Version:        1.0.2
5 Release:        1
6 License:        GPL
7 Group:          Daemons
8 Group(pl):      Serwery
9 Group(de):      Server
10 Source0:        %{name}-%{version}.tar.gz
11 Source1:        %{name}-init
12 Patch0:         %{name}-%{version}.debian-patch
13 Patch1:         %{name}-%{version}.pld-patch
14 Patch2:         %{name}-makefile-patch
15 Prereq:         /sbin/chkconfig
16 Prereq:         rc-scripts >= 0.2.0
17 Prereq:         fileutils
18 #BuildRequires: 
19 BuildRoot:      %{tmpdir}/%{name}-%{version}.orig
20
21 %description
22 The ARP daemon moves the management of the ARP (Address Resolution
23 Protocol) table from kernel to user space.  It is useful for sites
24 with LARGE network segments (256+ systems per segment), because the
25 kernel hash tables are not optimized to handle this situation. To use
26 the ARP daemon your kernel needs to have ARPD and NETLINK support
27 enabled. The standard kernels of PLD lack this support.
28 It shouldn't be run without that!!
29
30 %description -l pl
31 Demon ARP przekazuje zarz±dzanie tablic± ARP (Address Resolution
32 Protocol) z kernel'a do przestrzeni u¿ytkownika. Jest to bardzo 
33 u¿yteczne dla miejsc o du¿ych segmentach sieci (256+ systemów na
34 segment), poniewa¿ tablice w j±drze nie s± zoptymalizowane na takie
35 sytuacje. Aby u¿ywaæ tego demona musisz mieæ ARPD support oraz
36 NETLINK support uaktywnione w j±drze. 
37 Uwaga! Stanadardowe j±dro PLD nie ma supportu ARPD!!.
38 Demon nie powinien byæ startowany bez tego!!
39
40 %prep
41 %setup  -q -n %{name}-%{version}.orig
42 %patch0 -p1
43 %patch1 -p1
44 %patch2 -p1
45
46 %build
47
48 %{__make}
49
50 %install -n -n %{name}-%{version}
51 rm -rf $RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT/{usr/sbin,etc/rc.d/init.d}
54 install arpd $RPM_BUILD_ROOT/usr/sbin/arpd
55 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/arpd
56
57 gzip -9nf CHANGES Copyright debian/*
58
59 %post
60 /sbin/chkconfig --add arpd
61 if [ ! -f /dev/arpd ]; then
62         mknod /dev/arpd c 36 8 
63 fi
64 echo "Warning!!"
65 echo "You need arpd kernel support. The standard kernels of PLD lack this support!!"
66 if [ -f /var/lock/subsys/arpd ]; then
67         /etc/rc.d/init.d/arpd restart 1>&2
68 else
69         echo "Run \"/etc/rc.d/init.d/arpd start\" to start arpd daemon."
70 fi
71
72
73 %preun
74 /sbin/chkconfig --del arpd
75 if [ "$1" = "0" ]; then
76         if [ -f /var/lock/subsys/arpd ]; then
77                 /etc/rc.d/init.d/arpd stop 1>&2
78         fi
79         /sbin/chkconfig --del arpd
80 fi
81
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc *.gz
89 %doc README.html debian/*
90 %attr(754,root,root) /usr/sbin/arpd
91 %attr(754,root,root) /etc/rc.d/init.d/arpd
This page took 0.058138 seconds and 4 git commands to generate.