]> git.pld-linux.org Git - packages/arpd.git/blob - arpd.spec
- fixed multiline strings in uid patch (needed by gcc 3.3; BTS#791)
[packages/arpd.git] / arpd.spec
1 Summary:        User-space arp daemon
2 Summary(pl):    Demon arpd
3 Name:           arpd
4 Version:        1.0.2
5 Release:        9
6 License:        GPL
7 Group:          Daemons
8 # origin, but 404
9 #Source0:       http://www.loran.com/~layes/arpd/%{name}-%{version}.tar.gz
10 # working (copy of original package):
11 #Source0:       http://www.funet.fi/pub/Linux/PEOPLE/Linus/net-source/base/%{name}-%{version}.tar.gz
12 # but in CVS we probably have some renamed source from Debian (with .orig inside)
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  4b445f5698342c873068a86a18bc3d6a
15 Source1:        %{name}-init
16 Patch0:         %{name}-%{version}.debian-patch
17 Patch1:         %{name}-%{version}.pld-patch
18 Patch2:         %{name}-makefile-patch
19 Patch3:         %{name}-more_tables.patch
20 Patch4:         %{name}-uid.patch
21 #URL:           http://www.loran.com/~layes/arpd/
22 Prereq:         fileutils
23 Prereq:         rc-scripts >= 0.2.0
24 Requires(post,preun):   /sbin/chkconfig
25 Requires:       dev >= 2.8.0-4
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The ARP daemon moves the management of the ARP (Address Resolution
30 Protocol) table from kernel to user space. It is useful for sites with
31 LARGE network segments (256+ systems per segment), because the kernel
32 hash tables are not optimized to handle this situation. To use the ARP
33 daemon your kernel needs to have ARPD and NETLINK support enabled. The
34 standard kernels of PLD lack this support. It shouldn't be run without
35 that! This version can alocate 4096 entries.
36
37 %description -l pl
38 Demon ARP przekazuje zarz±dzanie tablic± ARP (Address Resolution
39 Protocol) z kernel'a do przestrzeni u¿ytkownika. Jest to bardzo
40 u¿yteczne dla miejsc o du¿ych segmentach sieci (256+ systemów na
41 segment), poniewa¿ tablice w j±drze nie s± zoptymalizowane na takie
42 sytuacje. Aby u¿ywaæ tego demona musisz mieæ ARPD support oraz NETLINK
43 support uaktywnione w j±drze. Uwaga! Stanadardowe j±dro PLD nie ma
44 supportu ARPD. Demon nie powinien byæ startowany bez tego! Ta wersja
45 potrafi zaakceptowaæ 4096 pozycji.
46
47 %prep
48 %setup -q -n %{name}-%{version}.orig
49 %patch0 -p1
50 %patch1 -p1
51 %patch2 -p1
52 %patch3 -p0
53 %patch4 -p1
54
55 %build
56 %{__make} \
57         CC="%{__cc}" \
58         LDFLAGS="%{rpmldflags}" \
59         RPM_OPT_FLAGS="%{rpmcflags}"
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT/{usr/sbin,etc/rc.d/init.d}
64
65 install arpd $RPM_BUILD_ROOT%{_sbindir}/arpd
66 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/arpd
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post
72 /sbin/chkconfig --add arpd
73 if [ -f /var/lock/subsys/arpd ]; then
74         /etc/rc.d/init.d/arpd restart 1>&2
75 else
76         echo "Run \"/etc/rc.d/init.d/arpd start\" to start arpd daemon."
77 fi
78
79 %preun
80 if [ "$1" = "0" ]; then
81         if [ -f /var/lock/subsys/arpd ]; then
82                 /etc/rc.d/init.d/arpd stop 1>&2
83         fi
84         /sbin/chkconfig --del arpd
85 fi
86
87 %files
88 %defattr(644,root,root,755)
89 %doc CHANGES README.html
90 %attr(754,root,root) %{_sbindir}/arpd
91 %attr(754,root,root) /etc/rc.d/init.d/arpd
This page took 0.096234 seconds and 3 git commands to generate.