]> git.pld-linux.org Git - packages/arpack.git/blame - arpack.spec
- rediffed arscnd-3 patch
[packages/arpack.git] / arpack.spec
CommitLineData
e821399d
RW
1#
2# Conditional build:
3%bcond_with acml # With ACML version of BLAS instead of NETLIB implementation
5f75c7f8 4#
f36cbeb0 5%define rel 13
12aa51af 6Summary: Subroutines for solving large scale eigenvalue problems
d96d6274 7Summary(pl.UTF-8): Rozwiązywanie zagadnienia własnego dla dużych macierzy
388c4eda
JB
8Name: arpack
9Version: 2.1
d2aaeb11 10Release: %{rel}%{?with_acml:ACML}
388c4eda 11License: Freely distributable
0f2a6b97 12Group: Libraries
388c4eda 13Source0: http://www.caam.rice.edu/software/ARPACK/SRC/%{name}96.tar.gz
0f2a6b97 14# Source0-md5: fffaa970198b285676f4156cebc8626e
388c4eda 15Source1: http://www.caam.rice.edu/software/ARPACK/SRC/patch.tar.gz
0f2a6b97 16# Source1-md5: 14830d758f195f272b8594a493501fa2
bf67c3ff
RW
17Source2: http://www.caam.rice.edu/software/ARPACK/SRC/ug.ps.gz
18# Source2-md5: 79cc51e4812c75873adafcad2185842e
19Source3: http://www.caam.rice.edu/software/ARPACK/SRC/P57_58.ps.gz
20# Source3-md5: b86d77199f989fc438acaf7ac0433e76
21Source4: http://www.caam.rice.edu/software/ARPACK/SRC/P61_62.ps.gz
22# Source4-md5: d116887acb3d61fecf645c2d37d4d517
bb56de9d
JB
23# originally from http://mathema.tician.de/news.tiker.net/files/arpack-arscnd-3.patch.gz (dead now)
24Patch0: %{name}-arscnd-3.patch
a8025ed2
AM
25Patch1: %{name}-automake_support.patch
26Patch2: %{name}-no_etime.patch
0f2a6b97 27URL: http://www.caam.rice.edu/software/ARPACK/
388c4eda
JB
28BuildRequires: autoconf
29BuildRequires: automake
0f2a6b97 30BuildRequires: gcc-g77
dbbba066 31BuildRequires: libtool >= 2:1.5
0ab41560 32%{!?with_acml:BuildRequires: lapack-devel}
5f75c7f8 33%{?with_acml:ExclusiveArch: %{x8664}}
388c4eda
JB
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37ARPACK software is capable of solving large scale symmetric,
38nonsymmetric, and generalized eigenproblems from significant
39application areas. The software is designed to compute a few (k)
40eigenvalues with user specified features such as those of largest real
41part or largest magnitude. Storage requirements are on the order of
42n*k locations. No auxiliary storage is required. A set of Schur basis
43vectors for the desired k-dimensional eigen-space is computed which is
44numerically orthogonal to working precision. Numerically accurate
45eigenvectors are available on request.
46
73725317
JR
47%description -l pl.UTF-8
48Rozwiązywanie zagadnienia własnego (symetrycznego, niesymetrycznego,
49ogólnego) dla dużych macierzy. Macierz może być dowolna, przy czym
50procedury działają szczególnie dobrze w przypadku dużych macierzy
51rzadkich bądź macierzy ze znaną strukturą. Biblioteka służy do
52obliczenia kilku (k) wartości własnych o zadanych z góry własnościach,
53takich jak największa (najmniejsza) część rzeczywista albo największy
54(najmniejszy) moduł. Wymagania pamięciowe są rzędu n*k, żadna
55dodatkowa pamięć (np. dyskowa) nie jest wymagana.
388c4eda
JB
56
57%package devel
0f2a6b97 58Summary: ARPACK development files
d96d6274 59Summary(pl.UTF-8): Pliki programistyczne ARPACK
388c4eda 60Group: Development/Libraries
dbbba066 61Requires: %{name} = %{version}-%{release}
e821399d 62%{!?with_acml:Requires: blas-devel}
388c4eda
JB
63
64%description devel
0f2a6b97 65ARPACK development files.
388c4eda 66
73725317 67%description devel -l pl.UTF-8
0f2a6b97 68Pliki programistyczne ARPACK.
388c4eda
JB
69
70%package static
0f2a6b97 71Summary: Static ARPACK library
d96d6274 72Summary(pl.UTF-8): Statyczna biblioteka ARPACK
388c4eda 73Group: Development/Libraries
dbbba066 74Requires: %{name}-devel = %{version}-%{release}
388c4eda
JB
75
76%description static
0f2a6b97 77Static ARPACK library.
388c4eda 78
73725317 79%description static -l pl.UTF-8
0f2a6b97 80Statyczna biblioteka ARPACK.
388c4eda
JB
81
82%prep
3992026d 83%setup -q -n ARPACK -b1
e5c694c2 84%patch0 -p1
fb9bad1f 85%patch1 -p1
a8025ed2 86%patch2 -p1
bf67c3ff
RW
87cp %{SOURCE2} .
88cp %{SOURCE3} .
89cp %{SOURCE4} .
388c4eda
JB
90
91%build
388c4eda
JB
92%{__libtoolize}
93%{__aclocal}
94%{__autoheader}
95%{__autoconf}
96%{__automake}
0ab41560 97%configure
e821399d 98
dbbba066 99%{__make}
388c4eda
JB
100
101%install
102rm -rf $RPM_BUILD_ROOT
103
0f2a6b97
JB
104%{__make} install \
105 DESTDIR=$RPM_BUILD_ROOT
388c4eda
JB
106
107%clean
4a257fc4 108rm -rf $RPM_BUILD_ROOT
388c4eda
JB
109
110%post -p /sbin/ldconfig
111%postun -p /sbin/ldconfig
112
113%files
114%defattr(644,root,root,755)
115%doc README
116%attr(755,root,root) %{_libdir}/libarpack.so.*.*.*
3a060c33 117%attr(755,root,root) %ghost %{_libdir}/libarpack.so.2
388c4eda
JB
118
119%files devel
120%defattr(644,root,root,755)
bf67c3ff 121%doc DOCUMENTS/*.doc *.ps.gz
c8932703 122%attr(755,root,root) %{_libdir}/libarpack.so
388c4eda
JB
123%{_libdir}/libarpack.la
124
125%files static
126%defattr(644,root,root,755)
127%{_libdir}/libarpack.a
This page took 0.174188 seconds and 4 git commands to generate.