]> git.pld-linux.org Git - packages/arnold.git/commitdiff
- added build patch, fixed build master auto/th/arnold-0.20020127-2
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 7 Mar 2017 20:11:51 +0000 (21:11 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 7 Mar 2017 20:11:51 +0000 (21:11 +0100)
- release 2

arnold-build.patch [new file with mode: 0644]
arnold.spec

diff --git a/arnold-build.patch b/arnold-build.patch
new file mode 100644 (file)
index 0000000..f65a25c
--- /dev/null
@@ -0,0 +1,47 @@
+--- arnold/src/cpc/debugger/debug.c.orig       2001-10-14 10:50:08.000000000 +0200
++++ arnold/src/cpc/debugger/debug.c    2017-03-07 19:46:32.700601403 +0100
+@@ -80,7 +80,7 @@ void Debug_WriteString(DEBUG_HANDLE Debu
+               return;
+       if (pDebugStruct->fh!=NULL)
+-              fprintf(pDebugStruct->fh,Message);
++              fprintf(pDebugStruct->fh, "%s", Message);
+ }
+ void  Debug_End(DEBUG_HANDLE  DebugHandle)
+--- arnold/src/cpc/debugger/gdebug.c.orig      2001-10-14 10:50:10.000000000 +0200
++++ arnold/src/cpc/debugger/gdebug.c   2017-03-07 19:46:58.717267772 +0100
+@@ -1656,7 +1656,7 @@ void     Debug_DissassembleInstruction(int A
+                                                               /* 11101001 - JP (HL) */
+                                                               /* 11111001 - LD SP,HL */
+-                                                              sprintf(OutputString,
++                                                              sprintf(OutputString, "%s",
+                                                                       MiscMneumonics3[((Opcode>>4) & 0x03)]);
+                                                       }
+                                               }
+--- arnold/src/cpc/tzx.c.orig  2001-10-21 09:43:06.000000000 +0200
++++ arnold/src/cpc/tzx.c       2017-03-07 19:45:56.430601816 +0100
+@@ -57,7 +57,7 @@ static unsigned long TapeImage_Flags;
+ static unsigned char *pTapeBlockPtr = NULL;
+ static void   TapeImage_GetNextDataBlock(void);
+-int           TapeImage_GetBlockLength(unsigned char *pBlock);
++static int    TapeImage_GetBlockLength(unsigned char *pBlock);
+ static void   TapeImage_HandleBlock(unsigned char *);
\r
\r
+--- arnold/src/Makefile.in.orig        2002-01-19 15:49:14.000000000 +0100
++++ arnold/src/Makefile.in     2017-03-07 19:47:31.387267400 +0100
+@@ -27,9 +27,9 @@ SDLLIB = @SDL_LIBS@
+ #-Wall for max warnings!
+ CFLAGS = @CPPFLAGS@ @CFLAGS@ $(GTKINC) $(SDLINC) @DEFS@ $(X11INC) -I. -DUNIX -Wall -Wno-unused
+ #-g3 -pg -dm -dp -a
+-LFLAGS1 = @LDFLAGS@ @LIBS@ $(GTKLIB) $(SDLLIB) $(X11LIBS)
++LFLAGS1 = @LDFLAGS@ @LIBS@
+ #debug
+-LFLAGS2 = -s 
++LFLAGS2 = $(GTKLIB) $(SDLLIB) $(X11LIBS)
+ #LFLAGS2= -g3 -pg -dm -dp -a
+ #normal
+ #LFLAGS2 = -s
index 2a93030f61acd012fd554ff9d5d30704ae0e997e..a800030db19e533bea3dffb1baf2740bfa3efd1a 100644 (file)
@@ -1,15 +1,19 @@
+# note: 20040104 release is on DEVEL branch, but its unix port is heavily broken; stick to 20020127
 Summary:       Amstrad CPC Emulator
 Summary(pl.UTF-8):     Emulator Amstrada CPC
 Name:          arnold
 Version:       0.20020127
-Release:       1
-License:       GPL (except ROMs)
-Group:         Applications
+Release:       2
+License:       GPL v2+ (except ROMs)
+Group:         Applications/Emulators
 Source0:       http://arnold.emuunlim.com/download/arnsrc27012002.zip
 # Source0-md5: a8ae9ce1aeeae6ba9a19083731811150
 Patch0:                %{name}-romsdir.patch
+Patch1:                %{name}-build.patch
 URL:           http://arnold.emuunlim.com/
 BuildRequires: SDL-devel >= 1.2.0
+BuildRequires: autoconf
+BuildRequires: automake
 BuildRequires: gtk+-devel >= 1.2.0
 BuildRequires: unzip
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -32,11 +36,16 @@ Amstrad plc.
 %prep
 %setup -q -n %{name}
 %patch0 -p1
+%patch1 -p1
+
+%{__rm} src/configure
 
 %build
 cd src
-chmod a+x configure
-%configure2_13
+%{__aclocal}
+%{__autoconf}
+%configure
+
 %{__make}
 
 %install
@@ -52,5 +61,5 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc bugsetc.txt file_id.diz readme.* whatsnew.*
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/arnold
 %{_datadir}/arnold
This page took 0.098951 seconds and 4 git commands to generate.