]> git.pld-linux.org Git - packages/armagetron.git/blob - armagetron.spec
- massive change ( validate errors warrings from desktop-file-validate)
[packages/armagetron.git] / armagetron.spec
1 #
2 # TODO: start scripts for server
3 Summary:        A Tron lightcycle game with focus on multiplayer mode
4 Summary(pl.UTF-8):      Gra Tron ze światłocyklem skupiająca się na trybie dla wielu graczy
5 Name:           armagetron
6 Version:        0.2.6.1
7 Release:        1
8 License:        GPL
9 Group:          X11/Applications/Games
10 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
11 # Source0-md5:  20c670d6e2bdcae2a3e52a3fab2788b7
12 Source1:        %{name}.desktop
13 Source2:        %{name}.png
14 Source3:        http://armagetron.sourceforge.net/addons/moviepack.zip
15 # Source3-md5:  e2d40309dde7e1339ca6aff7599cdfa3
16 Patch0:         %{name}-types.patch
17 URL:            http://armagetron.sourceforge.net/
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  SDL_image-devel
20 BuildRequires:  SDL_mixer-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  sed >= 4.0
24 BuildRequires:  unzip
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 # it installs data in %{_prefix}/games, so...
28 %define         _bindir                 /usr/bin
29 %define         _prefix                 /usr/%{_lib}
30 %define         _sysconfdir             /etc/%{name}
31 %define         _sysconfdir_server      /etc/%{name}-server
32
33 %description
34 In Armagetron, you ride a lightcycle around the game grid. You can
35 only make sharp turns of 90 degrees and a wall constantly builds up
36 after you. Make your enemies crash into your wall, but be aware that
37 they are trying to do the same to you. If you are fast enough, you may
38 be able to trap them, but the only way to speed up your lightcycle is
39 to drive close to the dangerous walls. Prepare for exciting strategic
40 preparations followed by action-packed close combat!
41
42 %description -l pl.UTF-8
43 W grze Armagetron jedzie się światłocyklem dookoła planszy. Można
44 wykonywać tylko ostre zakręty o 90 stopni, a za graczem ciągle buduje
45 się ściana. Trzeba spowodować, by wrogowie roztrzaskali się na tej
46 ścianie, ale także uważać, bo oni próbują zrobić to samo. Jeśli gracz
47 jest szybki, może złapać ich wszystkich, ale jedynym sposobem na
48 przyspieszenie światłocyklu jest jazda blisko niebezpiecznych ścian.
49 Trzeba się przygotować na ekscytujące strategiczne przygotowania i
50 następującą po nich walkę w zbliżeniu!
51
52 %package moviepack
53 Summary:        Moviepack addon
54 Summary(pl.UTF-8):      Dodatek Moviepack
55 Group:          X11/Applications/Games
56 Requires:       %{name} = %{version}-%{release}
57
58 %description moviepack
59 Moviepack addon.
60
61 %description moviepack -l pl.UTF-8
62 Dodatek Moviepack.
63
64 %package server
65 Summary:        Armagetron server
66 Summary(pl.UTF-8):      Serwer Armagetrona
67 Group:          Applications/Games
68
69 %description server
70 Armagetron server.
71
72 %description server -l pl.UTF-8
73 Serwer Armagetrona.
74
75 %prep
76 %setup -q -a3
77 %patch0 -p1
78
79 sed -i -e 's@/usr/lib@/usr/%{_lib}@;s@X11R6/lib@X11R6/%{_lib}@' configure.in
80
81 %build
82 cp -f /usr/share/automake/config.sub .
83 %{__aclocal}
84 %{__autoconf}
85
86 %configure \
87         --disable-glout 
88
89 %{__make} bindist
90 mv bindist bindist-dedicated
91 sed -i 's@\/etc\/armagetron@\/etc\/armagetron-server@' bindist-dedicated/bin/starter
92
93 %configure
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_bindir}} \
99         $RPM_BUILD_ROOT%{_prefix}/games/%{name}/moviepack \
100         $RPM_BUILD_ROOT%{_sysconfdir_server}
101
102 %{__make} install
103
104 cd bindist-dedicated
105 ./install
106 cd ..
107
108 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/* $RPM_BUILD_ROOT%{_bindir}
109
110 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
111 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
112
113 cp $RPM_BUILD_ROOT%{_sysconfdir}/* $RPM_BUILD_ROOT%{_sysconfdir_server}
114 cp -R moviepack $RPM_BUILD_ROOT%{_prefix}/games/%{name}
115 rm -f $RPM_BUILD_ROOT%{_prefix}/games/%{name}/moviepack/art_read_me.txt
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %doc CHANGELOG doc/*.html doc/net
123 %dir %{_sysconfdir}
124 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.cfg
125 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.srv
126 %attr(755,root,root) %{_bindir}/%{name}
127 %attr(755,root,root) %{_bindir}/%{name}-stat
128 %dir %{_prefix}/games/%{name}
129 %{_prefix}/games/%{name}/arenas
130 %dir %{_prefix}/games/%{name}/bin
131 %attr(755,root,root) %{_prefix}/games/%{name}/bin/[ap]*
132 %dir %{_prefix}/games/%{name}/language
133 %{_prefix}/games/%{name}/language/languages.txt
134 %{_prefix}/games/%{name}/language/english.txt
135 %lang(de) %{_prefix}/games/%{name}/language/deutsch.txt
136 %{_prefix}/games/%{name}/models
137 %{_prefix}/games/%{name}/sound
138 %{_prefix}/games/%{name}/textures
139 %{_desktopdir}/*.desktop
140 %{_pixmapsdir}/*
141
142 %files moviepack
143 %defattr(644,root,root,755)
144 %doc moviepack/art_read_me.txt
145 %{_prefix}/games/%{name}/moviepack
146
147 %files server 
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_bindir}/armagetron-dedicated
150 %dir %{_prefix}/games/armagetron-dedicated
151 %{_prefix}/games/armagetron-dedicated/bin
152 %attr(755,root,root) %{_prefix}/games/armagetron-dedicated/bin/*
153 %exclude %{_prefix}/games/armagetron-dedicated/bin/uninstall
154 %{_prefix}/games/armagetron-dedicated/language
155 %dir %{_sysconfdir_server}
156 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir_server}/*.cfg
157 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir_server}/*.srv
This page took 0.064047 seconds and 3 git commands to generate.