]> git.pld-linux.org Git - packages/arj.git/blame_incremental - arj.spec
Add patch to fix build with -Werror=format-security
[packages/arj.git] / arj.spec
... / ...
CommitLineData
1Summary: ARJ archiver for Linux
2Summary(pl.UTF-8): Archiwizator ARJ dla Linuksa
3Name: arj
4Version: 3.10.22
5Release: 4
6Epoch: 1
7License: GPL
8Group: Applications/Archiving
9Source0: http://testcase.newmail.ru/files/%{name}-%{version}.tar.gz
10# Source0-md5: f263bf3cf6d42a8b7e85b4fb514336d3
11Patch0: strnlen.patch
12Patch1: %{name}-glibc.patch
13Patch2: %{name}-format-security.patch
14BuildRequires: autoconf
15BuildRequires: automake
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18# main executable cannot be stripped (doesn't work then)
19%define no_install_post_strip 1
20%define specflags -fno-unit-at-a-time
21
22%description
23This product is an implementation of ARJ v 2.7x for DOS on UNIX and
24UNIX-like systems. It is assumed that the user is familiar with ARJ
25operation on DOS before using this package.
26
27%description -l pl.UTF-8
28Jest to implementacja programu ARJ v 2.7x dla DOS na platformę UNIX i
29systemy uniksopodobne. Zakłada się, że użytkownik korzystający z tego
30pakietu zna sposób funkcjonowania programu ARJ pod DOS-em.
31
32%prep
33%setup -q
34%patch0 -p1
35%patch1 -p1
36%patch2 -p1
37
38%build
39cd gnu
40%{__autoconf}
41install /usr/share/automake/config.* .
42
43%configure
44cd ..
45%{__make} -j1 \
46 CC="%{__cc}"
47
48%install
49rm -rf $RPM_BUILD_ROOT
50install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}}
51
52cd linux-gnu/en/rs
53install \
54 arj/arj \
55 arjdisp/arjdisp \
56 rearj/rearj \
57 $RPM_BUILD_ROOT%{_bindir}
58install register/arj-register $RPM_BUILD_ROOT%{_bindir}/arj-register
59
60install arjcrypt/arjcrypt.so $RPM_BUILD_ROOT%{_libdir}
61
62%{!?debug:strip -R .comment -R .note $RPM_BUILD_ROOT%{_bindir}/{arjdisp,rearj,arj-register}}
63%{!?debug:strip --strip-unneeded -R .comment -R .note $RPM_BUILD_ROOT%{_libdir}/*.so}
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(644,root,root,755)
70%doc ChangeLog doc/rev_hist.txt resource/en/arjl.txt resource/en/readme.txt resource/en/unix.txt
71%attr(755,root,root) %{_bindir}/*
72%attr(755,root,root) %{_libdir}/*.so
This page took 0.077145 seconds and 4 git commands to generate.