]> git.pld-linux.org Git - packages/argus-clients.git/blame - argus-clients.spec
- logrotate 3.8.0 requires "su" option for non-root writable dirs
[packages/argus-clients.git] / argus-clients.spec
CommitLineData
d31e0d15 1#
2# Conditional build:
3%bcond_without sasl # build with sasl support
4#
5%define _ver_major 3.0
6%define _ver_minor 0
3c00c4de 7%define _rc rc.43
d31e0d15 8%define _rel 0.1
a3a0742a
JB
9Summary: Real time network flow monitor - client applications
10Summary(pl.UTF-8): Monitor obciążenia sieci czasu rzeczywistego - programy klienckie
d31e0d15 11Name: argus-clients
12Version: %{_ver_major}.%{_ver_minor}
13Release: 0.%{_rc}.%{_rel}
14License: GPL v2
15Group: Applications/Networking
16Source0: ftp://qosient.com/dev/argus-%{_ver_major}/%{name}-%{version}.%{_rc}.tar.gz
3c00c4de 17# Source0-md5: d85d5546cdf527f096c367afffd8f334
d31e0d15 18Source1: %{name}-excel.rc
19Source2: %{name}-racluster.conf
20Source3: %{name}-radium.conf
21Source4: %{name}-radium.init
22Source5: %{name}-radium.sysconfig
23Source6: %{name}-radium.logrotate
24Source7: %{name}-ranonymize.conf
25Source8: %{name}-ra.print.all.conf
26Source9: %{name}-rarc
eff76aa1 27Patch0: %{name}-ragraph-rabins-paths.patch
3c00c4de 28Patch1: %{name}-ratop-ncurses.patch
29Patch2: %{name}-configure-ncurses.patch
d31e0d15 30URL: http://www.qosient.com/argus/
31BuildRequires: bison
32%{?with_sasl:BuildRequires: cyrus-sasl-devel}
33BuildRequires: flex
34BuildRequires: rpmbuild(macros) >= 1.268
35Requires(post,preun): /sbin/chkconfig
85654b18 36Requires: perl-rrdtool
d31e0d15 37Requires: rc-scripts
38Provides: group(argus)
39Provides: user(argus)
2cae06d7 40Conflicts: logrotate < 3.8.0
d31e0d15 41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%description
44Argus is a Real Time Flow Monitor designed to track and report on the
45status and performance of all network transactions seen in a data
46network traffic stream. It is similiar to Cisco NetFlow, however more
47powerful and with different data format.
48
49This package provides variuos methods to process and present the data.
50
51%description -l pl.UTF-8
52Argus jest monitorem sieci czasu rzeczywistego zaprojektowanym do
53śledzenia i raportowania stanu sieci oraz wszelkiego typu transakcji
a3a0742a
JB
54sieciowych widzianych w strumieniu danych. Jest bardzo podobny do
55NetFlow z Cisco, jednak bardziej rozbudowany i posiada inny format
56danych.
d31e0d15 57
da88597f 58Ta paczka dostarcza różne metody do przetwarzania i prezentowania
d31e0d15 59danych.
60
61%prep
62%setup -q -n %{name}-%{version}.%{_rc}
eff76aa1 63%patch0
3c00c4de 64%patch1
65%patch2
d31e0d15 66
67%build
68%configure \
69 --with%{!?with_sasl:out}-sasl
70%{__make}
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
75install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
76install -d $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig}
77install -d $RPM_BUILD_ROOT%{_var}/log/%{name}
78
79install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/excel.rc
80install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/racluster.conf
81install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/radium.conf
82install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/randomize.conf
83install %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/ra.print.all.conf
84install %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/rarc
85
86install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/radium
87install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/radium
88install %{SOURCE6} $RPM_BUILD_ROOT/etc/logrotate.d/radium
89
90touch $RPM_BUILD_ROOT%{_var}/log/%{name}/radium.log
91
92%{__make} install \
93 DESTDIR=$RPM_BUILD_ROOT
94
95# same file is in argus.spec
96mv $RPM_BUILD_ROOT%{_bindir}/argusbug $RPM_BUILD_ROOT%{_bindir}/argusbug-clients
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%pre
102%groupadd -g 214 argus
103%useradd -u 214 -d /usr/share/empty -s /bin/sh -g argus -c "argus daemon" argus
104
105%post
106/sbin/chkconfig --add radium
107%service radium restart
108
109%preun
110if [ "$1" = "0" ]; then
111 %service -q radium stop
112 /sbin/chkconfig --del radium
113fi
114
115%files
116%defattr(644,root,root,755)
117%doc CREDITS ChangeLog README doc/{CHANGES,FAQ,HOW-TO}
118%attr(755,root,root) %{_bindir}/argusbug-clients
119%attr(755,root,root) %{_bindir}/ra
120%attr(755,root,root) %{_bindir}/rabins
121%attr(755,root,root) %{_bindir}/racluster
122%attr(755,root,root) %{_bindir}/racount
3c00c4de 123%attr(755,root,root) %{_bindir}/radump
d31e0d15 124%attr(755,root,root) %{_bindir}/ragraph
125%attr(755,root,root) %{_bindir}/ragrep
126%attr(755,root,root) %{_bindir}/rahisto
3c00c4de 127%attr(755,root,root) %{_bindir}/ramatrix
d31e0d15 128%attr(755,root,root) %{_bindir}/ranonymize
129%attr(755,root,root) %{_bindir}/rapath
130%attr(755,root,root) %{_bindir}/rapolicy
131%attr(755,root,root) %{_bindir}/rasort
132%attr(755,root,root) %{_bindir}/rasplit
133%attr(755,root,root) %{_bindir}/rastrip
134%attr(755,root,root) %{_bindir}/ratemplate
135%attr(755,root,root) %{_bindir}/ratop
136%attr(755,root,root) %{_sbindir}/radium
137%attr(754,root,root) /etc/rc.d/init.d/radium
138%dir %{_sysconfdir}/%{name}
139%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/excel.rc
140%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/racluster.conf
141%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/radium.conf
142%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/randomize.conf
143%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ra.print.all.conf
144%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/rarc
145%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/radium
6baa0db5 146%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/radium
62b74fbe
ER
147%{_mandir}/man1/ra.1*
148%{_mandir}/man1/rabins.1*
149%{_mandir}/man1/racluster.1*
150%{_mandir}/man1/racount.1*
151%{_mandir}/man1/ragraph.1*
152%{_mandir}/man1/ragrep.1*
153%{_mandir}/man1/rahisto.1*
154%{_mandir}/man1/rasort.1*
155%{_mandir}/man1/rasplit.1*
156%{_mandir}/man1/rastrip.1*
157%{_mandir}/man5/racluster.5*
158%{_mandir}/man5/radium.conf.5*
159%{_mandir}/man5/rarc.5*
160%{_mandir}/man8/radium.8*
d31e0d15 161%attr(770,root,argus) %dir %{_var}/log/%{name}
162%attr(660,root,argus) %ghost %{_var}/log/%{name}/radium.log
This page took 0.511093 seconds and 4 git commands to generate.