]> git.pld-linux.org Git - packages/aravis.git/blob - aravis.spec
- updated to 0.8.2
[packages/aravis.git] / aravis.spec
1 #
2 # Conditional build:
3 %bcond_without  gui             # Viewer application
4 %bcond_without  gstreamer       # GStreamer plugin
5
6 Summary:        Aravis digital video camera acquisition library
7 Summary(pl.UTF-8):      Aravis - biblioteka do pobierania obrazu z kamer cyfrowych
8 Name:           aravis
9 Version:        0.8.2
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/aravis/0.8/%{name}-%{version}.tar.xz
14 # Source0-md5:  9902058162bfffe810cccfb1286dc1fd
15 URL:            https://wiki.gnome.org/Projects/Aravis
16 BuildRequires:  appstream-glib
17 BuildRequires:  audit-libs-devel
18 BuildRequires:  gettext-tools
19 BuildRequires:  glib2-devel >= 1:2.44
20 BuildRequires:  gobject-introspection-devel >= 0.10.0
21 %if %{with gstreamer} || %{with gui}
22 BuildRequires:  gstreamer-devel >= 1.0
23 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
24 %endif
25 %{?with_gui:BuildRequires:      gtk+3-devel >= 3.14.0}
26 BuildRequires:  gtk-doc >= 1.14
27 %{?with_gui:BuildRequires:      libnotify-devel}
28 BuildRequires:  libusb-devel >= 1.0
29 BuildRequires:  libxml2-devel >= 2.0
30 BuildRequires:  libxslt-progs
31 BuildRequires:  meson >= 0.47.0
32 BuildRequires:  ninja >= 1.5
33 BuildRequires:  pkgconfig >= 1:0.14
34 BuildRequires:  rpmbuild(macros) >= 1.736
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 BuildRequires:  zlib-devel
38 Requires:       glib2 >= 1:2.44
39 Requires:       gtk+3 >= 3.14.0
40 Obsoletes:      gstreamer0.10-aravis < 0.7
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Aravis is a GLib/GObject based library for video acquisition using
45 Genicam cameras. It currently only implements an Ethernet camera
46 protocol used for industrial cameras.
47
48 %description -l pl.UTF-8
49 Aravis to oparta na GLib/GObject biblioteka do pobierania obrazu przy
50 użyciu kamer Genicam. Obecnie ma zaimplementowany tylko protokół kamer
51 ethernetowych używany przez kamery przemysłowe.
52
53 %package viewer
54 Summary:        Simple viewer of video stream acquired using Aravis
55 Summary(pl.UTF-8):      Prosta przeglądarka strumienia obrazu pobranego przy użyciu biblioteki Aravis
56 Group:          X11/Applications/Graphics
57 Requires:       %{name} = %{version}-%{release}
58 Requires(post,postun):  gtk-update-icon-cache
59 Requires:       hicolor-icon-theme
60
61 %description viewer
62 Aravis Viewer is a simple viewer used to display video streams from
63 GENICAM-based Ethernet industrial cameras.
64
65 %description viewer -l pl.UTF-8
66 Aravis Viewer to prosta przeglądarka do wyświetlania strumieni obrazu
67 pobranych z ethernetowych kamer przemysłowych opartych na GENICAM.
68
69 %package devel
70 Summary:        Header files for Aravis library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Aravis
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       glib2-devel >= 1:2.44
75 Requires:       libxml2-devel >= 2.0
76 Requires:       zlib-devel
77
78 %description devel
79 Header files for Aravis library.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe biblioteki Aravis.
83
84 %package static
85 Summary:        Static Aravis library
86 Summary(pl.UTF-8):      Statyczna biblioteka Aravis
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 Static Aravis library.
92
93 %description static -l pl.UTF-8
94 Statyczna biblioteka Aravis.
95
96 %package apidocs
97 Summary:        API documentation for Aravis library
98 Summary(pl.UTF-8):      Dokumentacja API biblioteki Aravis
99 Group:          Documentation
100 Requires:       gtk-doc-common
101 %if "%{_rpmversion}" >= "4.6"
102 BuildArch:      noarch
103 %endif
104
105 %description apidocs
106 API documentation for Aravis library.
107
108 %description apidocs -l pl.UTF-8
109 Dokumentacja API biblioteki Aravis.
110
111 %package -n gstreamer-aravis
112 Summary:        GStreamer plugin for Aravis digital video camera acquisition library
113 Summary(pl.UTF-8):      Wtyczka GStreamera do biblioteki pobierania obrazu z kamer cyfrowych Aravis
114 Group:          Libraries
115 Requires:       %{name} = %{version}-%{release}
116 Requires:       gstreamer >= 1.0
117 Requires:       gstreamer-plugins-base >= 1.0
118
119 %description -n gstreamer-aravis
120 GStreamer plugin for Aravis digital video camera acquisition
121 library.
122
123 %description -n gstreamer-aravis -l pl.UTF-8
124 Wtyczka GStreamera do biblioteki pobierania obrazu z kamer cyfrowych
125 Aravis.
126
127 %prep
128 %setup -q
129
130 %build
131 %meson build \
132         %{!?with_gstreamer:-Dgst-plugin=disabled} \
133         %{!?with_gui:-Dviewer=disabled}
134
135 %ninja_build -C build
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 %ninja_install -C build
141
142 %find_lang %{name}-0.8
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %post   viewer
151 %update_icon_cache hicolor
152
153 %postun viewer
154 %update_icon_cache hicolor
155
156 %files -f %{name}-0.8.lang
157 %defattr(644,root,root,755)
158 %doc AUTHORS NEWS.md README.md
159 %attr(755,root,root) %{_bindir}/arv-fake-gv-camera-0.8
160 %attr(755,root,root) %{_bindir}/arv-tool-0.8
161 %attr(755,root,root) %{_libdir}/libaravis-0.8.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libaravis-0.8.so.0
163 %{_libdir}/girepository-1.0/Aravis-0.8.typelib
164 %{_mandir}/man1/arv-tool-0.8.1*
165
166 %if %{with gui}
167 %files viewer
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_bindir}/arv-viewer-0.8
170 %{_datadir}/aravis-0.8
171 %{_datadir}/metainfo/arv-viewer-0.8.appdata.xml
172 %{_desktopdir}/arv-viewer-0.8.desktop
173 %{_iconsdir}/hicolor/*x*/apps/aravis-0.8.png
174 %{_mandir}/man1/arv-viewer-0.8.1*
175 %endif
176
177 %files devel
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/libaravis-0.8.so
180 %{_includedir}/aravis-0.8
181 %{_datadir}/gir-1.0/Aravis-0.8.gir
182 %{_pkgconfigdir}/aravis-0.8.pc
183
184 %files static
185 %defattr(644,root,root,755)
186 %{_libdir}/libaravis-0.8.a
187
188 %files apidocs
189 %defattr(644,root,root,755)
190 %{_gtkdocdir}/aravis-0.8
191
192 %if %{with gstreamer}
193 %files -n gstreamer-aravis
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstaravis.0.8.so
196 %endif
This page took 0.045588 seconds and 3 git commands to generate.