]> git.pld-linux.org Git - packages/aqsis.git/blob - aqsis.spec
- Fixed build
[packages/aqsis.git] / aqsis.spec
1 # TODO:
2 # - Check that everything works as expected.
3 # - Remove duplications in %files section.
4 # - Proper configuration files handling by SPEC.
5 # - Fix paths in configuration file.
6 Summary:        Aqsis Rendering System
7 Summary(pl.UTF-8):      System Renderujący Aqsis
8 Name:           aqsis
9 Version:        1.2.0
10 Release:        0.2
11 License:        GPL v2 / LGPL v2.1
12 Group:          Applications/Graphics
13 Source0:        http://dl.sourceforge.net/aqsis/%{name}-%{version}.tar.gz
14 # Source0-md5:  ae9bb1c4b22e396fd7ce84ee3e13cb86
15 Patch0:         %{name}-scons-paths.patch
16 URL:            http://aqsis.sourceforge.net/
17 BuildRequires:  OpenEXR-devel
18 BuildRequires:  bison >= 1.35
19 BuildRequires:  boost-devel >= 1.32.0
20 BuildRequires:  flex >= 2.5.4
21 BuildRequires:  fltk-devel >= 1.1.0
22 BuildRequires:  libjpeg-devel >= 6b
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtiff-devel >= 3.7.1
25 BuildRequires:  libtool >= 2:1.5
26 BuildRequires:  libxslt-progs
27 BuildRequires:  rpmbuild(macros) >= 1.337
28 BuildRequires:  scons
29 BuildRequires:  zlib-devel >= 1.1.4
30 Provides:       renderman-engine
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 The Aqsis Rendering System consists of a set of libraries and
35 applications for creating high-quality computer imagery using the
36 Pixar RenderMan Interface.
37
38 %description -l pl.UTF-8
39 System Renderujący Aqsis składa się z zestawu bibliotek i programów
40 do tworzenia wysokiej jakości obrazów komputerowych z użyciem
41 interfejsu RenderMan firmy Pixar.
42
43 %package devel
44 Summary:        Header files for Aqsis Rendering System
45 Summary(pl.UTF-8):      Pliki nagłówkowe Systemu Renderującego Aqsis
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       libstdc++-devel
49 Requires:       libtiff-devel
50 Requires:       log4cpp-devel
51 Requires:       zlib-devel
52
53 %description devel
54 Header files for Aqsis Rendering System.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe Systemu Renderującego Aqsis.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62
63 %build
64 # We cannot build the targets here, because 'scons install' fires the entire
65 # compilation from the start.
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{/etc/%{name},%{name},%{_bindir},%{_libdir},%{_datadir}/%{name}}
70
71 # @LIBDIR@, @SHAREDIR@ and @CONFDIR@ comes from the aqsis-scons-paths patch
72 sed -e 's:@LIBDIR@:%{_libdir}:g' -i SConstruct
73 sed -e 's:@SHAREDIR@:%{_datadir}/%{name}:g' \
74     -e 's:@CONFDIR@:/etc/%{name}:g' \
75     -i platform/default/SConscript
76
77 export CXX='%{__cxx}'
78 export CXXFLAGS='%{rpmcflags}'
79 export CC='%{__cc}'
80 export CFLAGS='%{rpmcflags}'
81 %scons \
82         install_prefix=$RPM_BUILD_ROOT%{_prefix} \
83         sysconfdir=$RPM_BUILD_ROOT/etc/%{name} \
84         install
85 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS ReleaseNotes README
96 /etc/%{name}
97 %attr(755,root,root) %{_bindir}/*
98 %attr(755,root,root) %{_libdir}/lib*.so*
99 %dir %{_libdir}/%{name}
100 %attr(755,root,root) %{_libdir}/%{name}/*.so
101 %dir %{_libdir}/%{name}/plugins
102 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
103 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
104 %{_datadir}/%{name}
105
106 %files devel
107 %defattr(644,root,root,755)
108 #%attr(755,root,root) %{_libdir}/lib*.so
109 #%{_libdir}/lib*.la
110 %{_includedir}/%{name}
This page took 0.033562 seconds and 3 git commands to generate.