]> git.pld-linux.org Git - packages/aqsis.git/blob - aqsis.spec
6f017162b82c2420b11f29970edfce1ce4f99a7e
[packages/aqsis.git] / aqsis.spec
1 # TODO:
2 # - Check to see if splitting plugins into several packages makes any sense
3 #   (probably not).
4 # - Check that everything works as expected.
5 # - Remove duplications in %files section.
6 # - Fix aqsis-scons-paths.patch so modyfing it after sysconfdir change will
7 #   not be needed.
8 # - Check why the second stage of compilation ignores CXX and CXXFLAGS and
9 #   fix it of course :)
10 # - Proper configuration files handling by SPEC.
11 # - Fix paths in configuration file.
12 Summary:        Aqsis Rendering System
13 Summary(pl.UTF-8):      System Renderujący Aqsis
14 Name:           aqsis
15 Version:        1.2.0
16 Release:        0.1
17 License:        GPL v2 / LGPL v2.1
18 Group:          Applications/Graphics
19 Source0:        http://dl.sourceforge.net/aqsis/%{name}-%{version}.tar.gz
20 # Source0-md5:  ae9bb1c4b22e396fd7ce84ee3e13cb86
21 Patch0:         aqsis-scons-paths.patch
22 URL:            http://aqsis.sourceforge.net/
23 BuildRequires:  OpenEXR-devel
24 BuildRequires:  bison >= 1.35
25 BuildRequires:  boost-devel >= 1.32.0
26 BuildRequires:  flex >= 2.5.4
27 BuildRequires:  fltk-devel >= 1.1.0
28 BuildRequires:  libjpeg-devel >= 6b
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtiff-devel >= 3.7.1
31 BuildRequires:  libtool >= 2:1.5
32 BuildRequires:  libxslt-progs
33 BuildRequires:  zlib-devel >= 1.1.4
34 Provides:       renderman-engine
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 The Aqsis Rendering System consists of a set of libraries and
39 applications for creating high-quality computer imagery using the
40 Pixar RenderMan Interface.
41
42 %description -l pl.UTF-8
43 System renderujący Aqsis składa się z zestawu bibliotek i programów do
44 tworzenia wysokiej jakości obrazów komputerowych z użyciem interfejsu
45 RenderMan firmy Pixar.
46
47 %package devel
48 Summary:        Header files for Aqsis Rendering System
49 Summary(pl.UTF-8):      Pliki nagłówkowe Systemu Renderującego Aqsis
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       libstdc++-devel
53 Requires:       libtiff-devel
54 Requires:       log4cpp-devel
55 Requires:       zlib-devel
56
57 %description devel
58 Header files for Aqsis Rendering System.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe systemu renderującego Aqsis.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66
67 %build
68 export CXX='%{__cxx}'
69 export CXXFLAGS='%{rpmcflags}'
70 export CC='%{__cc}'
71 export CFLAGS='%{rpmcflags}'
72 # WARNING! If you'll change the sysconfdir argument below, remember to
73 # make apriopriate change in aqsis-scons-paths.patch!
74 %{scons} \
75         install_prefix="$RPM_BUILD_ROOT%{_prefix}" \
76         sysconfdir="$RPM_BUILD_ROOT/etc/%{name}"
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT{/etc/%{name},%{name},%{_bindir},%{_libdir},%{_datadir}/%{name}}
81
82 %{scons} install_prefix="$RPM_BUILD_ROOT%{_prefix}" install
83 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
84 #mv $RPM_BUILD_ROOT%{_usr}/etc $RPM_BUILD_ROOT
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post   -p /sbin/ldconfig
90 %postun -p /sbin/ldconfig
91
92 %files
93 %defattr(644,root,root,755)
94 %doc AUTHORS ReleaseNotes README
95 %attr(755,root,root) %{_bindir}/*
96 %attr(755,root,root) %{_libdir}/lib*.so*
97 %dir %{_libdir}/%{name}/
98 %attr(755,root,root) %{_libdir}/%{name}/*.so
99 %dir %{_libdir}/%{name}/plugins/
100 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
101 %{_libdir}/%{name}/lib*.so*
102 %{_datadir}/%{name}
103 /etc/%{name}
104
105 %files devel
106 %defattr(644,root,root,755)
107 #%attr(755,root,root) %{_libdir}/lib*.so
108 #%{_libdir}/lib*.la
109 %{_includedir}/%{name}
This page took 0.069074 seconds and 2 git commands to generate.