]> git.pld-linux.org Git - packages/aqsis.git/blob - aqsis.spec
- BR: scons
[packages/aqsis.git] / aqsis.spec
1 # TODO:
2 # - Check to see if splitting plugins into several packages makes any sense
3 #   (probably not).
4 # - Check that everything works as expected.
5 # - Remove duplications in %files section.
6 # - Fix aqsis-scons-paths.patch so modyfing it after sysconfdir change will
7 #   not be needed.
8 # - Check why the second stage of compilation ignores CXX and CXXFLAGS and
9 #   fix it of course :)
10 # - Proper configuration files handling by SPEC.
11 # - Fix paths in configuration file.
12 Summary:        Aqsis Rendering System
13 Summary(pl.UTF-8):      System Renderujący Aqsis
14 Name:           aqsis
15 Version:        1.2.0
16 Release:        0.1
17 License:        GPL v2 / LGPL v2.1
18 Group:          Applications/Graphics
19 Source0:        http://dl.sourceforge.net/aqsis/%{name}-%{version}.tar.gz
20 # Source0-md5:  ae9bb1c4b22e396fd7ce84ee3e13cb86
21 Patch0:         %{name}-scons-paths.patch
22 URL:            http://aqsis.sourceforge.net/
23 BuildRequires:  OpenEXR-devel
24 BuildRequires:  bison >= 1.35
25 BuildRequires:  boost-devel >= 1.32.0
26 BuildRequires:  flex >= 2.5.4
27 BuildRequires:  fltk-devel >= 1.1.0
28 BuildRequires:  libjpeg-devel >= 6b
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtiff-devel >= 3.7.1
31 BuildRequires:  libtool >= 2:1.5
32 BuildRequires:  libxslt-progs
33 BuildRequires:  rpmbuild(macros) >= 1.337
34 BuildRequires:  scons
35 BuildRequires:  zlib-devel >= 1.1.4
36 Provides:       renderman-engine
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 The Aqsis Rendering System consists of a set of libraries and
41 applications for creating high-quality computer imagery using the
42 Pixar RenderMan Interface.
43
44 %description -l pl.UTF-8
45 System renderujący Aqsis składa się z zestawu bibliotek i programów do
46 tworzenia wysokiej jakości obrazów komputerowych z użyciem interfejsu
47 RenderMan firmy Pixar.
48
49 %package devel
50 Summary:        Header files for Aqsis Rendering System
51 Summary(pl.UTF-8):      Pliki nagłówkowe Systemu Renderującego Aqsis
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       libstdc++-devel
55 Requires:       libtiff-devel
56 Requires:       log4cpp-devel
57 Requires:       zlib-devel
58
59 %description devel
60 Header files for Aqsis Rendering System.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe systemu renderującego Aqsis.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68
69 %build
70 export CXX='%{__cxx}'
71 export CXXFLAGS='%{rpmcflags}'
72 export CC='%{__cc}'
73 export CFLAGS='%{rpmcflags}'
74 # WARNING! If you'll change the sysconfdir argument below, remember to
75 # make apriopriate change in aqsis-scons-paths.patch!
76 %scons \
77         install_prefix=$RPM_BUILD_ROOT%{_prefix} \
78         sysconfdir=$RPM_BUILD_ROOT/etc/%{name}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT{/etc/%{name},%{name},%{_bindir},%{_libdir},%{_datadir}/%{name}}
83
84 %scons install_prefix=$RPM_BUILD_ROOT%{_prefix} \
85         install
86 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
87 #mv $RPM_BUILD_ROOT%{_usr}/etc $RPM_BUILD_ROOT
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS ReleaseNotes README
98 /etc/%{name}
99 %attr(755,root,root) %{_bindir}/*
100 %attr(755,root,root) %{_libdir}/lib*.so*
101 %dir %{_libdir}/%{name}
102 %attr(755,root,root) %{_libdir}/%{name}/*.so
103 %dir %{_libdir}/%{name}/plugins
104 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
105 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
106 %{_datadir}/%{name}
107
108 %files devel
109 %defattr(644,root,root,755)
110 #%attr(755,root,root) %{_libdir}/lib*.so
111 #%{_libdir}/lib*.la
112 %{_includedir}/%{name}
This page took 0.034129 seconds and 3 git commands to generate.