]> git.pld-linux.org Git - packages/aqsis.git/blob - aqsis.spec
- macros for %scons
[packages/aqsis.git] / aqsis.spec
1 # TODO:
2 # - Check to see if splitting plugins into several packages makes any sense
3 #   (probably not).
4 # - Check that everything works as expected.
5 # - Remove duplications in %files section.
6 # - Fix aqsis-scons-paths.patch so modyfing it after sysconfdir change will
7 #   not be needed.
8 # - Check why the second stage of compilation ignores CXX and CXXFLAGS and
9 #   fix it of course :)
10 # - Proper configuration files handling by SPEC.
11 # - Fix paths in configuration file.
12 Summary:        Aqsis Rendering System
13 Summary(pl.UTF-8):      System Renderujący Aqsis
14 Name:           aqsis
15 Version:        1.2.0
16 Release:        0.1
17 License:        GPL v2 / LGPL v2.1
18 Group:          Applications/Graphics
19 Source0:        http://dl.sourceforge.net/aqsis/%{name}-%{version}.tar.gz
20 # Source0-md5:  ae9bb1c4b22e396fd7ce84ee3e13cb86
21 Patch0:         %{name}-scons-paths.patch
22 URL:            http://aqsis.sourceforge.net/
23 BuildRequires:  OpenEXR-devel
24 BuildRequires:  bison >= 1.35
25 BuildRequires:  boost-devel >= 1.32.0
26 BuildRequires:  flex >= 2.5.4
27 BuildRequires:  fltk-devel >= 1.1.0
28 BuildRequires:  libjpeg-devel >= 6b
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtiff-devel >= 3.7.1
31 BuildRequires:  libtool >= 2:1.5
32 BuildRequires:  libxslt-progs
33 BuildRequires:  rpmbuild(macros) >= 1.337
34 BuildRequires:  zlib-devel >= 1.1.4
35 Provides:       renderman-engine
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 The Aqsis Rendering System consists of a set of libraries and
40 applications for creating high-quality computer imagery using the
41 Pixar RenderMan Interface.
42
43 %description -l pl.UTF-8
44 System renderujący Aqsis składa się z zestawu bibliotek i programów do
45 tworzenia wysokiej jakości obrazów komputerowych z użyciem interfejsu
46 RenderMan firmy Pixar.
47
48 %package devel
49 Summary:        Header files for Aqsis Rendering System
50 Summary(pl.UTF-8):      Pliki nagłówkowe Systemu Renderującego Aqsis
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       libstdc++-devel
54 Requires:       libtiff-devel
55 Requires:       log4cpp-devel
56 Requires:       zlib-devel
57
58 %description devel
59 Header files for Aqsis Rendering System.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe systemu renderującego Aqsis.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67
68 %build
69 export CXX='%{__cxx}'
70 export CXXFLAGS='%{rpmcflags}'
71 export CC='%{__cc}'
72 export CFLAGS='%{rpmcflags}'
73 # WARNING! If you'll change the sysconfdir argument below, remember to
74 # make apriopriate change in aqsis-scons-paths.patch!
75 %scons \
76         install_prefix=$RPM_BUILD_ROOT%{_prefix} \
77         sysconfdir=$RPM_BUILD_ROOT/etc/%{name}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT{/etc/%{name},%{name},%{_bindir},%{_libdir},%{_datadir}/%{name}}
82
83 %scons install_prefix=$RPM_BUILD_ROOT%{_prefix} \
84         install
85 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
86 #mv $RPM_BUILD_ROOT%{_usr}/etc $RPM_BUILD_ROOT
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc AUTHORS ReleaseNotes README
97 /etc/%{name}
98 %attr(755,root,root) %{_bindir}/*
99 %attr(755,root,root) %{_libdir}/lib*.so*
100 %dir %{_libdir}/%{name}
101 %attr(755,root,root) %{_libdir}/%{name}/*.so
102 %dir %{_libdir}/%{name}/plugins
103 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
104 %attr(755,root,root) %{_libdir}/%{name}/lib*.so*
105 %{_datadir}/%{name}
106
107 %files devel
108 %defattr(644,root,root,755)
109 #%attr(755,root,root) %{_libdir}/lib*.so
110 #%{_libdir}/lib*.la
111 %{_includedir}/%{name}
This page took 0.080459 seconds and 3 git commands to generate.