]> git.pld-linux.org Git - packages/aqsis.git/blob - aqsis.spec
3818319c9776aa39d34e3fbfe52b50f1b5ca22dc
[packages/aqsis.git] / aqsis.spec
1 # TODO:
2 # - Check to see if splitting plugins into several packages makes any sense
3 #   (probably not).
4 # - Check that everything works as expected.
5 # - Remove duplications in %files section.
6 # - Fix aqsis-scons-paths.patch so modyfing it after sysconfdir change will
7 #   not be needed.
8 # - Check why the second stage of compilation ignores CXX and CXXFLAGS and
9 #   fix it of course :)
10 Summary:        Aqsis Rendering System
11 Summary(pl.UTF-8):      System Renderujący Aqsis
12 Name:           aqsis
13 Version:        1.2.0
14 Release:        0.1
15 License:        GPL v2 / LGPL v2.1
16 Group:          Applications/Graphics
17 Source0:        http://dl.sourceforge.net/aqsis/%{name}-%{version}.tar.gz
18 # Source0-md5:  ae9bb1c4b22e396fd7ce84ee3e13cb86
19 Patch0:         aqsis-scons-paths.patch
20 URL:            http://aqsis.sourceforge.net/
21 BuildRequires:  OpenEXR-devel
22 BuildRequires:  bison >= 1.35
23 BuildRequires:  boost-devel >= 1.32.0
24 BuildRequires:  flex >= 2.5.4
25 BuildRequires:  fltk-devel >= 1.1.0
26 BuildRequires:  libjpeg-devel >= 6b
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtiff-devel >= 3.7.1
29 BuildRequires:  libtool >= 2:1.5
30 BuildRequires:  libxslt-progs
31 BuildRequires:  zlib-devel >= 1.1.4
32 Provides:       renderman-engine
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 The Aqsis Rendering System consists of a set of libraries and
37 applications for creating high-quality computer imagery using the
38 Pixar RenderMan Interface.
39
40 %description -l pl.UTF-8
41 System renderujący Aqsis składa się z zestawu bibliotek i programów do
42 tworzenia wysokiej jakości obrazów komputerowych z użyciem interfejsu
43 RenderMan firmy Pixar.
44
45 %package devel
46 Summary:        Header files for Aqsis Rendering System
47 Summary(pl.UTF-8):      Pliki nagłówkowe Systemu Renderującego Aqsis
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       libstdc++-devel
51 Requires:       libtiff-devel
52 Requires:       log4cpp-devel
53 Requires:       zlib-devel
54
55 %description devel
56 Header files for Aqsis Rendering System.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe systemu renderującego Aqsis.
60
61 %prep
62 %setup -q
63 %patch0 -p1
64
65 %build
66 export CXX='%{__cxx}'
67 export CXXFLAGS='%{rpmcflags}'
68 export CC='%{__cc}'
69 export CFLAGS='%{rpmcflags}'
70 # WARNING! If you'll change the sysconfdir argument below, remember to
71 # make apriopriate change in aqsis-scons-paths.patch!
72 %{scons} \
73         install_prefix="$RPM_BUILD_ROOT%{_prefix}" \
74         sysconfdir="$RPM_BUILD_ROOT/etc/%{name}"
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{/etc/%{name},%{name},%{_bindir},%{_libdir},%{_datadir}/%{name}}
79
80 %{scons} install_prefix="$RPM_BUILD_ROOT%{_prefix}" install
81 #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
82 #mv $RPM_BUILD_ROOT%{_usr}/etc $RPM_BUILD_ROOT
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc AUTHORS ReleaseNotes README
93 %attr(755,root,root) %{_bindir}/*
94 %attr(755,root,root) %{_libdir}/lib*.so*
95 %dir %{_libdir}/%{name}/
96 %attr(755,root,root) %{_libdir}/%{name}/*.so
97 %dir %{_libdir}/%{name}/plugins/
98 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so
99 %{_libdir}/%{name}/lib*.so*
100 %{_datadir}/%{name}
101 /etc/%{name}
102
103 %files devel
104 %defattr(644,root,root,755)
105 #%attr(755,root,root) %{_libdir}/lib*.so
106 #%{_libdir}/lib*.la
107 %{_includedir}/%{name}
This page took 0.063661 seconds and 2 git commands to generate.