]> git.pld-linux.org Git - packages/apr.git/blobdiff - apr.spec
- updated to 1.3.0
[packages/apr.git] / apr.spec
index 3220b96e16db8bcdd5b1e1bce182a617c8183a6a..88298374290642449c536d2e7d22ccf51066da21 100644 (file)
--- a/apr.spec
+++ b/apr.spec
@@ -1,18 +1,27 @@
-%define        snap    20030913101709
 Summary:       Apache Portable Runtime
+Summary(pl.UTF-8):     Apache Portable Runtime - przenośna biblioteka uruchomieniowa
 Name:          apr
-Version:       0.9.4
-Release:       0.%{snap}.2
+Version:       1.3.0
+Release:       1
 Epoch:         1
-License:       GPL
+License:       Apache v2.0
 Group:         Libraries
-# http://www.apache.org/dist/apr/%{name}-%{version}.tar.gz
-Source0:       http://cvs.apache.org/snapshots/apr/%{name}_%{snap}.tar.gz
-# Source0-md5: d14874964cd7f686594534d9e949eaee
+Source0:       http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
+# Source0-md5: 27d8fc8b13f8ea1a40e6796e7453bd84
+Patch0:                %{name}-link.patch
+Patch1:                %{name}-metuxmpm.patch
+Patch2:                %{name}-libtool.patch
 URL:           http://apr.apache.org/
-BuildRequires: libtool
-BuildRequires: autoconf
-BuildRequires: perl-base
+BuildRequires: autoconf >= 2.13
+BuildRequires: automake
+BuildRequires: libtool >= 2:2.2
+BuildRequires: libuuid-devel
+BuildRequires: sed >= 4.0
+BuildRequires: python
+BuildRequires: uname(release) >= 2.6
+Requires:      uname(release) >= 2.6
+Conflicts:     kernel24
+Conflicts:     kernel24-smp
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _includedir     /usr/include/apr
@@ -28,30 +37,73 @@ regardless of the platform on which their software is built, relieving
 them of the need to code special-case conditions to work around or
 take advantage of platform-specific deficiencies or features.
 
+%description -l pl.UTF-8
+Celem projektu APR (Apache Portable Runtime) jest stworzenie i
+utrzymywanie bibliotek dostarczających przewidywalnego i spójnego
+interfejsu do leżących u podstaw implementacji zależnych od platformy.
+Głównym celem jest dostarczenie API, którego mogą używać programiści
+mając pewność, że zachowuje się w sposób przewidywalny, jeśli nie
+identyczny, niezależnie od platformy na jakiej oprogramowanie jest
+budowane oraz bez potrzeby kodowania specjalnych warunków do
+obchodzenia lub wykorzystywania specyficznych dla platform różnic lub
+możliwości.
+
 %package devel
-Summary:       Header files and develpment documentation for apr
+Summary:       Header files and development documentation for apr
+Summary(pl.UTF-8):     Pliki nagłówkowe i dokumentacja programisty do apr
 Group:         Development/Libraries
-Requires:      %{name} = %{epoch}:%{version}
-Requires:      libtool
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      libuuid-devel
+Requires:      automake
+Requires:      libtool >= 2:2.2
 
 %description devel
-Header files and develpment documentation for apr.
+Header files and development documentation for apr.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe i dokumentacja programisty do apr.
 
 %package static
 Summary:       Static apr library
+Summary(pl.UTF-8):     Statyczna biblioteka apr
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{epoch}:%{version}
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
 
 %description static
 Static apr library.
 
+%description static -l pl.UTF-8
+Statyczna biblioteka apr.
+
 %prep
-%setup  -q -n %{name}
+%setup -q
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+
+cat >> config.layout <<'EOF'
+<Layout PLD>
+sbindir:       %{_sbindir}
+libexecdir:    %{_libdir}/apr
+installbuilddir: ${datadir}/build-${APR_MAJOR_VERSION}
+localstatedir: /var/run
+runtimedir:    /var/run
+libsuffix:     -${APR_MAJOR_VERSION}
+</Layout>
+EOF
 
 %build
-./buildconf
+install /usr/share/automake/config.* build
+
 %configure \
-       --enable-threads
+       --enable-layout=PLD \
+%ifarch %{ix86} %{i8664}
+%ifnarch i386
+       --enable-nonportable-atomics \
+%endif
+%endif
+       --enable-threads \
+       --with-devrandom=/dev/urandom
 %{__make}
 
 %install
@@ -62,27 +114,36 @@ rm -rf $RPM_BUILD_ROOT
 
 ln -sf %{_bindir}/libtool $RPM_BUILD_ROOT%{_datadir}/libtool
 
-install build/{*apr*.m4,*.awk,*.sh,config.*}   $RPM_BUILD_ROOT%{_datadir}/build
-
-perl -pi -e "s#$RPM_BUILD_DIR/%{name}#%{_datadir}#g" $RPM_BUILD_ROOT%{_bindir}/*
-perl -pi -e "s#$RPM_BUILD_DIR/%{name}.*#%{_datadir}/build#g" $RPM_BUILD_ROOT%{_datadir}/build/*
+mv -f $RPM_BUILD_ROOT%{_datadir}/build-1 $RPM_BUILD_ROOT%{_datadir}/build
+install build/{*apr*.m4,*.awk,*.sh,gen-build.py} $RPM_BUILD_ROOT%{_datadir}/build
+ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_datadir}/build
+ln -snf /usr/share/libtool/config/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
+ln -snf /usr/bin/libtool $RPM_BUILD_ROOT%{_datadir}/build
+ln -sf build $RPM_BUILD_ROOT%{_datadir}/build-1
 
-%post   -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+sed -i -e 's@^\(APR_SOURCE_DIR=\).*@\1"%{_datadir}"@' \
+       $RPM_BUILD_ROOT%{_bindir}/apr-1-config
+sed -i -e 's@^\(apr_builddir\|apr_builders\)=.*@\1=%{_datadir}/build-1@' \
+       $RPM_BUILD_ROOT%{_datadir}/build/apr_rules.mk
+sed -i -e '1s@#!.*python@#!%{__python}@' $RPM_BUILD_ROOT%{_datadir}/build/gen-build.py
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
-%doc CHANGES STATUS docs/*.html
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%doc CHANGES docs/*.html
+%attr(755,root,root) %{_libdir}/libapr-1.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libapr-1.so.0
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
+%attr(755,root,root) %{_bindir}/apr-1-config
+%attr(755,root,root) %{_libdir}/libapr-1.so
+%{_libdir}/libapr-1.la
 %{_libdir}/apr.exp
 %{_includedir}
 %dir %{_datadir}
@@ -93,7 +154,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_datadir}/build/config.*
 %attr(755,root,root) %{_datadir}/build/*.sh
 %attr(755,root,root) %{_datadir}/build/libtool
+%attr(755,root,root) %{_datadir}/build/gen-build.py
+%{_datadir}/build-1
+%{_pkgconfigdir}/apr-1.pc
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libapr-1.a
This page took 0.109827 seconds and 4 git commands to generate.