]> git.pld-linux.org Git - packages/apr.git/blame - apr.spec
- racy version but doesn't use new API thus should work on old kernels, too
[packages/apr.git] / apr.spec
CommitLineData
7bcdeaec 1%bcond_with tests
f3bf17ad 2Summary: Apache Portable Runtime
e51e866d 3Summary(pl.UTF-8): Apache Portable Runtime - przenośna biblioteka uruchomieniowa
f3bf17ad 4Name: apr
d9cfa95e 5Version: 1.3.3
7bcdeaec 6Release: 9
f3bf17ad 7Epoch: 1
b34d84ea 8License: Apache v2.0
f3bf17ad 9Group: Libraries
55e3eaa9 10Source0: http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
d9cfa95e 11# Source0-md5: 2090c21dee4f0eb1512604127dcd158f
9e32e98f
JB
12Patch0: %{name}-link.patch
13Patch1: %{name}-metuxmpm.patch
e0b90f27 14Patch2: %{name}-libtool.patch
855204ca 15Patch3: %{name}-bug-46425.patch
f3bf17ad 16URL: http://apr.apache.org/
3c7d7510 17BuildRequires: autoconf >= 2.50
c7edcef5 18BuildRequires: automake
1c519bd4 19BuildRequires: glibc-devel >= 6:2.9
df8efb25 20%if "%{pld_release}" != "ac"
1b25cd0a 21BuildRequires: libtool >= 2:2.2
df8efb25
ER
22%else
23BuildRequires: libtool
24%endif
69f0f35f 25BuildRequires: libuuid-devel
9e32e98f 26BuildRequires: python
df8efb25 27BuildRequires: rpm >= 4.4.9-56
7bac6e65 28BuildRequires: rpm-pythonprov
df8efb25
ER
29BuildRequires: sed >= 4.0
30%if "%{pld_release}" != "ac"
1c519bd4 31BuildRequires: uname(release) >= 2.6
594a4336 32Requires: uname(release) >= 2.6.27
df8efb25 33%endif
52336182
JB
34Conflicts: kernel24
35Conflicts: kernel24-smp
f3bf17ad
AM
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%define _includedir /usr/include/apr
39%define _datadir /usr/share/apr
40
41%description
42The mission of the Apache Portable Runtime (APR) project is to create
43and maintain software libraries that provide a predictable and
44consistent interface to underlying platform-specific implementations.
45The primary goal is to provide an API to which software developers may
46code and be assured of predictable if not identical behaviour
47regardless of the platform on which their software is built, relieving
48them of the need to code special-case conditions to work around or
49take advantage of platform-specific deficiencies or features.
50
a79d9376 51%description -l pl.UTF-8
b4838f76 52Celem projektu APR (Apache Portable Runtime) jest stworzenie i
a79d9376
JR
53utrzymywanie bibliotek dostarczających przewidywalnego i spójnego
54interfejsu do leżących u podstaw implementacji zależnych od platformy.
55Głównym celem jest dostarczenie API, którego mogą używać programiści
56mając pewność, że zachowuje się w sposób przewidywalny, jeśli nie
57identyczny, niezależnie od platformy na jakiej oprogramowanie jest
58budowane oraz bez potrzeby kodowania specjalnych warunków do
59obchodzenia lub wykorzystywania specyficznych dla platform różnic lub
60możliwości.
b4838f76 61
f3bf17ad 62%package devel
b4838f76 63Summary: Header files and development documentation for apr
e51e866d 64Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja programisty do apr
f3bf17ad 65Group: Development/Libraries
b4838f76 66Requires: %{name} = %{epoch}:%{version}-%{release}
d53f5760 67Requires: automake
df8efb25 68%if "%{pld_release}" != "ac"
1b25cd0a 69Requires: libtool >= 2:2.2
df8efb25
ER
70%else
71Requires: libtool
72%endif
d9cfa95e 73Requires: libuuid-devel
7bac6e65 74Requires: python-modules
f3bf17ad
AM
75
76%description devel
b4838f76
JB
77Header files and development documentation for apr.
78
a79d9376
JR
79%description devel -l pl.UTF-8
80Pliki nagłówkowe i dokumentacja programisty do apr.
f3bf17ad
AM
81
82%package static
83Summary: Static apr library
e51e866d 84Summary(pl.UTF-8): Statyczna biblioteka apr
f3bf17ad 85Group: Development/Libraries
b4838f76 86Requires: %{name}-devel = %{epoch}:%{version}-%{release}
f3bf17ad
AM
87
88%description static
89Static apr library.
90
a79d9376 91%description static -l pl.UTF-8
b4838f76
JB
92Statyczna biblioteka apr.
93
f3bf17ad 94%prep
af4e4c47 95%setup -q
9e32e98f
JB
96%patch0 -p1
97%patch1 -p1
e0b90f27 98%patch2 -p1
7bcdeaec 99%patch3 -p1
f3bf17ad 100
13f3c811
JB
101cat >> config.layout <<'EOF'
102<Layout PLD>
103sbindir: %{_sbindir}
104libexecdir: %{_libdir}/apr
105installbuilddir: ${datadir}/build-${APR_MAJOR_VERSION}
106localstatedir: /var/run
107runtimedir: /var/run
108libsuffix: -${APR_MAJOR_VERSION}
2523b113 109</Layout>
13f3c811
JB
110EOF
111
f3bf17ad 112%build
b34d84ea 113install /usr/share/automake/config.* build
cb4191bc 114%{__autoconf}
2523b113 115
f3bf17ad 116%configure \
13f3c811 117 --enable-layout=PLD \
3c7d7510 118%ifarch %{ix86} %{x8664}
02a2518a 119%ifnarch i386
120 --enable-nonportable-atomics \
121%endif
122%endif
13f3c811
JB
123 --enable-threads \
124 --with-devrandom=/dev/urandom
f3bf17ad
AM
125%{__make}
126
7bcdeaec
AM
127%{?with_tests:%{__make} -j1 test}
128
f3bf17ad
AM
129%install
130rm -rf $RPM_BUILD_ROOT
131
132%{__make} install \
133 DESTDIR=$RPM_BUILD_ROOT
134
9e32e98f 135mv -f $RPM_BUILD_ROOT%{_datadir}/build-1 $RPM_BUILD_ROOT%{_datadir}/build
16773349 136install build/{*apr*.m4,*.awk,*.sh,gen-build.py} $RPM_BUILD_ROOT%{_datadir}/build
d53f5760 137ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_datadir}/build
d522858e
ER
138if [ -f /usr/share/libtool/config/ltmain.sh ]; then
139 ln -snf /usr/share/libtool/config/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
140else
141 ln -snf /usr/share/libtool/ltmain.sh $RPM_BUILD_ROOT%{_datadir}/build
142fi
d53f5760 143ln -snf /usr/bin/libtool $RPM_BUILD_ROOT%{_datadir}/build
9e32e98f 144ln -sf build $RPM_BUILD_ROOT%{_datadir}/build-1
8c18c9a9 145
16773349
ER
146sed -i -e 's@^\(APR_SOURCE_DIR=\).*@\1"%{_datadir}"@' \
147 $RPM_BUILD_ROOT%{_bindir}/apr-1-config
148sed -i -e 's@^\(apr_builddir\|apr_builders\)=.*@\1=%{_datadir}/build-1@' \
9e32e98f 149 $RPM_BUILD_ROOT%{_datadir}/build/apr_rules.mk
16773349 150sed -i -e '1s@#!.*python@#!%{__python}@' $RPM_BUILD_ROOT%{_datadir}/build/gen-build.py
f3bf17ad
AM
151
152%clean
153rm -rf $RPM_BUILD_ROOT
154
b4838f76
JB
155%post -p /sbin/ldconfig
156%postun -p /sbin/ldconfig
157
f3bf17ad
AM
158%files
159%defattr(644,root,root,755)
023f96c0 160%doc CHANGES docs/*.html
7a48bef9
JB
161%attr(755,root,root) %{_libdir}/libapr-1.so.*.*.*
162%attr(755,root,root) %ghost %{_libdir}/libapr-1.so.0
f3bf17ad
AM
163
164%files devel
165%defattr(644,root,root,755)
7a48bef9
JB
166%attr(755,root,root) %{_bindir}/apr-1-config
167%attr(755,root,root) %{_libdir}/libapr-1.so
168%{_libdir}/libapr-1.la
f3bf17ad
AM
169%{_libdir}/apr.exp
170%{_includedir}
171%dir %{_datadir}
9e32e98f
JB
172%dir %{_datadir}/build
173%{_datadir}/build/*.mk
174%{_datadir}/build/*.m4
175%{_datadir}/build/*.awk
176%attr(755,root,root) %{_datadir}/build/config.*
177%attr(755,root,root) %{_datadir}/build/*.sh
178%attr(755,root,root) %{_datadir}/build/libtool
16773349 179%attr(755,root,root) %{_datadir}/build/gen-build.py
9e32e98f 180%{_datadir}/build-1
af4e4c47 181%{_pkgconfigdir}/apr-1.pc
f3bf17ad
AM
182
183%files static
184%defattr(644,root,root,755)
7a48bef9 185%{_libdir}/libapr-1.a
This page took 1.089292 seconds and 4 git commands to generate.