]> git.pld-linux.org Git - packages/apr-compat.git/commitdiff
- added link patch - link with used libs, no unused libs in apr-config --libs
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 5 Oct 2003 22:27:55 +0000 (22:27 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- it's snapshot version, so added release to subpackage deps
- removed libtool from -devel Reqs - it provides own version of libtool
- pl descriptions

Changed files:
    apr-compat.spec -> 1.6
    apr-link.patch -> 1.1

apr-compat.spec
apr-link.patch [new file with mode: 0644]

index 3220b96e16db8bcdd5b1e1bce182a617c8183a6a..28cbef4e9e3a82cc43d4243b71b56410fa6d5a43 100644 (file)
@@ -1,5 +1,6 @@
 %define        snap    20030913101709
 Summary:       Apache Portable Runtime
+Summary(pl):   Apache Portable Runtime - przeno¶na biblioteka uruchomieniowa
 Name:          apr
 Version:       0.9.4
 Release:       0.%{snap}.2
@@ -9,9 +10,10 @@ Group:                Libraries
 # http://www.apache.org/dist/apr/%{name}-%{version}.tar.gz
 Source0:       http://cvs.apache.org/snapshots/apr/%{name}_%{snap}.tar.gz
 # Source0-md5: d14874964cd7f686594534d9e949eaee
+Patch0:                %{name}-link.patch
 URL:           http://apr.apache.org/
-BuildRequires: libtool
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.13
+BuildRequires: libtool >= 1.3.3
 BuildRequires: perl-base
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -28,25 +30,44 @@ regardless of the platform on which their software is built, relieving
 them of the need to code special-case conditions to work around or
 take advantage of platform-specific deficiencies or features.
 
+%description -l pl
+Celem projektu APR (Apache Portable Runtime) jest stworzenie i
+utrzymywanie bibliotek dostarcaj±cych przewidywalnego i spójnego
+interfejsu do le¿±cych u podstaw implementacji zale¿nych od platformy.
+G³ównym celem jest dostarczenie API, którego mog± u¿ywaæ programi¶ci
+maj±c pewno¶æ, ¿e zachowuje siê w sposób przewidywalny, je¶li nie
+identyczny, niezale¿nie od platformy na jakiej oprogramowanie jest
+budowane oraz bez potrzeby kodowania specjalnych warunków do
+obchodzenia lub wykorzystywania specyficznych dla platform ró¿nic lub
+mo¿liwo¶ci.
+
 %package devel
-Summary:       Header files and develpment documentation for apr
+Summary:       Header files and development documentation for apr
+Summary(pl):   Pliki nag³ówkowe i dokumentacja programisty do apr
 Group:         Development/Libraries
-Requires:      %{name} = %{epoch}:%{version}
-Requires:      libtool
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description devel
-Header files and develpment documentation for apr.
+Header files and development documentation for apr.
+
+%description devel -l pl
+Pliki nag³ówkowe i dokumentacja programisty do apr.
 
 %package static
 Summary:       Static apr library
+Summary(pl):   Statyczna biblioteka apr
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{epoch}:%{version}
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
 
 %description static
 Static apr library.
 
+%description static -l pl
+Statyczna biblioteka apr.
+
 %prep
-%setup  -q -n %{name}
+%setup -q -n %{name}
+%patch -p1 -b .orig
 
 %build
 ./buildconf
@@ -62,17 +83,17 @@ rm -rf $RPM_BUILD_ROOT
 
 ln -sf %{_bindir}/libtool $RPM_BUILD_ROOT%{_datadir}/libtool
 
-install build/{*apr*.m4,*.awk,*.sh,config.*}   $RPM_BUILD_ROOT%{_datadir}/build
+install build/{*apr*.m4,*.awk,*.sh,config.*} $RPM_BUILD_ROOT%{_datadir}/build
 
-perl -pi -e "s#$RPM_BUILD_DIR/%{name}#%{_datadir}#g" $RPM_BUILD_ROOT%{_bindir}/*
-perl -pi -e "s#$RPM_BUILD_DIR/%{name}.*#%{_datadir}/build#g" $RPM_BUILD_ROOT%{_datadir}/build/*
-
-%post   -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%{__perl} -pi -e "s#$RPM_BUILD_DIR/%{name}#%{_datadir}#g" $RPM_BUILD_ROOT%{_bindir}/*
+%{__perl} -pi -e "s#$RPM_BUILD_DIR/%{name}.*#%{_datadir}/build#g" $RPM_BUILD_ROOT%{_datadir}/build/*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
 %doc CHANGES STATUS docs/*.html
diff --git a/apr-link.patch b/apr-link.patch
new file mode 100644 (file)
index 0000000..10e01f6
--- /dev/null
@@ -0,0 +1,59 @@
+--- apr/build/apr_threads.m4.orig      2003-10-05 21:35:45.000000000 +0200
++++ apr/build/apr_threads.m4   2003-10-05 21:50:16.883264632 +0200
+@@ -130,6 +130,8 @@
+ fi
+ ])
++dnl -pthread in CFLAGS is not sufficient if linking in separate process
++pthreads_working=
+ AC_CACHE_CHECK(for pthreads_lib, ac_cv_pthreads_lib,[
+ ac_cv_pthreads_lib=""
+ if test "$pthreads_working" != "yes"; then
+--- apr/configure.in.orig      2003-09-02 12:19:46.000000000 +0200
++++ apr/configure.in   2003-10-05 22:35:55.808884648 +0200
+@@ -189,7 +189,7 @@
+ # On AIX, libraries need to be specified on the link of lib_target
+ lib_target_libs=""
+ case $host in
+-    *aix*)
++    *aix*|*linux*)
+         lib_target_libs="\$(EXTRA_LIBS)";
+         ;;
+     *-solaris2*)
+@@ -463,11 +463,9 @@
+ dnl It should check for LIBS being empty and set LIBS equal to the new value 
+ dnl without the extra " " in that case, but they didn't do that.  So, we
+ dnl end up LIBS="-lm -lcrypt -lnsl  -ldl" which is an annoyance.
+-AC_CHECK_LIB(resolv, res_init)
+-AC_CHECK_LIB(nsl, gethostbyname)
++dnl AC_CHECK_LIB(resolv, res_init)  -- not used by apr
+ AC_SEARCH_LIBS(gethostname, nsl)
+-AC_CHECK_LIB(socket, socket)
+-AC_SEARCH_LIBS(crypt, crypt ufc)
++AC_SEARCH_LIBS(socket, socket)
+ AC_CHECK_LIB(truerand, main)
+ AC_SEARCH_LIBS(modf, m)
+ AC_SEARCH_LIBS(sqrt, m)
+@@ -604,7 +602,7 @@
+ # The real-time POSIX extensions (e.g. shm_*, sem_*) may only
+ # be available if linking against librt.
+-AC_SEARCH_LIBS(shm_open, rt)
++dnl AC_SEARCH_LIBS(shm_open, rt)  -- not used by apr
+ case $host in
+  *-sysv*)
+@@ -863,10 +861,13 @@
+ if test "$strerror_r" = "1"; then
+   APR_CHECK_STRERROR_R_RC
+ fi
++save_LIBS="$LIBS"
++AC_SEARCH_LIBS(crypt, crypt ufc)
+ AC_CHECK_FUNCS(crypt_r, [ crypt_r="1" ], [ crypt_r="0" ])
+ if test "$crypt_r" = "1"; then
+   APR_CHECK_CRYPT_R_STYLE
+ fi
++LIBS="$save_LIBS"
+ AC_CHECK_FUNCS(mmap, [ mmap="1" ], [ mmap="0" ])
+ if test "$native_mmap_emul" = "1"; then
+     mmap="1"
This page took 0.04183 seconds and 4 git commands to generate.