]> git.pld-linux.org Git - packages/apparmor-parser.git/commitdiff
- up to 3.0.1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 7 Feb 2021 14:48:39 +0000 (15:48 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 7 Feb 2021 14:48:39 +0000 (15:48 +0100)
apparmor-2.13.4-make4.3.patch [deleted file]
apparmor-2.13.4-run_variable.patch [deleted file]
apparmor-parser-cache-rebuild.patch
apparmor-parser-pld.patch
apparmor-parser.spec
cap.patch [new file with mode: 0644]

diff --git a/apparmor-2.13.4-make4.3.patch b/apparmor-2.13.4-make4.3.patch
deleted file mode 100644 (file)
index 383157a..0000000
+++ /dev/null
@@ -1,308 +0,0 @@
-From fc2beaca9d642fb93736066f26e3588ad30ec7a4 Mon Sep 17 00:00:00 2001
-From: Eric Chiang <ericchiang@google.com>
-Date: Thu, 17 Jan 2019 11:02:57 -0800
-Subject: [PATCH 1/4] *: ensure make apparmor_parser is cached
-
-This change updates parser/Makefile to respect target dependencies and
-not rebuild apparmor_parser if nothing's changed. The goal is to allow
-cross-compiled tests #17 to run on a target system without the tests
-attempting to rebuild the parser.
-
-Two changes were made:
-
-* Generate af_names.h in a script so the script timestamp is compared.
-* Use FORCE instead of PHONY for libapparmor_re/libapparmor_re.a
-
-Changes to list_af_names are intended to exactly replicate the old
-behavior.
-
-Signed-off-by: Eric Chiang <ericchiang@google.com>
-(cherry picked from commit cb8c3377babfed4600446d1f60d53d8e2a581578)
----
- common/Make.rules                | 21 ---------------------
- common/list_af_names.sh          | 19 +++++++++++++++++++
- parser/Makefile                  | 13 +++++--------
- utils/vim/create-apparmor.vim.py |  2 +-
- 4 files changed, 25 insertions(+), 30 deletions(-)
- create mode 100755 common/list_af_names.sh
-
-diff --git a/common/Make.rules b/common/Make.rules
-index d2149fcd..357bdec8 100644
---- a/common/Make.rules
-+++ b/common/Make.rules
-@@ -87,27 +87,6 @@ CAPABILITIES=$(shell echo "\#include <linux/capability.h>" | cpp -dM | LC_ALL=C
- list_capabilities: /usr/include/linux/capability.h
-       @echo "$(CAPABILITIES)"
--# =====================
--# generate list of network protocols based on
--# sys/socket.h for use in multiple locations in
--# the source tree
--# =====================
--
--# These are the families that it doesn't make sense for apparmor
--# to mediate. We use PF_ here since that is what is required in
--# bits/socket.h, but we will rewrite these as AF_.
--
--FILTER_FAMILIES=PF_UNIX
--
--__FILTER=$(shell echo $(strip $(FILTER_FAMILIES)) | sed -e 's/ /\\\|/g')
--
--# emits the AF names in a "AF_NAME NUMBER," pattern
--AF_NAMES=$(shell echo "\#include <sys/socket.h>" | cpp -dM | LC_ALL=C sed -n -e '/$(__FILTER)/d' -e 's/PF_LOCAL/PF_UNIX/' -e 's/^\#define[ \t]\+PF_\([A-Z0-9_]\+\)[ \t]\+\([0-9]\+\).*$$/AF_\1 \2,/p' | sort -n -k2)
--
--.PHONY: list_af_names
--list_af_names:
--      @echo "$(AF_NAMES)"
--
- # =====================
- # manpages
- # =====================
-diff --git a/common/list_af_names.sh b/common/list_af_names.sh
-new file mode 100755
-index 00000000..d7987537
---- /dev/null
-+++ b/common/list_af_names.sh
-@@ -0,0 +1,19 @@
-+#!/bin/bash -e
-+
-+# =====================
-+# generate list of network protocols based on
-+# sys/socket.h for use in multiple locations in
-+# the source tree
-+# =====================
-+
-+# It doesn't make sence for AppArmor to mediate PF_UNIX, filter it out. Search
-+# for "PF_" constants since that is what is required in bits/socket.h, but
-+# rewrite as "AF_".
-+
-+echo "#include <sys/socket.h>" | \
-+  cpp -dM | \
-+  LC_ALL=C sed -n \
-+    -e '/PF_UNIX/d' \
-+    -e 's/PF_LOCAL/PF_UNIX/' \
-+    -e 's/^#define[ \t]\+PF_\([A-Z0-9_]\+\)[ \t]\+\([0-9]\+\).*$/AF_\1 \2,/p' | \
-+  sort -n -k2
-diff --git a/parser/Makefile b/parser/Makefile
-index 73e88f5c..c22d32da 100644
---- a/parser/Makefile
-+++ b/parser/Makefile
-@@ -281,10 +281,9 @@ parser_version.h: Makefile
- # as well as the filtering that occurs for network protocols that
- # apparmor should not mediate.
--.PHONY: af_names.h
--af_names.h:
--      echo "$(AF_NAMES)" | LC_ALL=C sed -n -e 's/[ \t]\?AF_MAX[ \t]\+[0-9]\+,//g'  -e 's/[ \t]\+\?AF_\([A-Z0-9_]\+\)[ \t]\+\([0-9]\+\),/#ifndef AF_\1\n#  define AF_\1 \2\n#endif\nAA_GEN_NET_ENT("\L\1", \UAF_\1)\n\n/pg' > $@
--      echo "$(AF_NAMES)" | LC_ALL=C sed -n -e 's/.*,[ \t]\+AF_MAX[ \t]\+\([0-9]\+\),\?.*/#define AA_AF_MAX \1\n/p' >> $@
-+af_names.h: ../common/list_af_names.sh
-+      ../common/list_af_names.sh | LC_ALL=C sed -n -e 's/[ \t]\?AF_MAX[ \t]\+[0-9]\+,//g'  -e 's/[ \t]\+\?AF_\([A-Z0-9_]\+\)[ \t]\+\([0-9]\+\),/#ifndef AF_\1\n#  define AF_\1 \2\n#endif\nAA_GEN_NET_ENT("\L\1", \UAF_\1)\n/pg' > $@
-+      ../common/list_af_names.sh | LC_ALL=C sed -n -e 's/AF_MAX[ \t]\+\([0-9]\+\),\?.*/\n#define AA_AF_MAX \1\n/p' >> $@
-       # cat $@
- cap_names.h: /usr/include/linux/capability.h
-@@ -304,10 +303,7 @@ tests: apparmor_parser ${TESTS}
-       sh -e -c 'for test in ${TESTS} ; do echo "*** running $${test}" && ./$${test}; done'
-       $(Q)$(MAKE) -s -C tst tests
--# always need to rebuild.
--.SILENT: $(AAREOBJECT)
--.PHONY: $(AAREOBJECT)
--$(AAREOBJECT):
-+$(AAREOBJECT): FORCE
-       $(MAKE) -C $(AAREDIR) CFLAGS="$(EXTRA_CXXFLAGS)"
- .PHONY: install-rhel4
-@@ -408,3 +404,4 @@ clean: pod_clean
-       $(MAKE) -s -C po clean
-       $(MAKE) -s -C tst clean
-+FORCE:
-diff --git a/utils/vim/create-apparmor.vim.py b/utils/vim/create-apparmor.vim.py
-index 10bd5b8d..fea134f6 100644
---- a/utils/vim/create-apparmor.vim.py
-+++ b/utils/vim/create-apparmor.vim.py
-@@ -57,7 +57,7 @@ for cap in capabilities:
-         benign_caps.append(cap)
- # get network protos list
--(rc, output) = cmd(['make', '-s', '--no-print-directory', 'list_af_names'])
-+(rc, output) = cmd(['../../common/list_af_names.sh'])
- if rc != 0:
-     sys.stderr.write("make list_af_names failed: " + output)
-     exit(rc)
--- 
-2.26.2
-
-
-From 69651fc6565cf033ab763a607d786eb14143b7c6 Mon Sep 17 00:00:00 2001
-From: John Johansen <john.johansen@canonical.com>
-Date: Fri, 14 Jun 2019 01:04:22 -0700
-Subject: [PATCH 2/4] Revert "utils/test-network.py: fix failing testcase"
-
-This reverts commit 378519d23f8b6e55b1c0741e8cd197863e0ff8a0.
-this commit was meant for the 2.13 branch not master
-
-Signed-off-by: John Johansen <john.johansen@canonical.com>
-(cherry picked from commit 9144e39d252cd75dd2d6941154e014f7d46147ca)
----
- utils/test/test-network.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/utils/test/test-network.py b/utils/test/test-network.py
-index 8605786d..73a6b9d1 100644
---- a/utils/test/test-network.py
-+++ b/utils/test/test-network.py
-@@ -31,7 +31,7 @@ exp = namedtuple('exp', ['audit', 'allow_keyword', 'deny', 'comment',
- class NetworkKeywordsTest(AATest):
-     def test_network_keyword_list(self):
--        rc, output = cmd(['make', '-s', '--no-print-directory', 'list_af_names'])
-+        rc, output = cmd('../../common/list_af_names.sh')
-         self.assertEqual(rc, 0)
-         af_names = []
--- 
-2.26.2
-
-
-From 0d8e4cda3fb5194b82e288cadbcce98998064b7a Mon Sep 17 00:00:00 2001
-From: allgdante <allan.garret@gmail.com>
-Date: Mon, 23 Mar 2020 15:09:15 +0000
-Subject: [PATCH 3/4] Generate CAPABILITIES in a script due to make 4.3
-
-This way we could generate the capabilities in a way that works with
-every version of make.
-Changes to list_capabilities are intended to exactly replicate the old
-behavior.
-
-(cherry picked from commit e92da079ca12e776991bd36524430bd67c1cb72a)
----
- common/Make.rules                | 13 -------------
- common/list_capabilities.sh      | 14 ++++++++++++++
- parser/Makefile                  |  2 +-
- utils/Makefile                   |  2 +-
- utils/vim/create-apparmor.vim.py |  2 +-
- 5 files changed, 17 insertions(+), 16 deletions(-)
- create mode 100755 common/list_capabilities.sh
-
-diff --git a/common/Make.rules b/common/Make.rules
-index 357bdec8..ecc6181a 100644
---- a/common/Make.rules
-+++ b/common/Make.rules
-@@ -74,19 +74,6 @@ endif
- pod_clean:
-       -rm -f ${MANPAGES} *.[0-9].gz ${HTMLMANPAGES} pod2htm*.tmp
--# =====================
--# generate list of capabilities based on
--# /usr/include/linux/capabilities.h for use in multiple locations in
--# the source tree
--# =====================
--
--# emits defined capabilities in a simple list, e.g. "CAP_NAME CAP_NAME2"
--CAPABILITIES=$(shell echo "\#include <linux/capability.h>" | cpp -dM | LC_ALL=C sed -n -e '/CAP_EMPTY_SET/d' -e 's/^\#define[ \t]\+CAP_\([A-Z0-9_]\+\)[ \t]\+\([0-9xa-f]\+\)\(.*\)$$/CAP_\1/p' | LC_ALL=C sort)
--
--.PHONY: list_capabilities
--list_capabilities: /usr/include/linux/capability.h
--      @echo "$(CAPABILITIES)"
--
- # =====================
- # manpages
- # =====================
-diff --git a/common/list_capabilities.sh b/common/list_capabilities.sh
-new file mode 100755
-index 00000000..4e37cda7
---- /dev/null
-+++ b/common/list_capabilities.sh
-@@ -0,0 +1,14 @@
-+#!/bin/bash -e
-+
-+# =====================
-+# generate list of capabilities based on
-+# /usr/include/linux/capabilities.h for use in multiple locations in
-+# the source tree
-+# =====================
-+
-+echo "#include <linux/capability.h>" | \
-+  cpp -dM | \
-+  LC_ALL=C sed -n \
-+    -e '/CAP_EMPTY_SET/d' \
-+    -e 's/^\#define[ \t]\+CAP_\([A-Z0-9_]\+\)[ \t]\+\([0-9xa-f]\+\)\(.*\)$/CAP_\1/p' | \
-+  LC_ALL=C sort
-diff --git a/parser/Makefile b/parser/Makefile
-index c22d32da..3e50125a 100644
---- a/parser/Makefile
-+++ b/parser/Makefile
-@@ -287,7 +287,7 @@ af_names.h: ../common/list_af_names.sh
-       # cat $@
- cap_names.h: /usr/include/linux/capability.h
--      echo "$(CAPABILITIES)" | LC_ALL=C sed -n -e "s/[ \\t]\\?CAP_\\([A-Z0-9_]\\+\\)/\{\"\\L\\1\", \\UCAP_\\1\},\\n/pg" > $@
-+      ../common/list_capabilities.sh | LC_ALL=C sed -n -e "s/[ \\t]\\?CAP_\\([A-Z0-9_]\\+\\)/\{\"\\L\\1\", \\UCAP_\\1\},\\n/pg" > $@
- tst_lib: lib.c parser.h $(filter-out lib.o, ${TEST_OBJECTS})
-       $(CXX) $(TEST_CFLAGS) -o $@ $< $(filter-out $(<:.c=.o), ${TEST_OBJECTS}) $(TEST_LDFLAGS) $(TEST_LDLIBS)
-diff --git a/utils/Makefile b/utils/Makefile
-index 68f8c376..ea9e0601 100644
---- a/utils/Makefile
-+++ b/utils/Makefile
-@@ -80,7 +80,7 @@ clean: pod_clean
- .SILENT: check_severity_db
- check_severity_db: /usr/include/linux/capability.h severity.db
-       # The sed statement is based on the one in the parser's makefile
--      RC=0 ; for cap in ${CAPABILITIES} ; do \
-+      RC=0 ; for cap in $(shell ../common/list_capabilities.sh) ; do \
-           if !  grep -q -w $${cap} severity.db ; then \
-               echo "Warning! capability $${cap} not found in severity.db" ; \
-               RC=1 ; \
-diff --git a/utils/vim/create-apparmor.vim.py b/utils/vim/create-apparmor.vim.py
-index fea134f6..6a5f02a2 100644
---- a/utils/vim/create-apparmor.vim.py
-+++ b/utils/vim/create-apparmor.vim.py
-@@ -45,7 +45,7 @@ def cmd(command, input=None, stderr=subprocess.STDOUT, stdout=subprocess.PIPE, s
-     return [sp.returncode, out + outerr]
- # get capabilities list
--(rc, output) = cmd(['make', '-s', '--no-print-directory', 'list_capabilities'])
-+(rc, output) = cmd(['../../common/list_capabilities.sh'])
- if rc != 0:
-     sys.stderr.write("make list_capabilities failed: " + output)
-     exit(rc)
--- 
-2.26.2
-
-
-From af0c288fcd4b9ddbf3a062d6d0e1c9618e8f3c75 Mon Sep 17 00:00:00 2001
-From: Christian Boltz <apparmor@cboltz.de>
-Date: Sun, 29 Mar 2020 00:07:11 +0100
-Subject: [PATCH 4/4] fix capabilities in apparmor.vim
-
-https://gitlab.com/apparmor/apparmor/-/merge_requests/461 /
-e92da079ca12e776991bd36524430bd67c1cb72a changed creating the
-capabilities to use a script.
-
-A side effect is that the list is now separated by \n instead of
-spaces. Adjust create-apparmor.vim.py to the new output.
-
-(cherry picked from commit 60b005788e79c1be7276349242e0cc97b99f7118)
----
- utils/vim/create-apparmor.vim.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/utils/vim/create-apparmor.vim.py b/utils/vim/create-apparmor.vim.py
-index 6a5f02a2..b5df957a 100644
---- a/utils/vim/create-apparmor.vim.py
-+++ b/utils/vim/create-apparmor.vim.py
-@@ -50,7 +50,7 @@ if rc != 0:
-     sys.stderr.write("make list_capabilities failed: " + output)
-     exit(rc)
--capabilities = re.sub('CAP_', '', output.strip()).lower().split(" ")
-+capabilities = re.sub('CAP_', '', output.strip()).lower().split('\n')
- benign_caps = []
- for cap in capabilities:
-     if cap not in danger_caps:
--- 
-2.26.2
-
diff --git a/apparmor-2.13.4-run_variable.patch b/apparmor-2.13.4-run_variable.patch
deleted file mode 100644 (file)
index e3a59cf..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-From 454fca7483eae7b7ee613343c2c02abaa20e37e3 Mon Sep 17 00:00:00 2001
-From: nl6720 <nl6720@gmail.com>
-Date: Thu, 13 Feb 2020 09:58:33 +0200
-Subject: [PATCH] Add "run" variable
-
-Signed-off-by: nl6720 <nl6720@gmail.com>
-(cherry picked from commit 452b5b8735e449cba29a1fb25c9bff38ba8763ec)
----
- parser/apparmor.d.pod               | 1 +
- profiles/apparmor.d/tunables/global | 1 +
- profiles/apparmor.d/tunables/run    | 1 +
- 3 files changed, 3 insertions(+)
- create mode 100644 profiles/apparmor.d/tunables/run
-
-diff --git a/parser/apparmor.d.pod b/parser/apparmor.d.pod
-index 662830bd..59ac72c9 100644
---- a/parser/apparmor.d.pod
-+++ b/parser/apparmor.d.pod
-@@ -1279,6 +1279,7 @@ provided AppArmor policy:
-   @{apparmorfs}
-   @{sys}
-   @{tid}
-+  @{run}
-   @{XDG_DESKTOP_DIR}
-   @{XDG_DOWNLOAD_DIR}
-   @{XDG_TEMPLATES_DIR}
-diff --git a/profiles/apparmor.d/tunables/global b/profiles/apparmor.d/tunables/global
-index 28d6fc6d..3b6f99cc 100644
---- a/profiles/apparmor.d/tunables/global
-+++ b/profiles/apparmor.d/tunables/global
-@@ -19,3 +19,4 @@
- #include <tunables/kernelvars>
- #include <tunables/xdg-user-dirs>
- #include <tunables/share>
-+#include <tunables/run>
-diff --git a/profiles/apparmor.d/tunables/run b/profiles/apparmor.d/tunables/run
-new file mode 100644
-index 00000000..e535d2fe
---- /dev/null
-+++ b/profiles/apparmor.d/tunables/run
-@@ -0,0 +1 @@
-+@{run}=/run /var/run
--- 
-2.26.2
-
index 97954bc79b4eae1e18e7c6244a69bea9fe1dea45..f08efcbb263aff5df53d0bc93250ee4c969127cf 100644 (file)
@@ -13,15 +13,14 @@ diff -ur apparmor-2.12.org/parser/parser_main.c apparmor-2.12/parser/parser_main
 diff -ur apparmor-2.12.org/parser/policy_cache.c apparmor-2.12/parser/policy_cache.c
 --- apparmor-2.12.org/parser/policy_cache.c    2017-12-24 09:48:31.000000000 +0100
 +++ apparmor-2.12/parser/policy_cache.c        2018-01-10 09:30:27.533641865 +0100
-@@ -78,6 +78,15 @@
+@@ -78,6 +78,14 @@
        cache_tstamp = t;
  }
  
 +void cache_tstamp_final_check(void)
 +{
 +      if (tstamp_cmp(cache_tstamp, mru_policy_tstamp) != 0) {
-+              if (debug_cache)
-+                      pwarn("%s: cache mtime is different than policy files mtimes\n", progname);
++              pwarn(WARN_CACHE, "%s: cache mtime is different than policy files mtimes\n", progname);
 +              mru_skip_cache = 1;
 +      }
 +}
index 19ad4dbe3dcf62ce031700e597d9912cf564b2da..d31e4facb58689140e92b8a1546f8b58dd57b9c1 100644 (file)
@@ -1,29 +1,13 @@
 === modified file 'parser/rc.apparmor.functions'
---- parser/rc.apparmor.functions       2011-06-01 14:52:35 +0000
-+++ parser/rc.apparmor.functions       2011-07-14 06:56:45 +0000
-@@ -206,7 +207,7 @@
-                       if force_complain "${profile}" ; then
-                               COMPLAIN="-C"
-                       fi
--                      $PARSER $ABSTRACTIONS $PARSER_ARGS $COMPLAIN "$profile" > /dev/null
-+                      $PARSER $ABSTRACTIONS $PARSER_ARGS $PARSER_CUSTOM_ARGS -W $COMPLAIN "$profile" > /dev/null
-                       if [ $? -ne 0 ]; then
-                               aa_log_failure_msg "$profile failed to load"
-                               STATUS=1
-
-=== modified file 'parser/subdomain.conf'
---- parser/subdomain.conf      2011-01-13 21:58:26 +0000
-+++ parser/subdomain.conf      2011-07-14 06:59:27 +0000
-@@ -23,6 +23,11 @@
- # Enable the AppArmor event daemon for reporting?
- APPARMOR_ENABLE_AAEVENTD="no"
+--- parser/rc.apparmor.functions~      2020-12-02 12:01:37.000000000 +0100
++++ parser/rc.apparmor.functions       2021-02-07 15:19:11.388572849 +0100
+@@ -32,7 +32,7 @@
+ # Some nice defines that we use
  
-+## Path:      System/AppArmor
-+## Description: Custom user flags for apparmor profile parser
-+#
-+PARSER_CUSTOM_ARGS=""
-+
- #SUBDOMAIN_MODULE_PANIC=XXX
- #This option controls how subdomain behaves when the init script attempts
- #to load the AppArmor module and fails.  There are 4 options
+ PARSER=/sbin/apparmor_parser
+-PARSER_OPTS=
++PARSER_OPTS="-W"
+ # Suppress warnings when booting in quiet mode
+ if [ "${QUIET:-no}" = yes ] || [ "${quiet:-n}" = y ]; then
+       PARSER_OPTS="$PARSER_OPTS --quiet"
 
index f574ecbd65f4c661c665e757ccad9a1b15f223d9..d47e4e2ba4a6aa70ab97bd9de2ce23316c6df24b 100644 (file)
@@ -6,19 +6,18 @@
 Summary:       AppArmor userlevel parser utility
 Summary(pl.UTF-8):     Narzędzie przestrzeni użytkownika do przetwarzania AppArmor
 Name:          apparmor-parser
-Version:       2.13.4
-Release:       2
+Version:       3.0.1
+Release:       1
 Epoch:         1
 License:       GPL v2
 Group:         Applications/System
-Source0:       http://launchpad.net/apparmor/2.13/%{version}/+download/apparmor-%{version}.tar.gz
-# Source0-md5: a50b793a3362551f07733be3df9c328f
+Source0:       http://launchpad.net/apparmor/3.0/%{version}/+download/apparmor-%{version}.tar.gz
+# Source0-md5: e05eab22bdd1dfc64854856a7292cf09
 Source1:       %{name}.init
 Patch0:                %{name}-pld.patch
 # Drop when upstream does cache rebuild based on hash and not on mtime
 Patch1:                %{name}-cache-rebuild.patch
-Patch2:                apparmor-2.13.4-make4.3.patch
-Patch3:                apparmor-2.13.4-run_variable.patch
+Patch2:                cap.patch
 URL:           http://wiki.apparmor.net/
 BuildRequires: bison
 BuildRequires: flex
@@ -59,7 +58,6 @@ SubDomain.
 %patch0 -p0
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
 
 # avoid unnecessary rebuilding on install
 %{__sed} -i -e '/^\.PHONY: af_names.h/d' parser/Makefile
@@ -82,7 +80,7 @@ SubDomain.
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/lib/apparmor,/subdomain}
+install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/lib/apparmor}
 
 %{__make} -C parser install \
        DESTDIR=$RPM_BUILD_ROOT \
@@ -112,16 +110,14 @@ fi
 %attr(755,root,root) %{_sbindir}/aa-teardown
 %dir %{_sysconfdir}/apparmor
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apparmor/parser.conf
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apparmor/subdomain.conf
 %attr(754,root,root) /etc/rc.d/init.d/apparmor
 %{systemdunitdir}/apparmor.service
 %dir /lib/apparmor
 /lib/apparmor/rc.apparmor.functions
 %attr(754,root,root) /lib/apparmor/apparmor.systemd
-%dir /subdomain
 %dir /var/lib/apparmor
 %{_mandir}/man5/apparmor.d.5*
-%{_mandir}/man5/subdomain.conf.5*
 %{_mandir}/man7/apparmor.7*
+%{_mandir}/man7/apparmor_xattrs.7*
 %{_mandir}/man8/aa-teardown.8*
 %{_mandir}/man8/apparmor_parser.8*
diff --git a/cap.patch b/cap.patch
new file mode 100644 (file)
index 0000000..e0e3b3d
--- /dev/null
+++ b/cap.patch
@@ -0,0 +1,11 @@
+--- apparmor/parser/base_cap_names.h~  2021-02-07 15:05:22.861787137 +0100
++++ apparmor/parser/base_cap_names.h   2021-02-07 15:33:32.728756353 +0100
+@@ -12,6 +12,8 @@
+ {"chown", CAP_CHOWN, NO_BACKMAP_CAP, CAPFLAG_BASE_FEATURE},
++{"context", CAP_CONTEXT, NO_BACKMAP_CAP, CAPFLAG_BASE_FEATURE},
++
+ {"dac_override", CAP_DAC_OVERRIDE, NO_BACKMAP_CAP, CAPFLAG_BASE_FEATURE},
+ {"dac_read_search", CAP_DAC_READ_SEARCH, NO_BACKMAP_CAP, CAPFLAG_BASE_FEATURE},
This page took 0.100808 seconds and 4 git commands to generate.