]> git.pld-linux.org Git - packages/apcupsd.git/blobdiff - apcupsd.spec
- updated configure patch is back
[packages/apcupsd.git] / apcupsd.spec
index fc0f5baac9c8bf1460afc0f8a873d3f69c1d98a8..d8fa78c24a950b3cb8936e6200768936b310ac00 100644 (file)
@@ -1,26 +1,35 @@
 #
 # Conditional build:
-%bcond_with    usb     # with USB support
+%bcond_without test    # without TEST support
+%bcond_without usb     # without USB support
+%bcond_without net     # without network support
+%bcond_without cgi     # with CGI program support
+%bcond_with    snmp    # with SNMP support
 #
 Summary:       Power management software for APC UPS hardware
 Summary(pl):   Oprogramowanie do zarz±dzania energi± dla UPS-ów APC
 Name:          apcupsd
-Version:       3.10.12
-Release:       0.9
+Version:       3.12.1
+Release:       0.1
 License:       GPL v2
 Group:         Networking/Daemons
 Source0:       http://dl.sourceforge.net/apcupsd/%{name}-%{version}.tar.gz
-# Source0-md5: 4c35774d587c54276cf03926768ad551
+# Source0-md5: d2e710176430a28d624500e145d9ffe3
 Source1:       %{name}.init
 Source2:       %{name}.logrotate
+Source3:       %{name}.sysconfig
 Patch0:                %{name}-configure.patch
 URL:           http://www.apcupsd.com/
 BuildRequires: autoconf
-Requires(post,preun):  /sbin/chkconfig
+BuildRequires: automake
+%{?with_snmp:BuildRequires:    net-snmp-devel}
 Requires(post):        fileutils
+Requires(post,preun):  /sbin/chkconfig
+Requires:      rc-scripts
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/apcupsd
+%define         _cgidir        /home/services/httpd/cgi-bin
 
 %description
 UPS power management under Linux for APCC Products. It allows your
@@ -36,30 +45,51 @@ komputerowi dzia
 odpowiednio uruchamia kontrolowany shutdown przy d³u¿szej awarii
 zasilania.
 
+%package cgi 
+Summary:        upsstats - Web-based UPS status viewer
+Summary(pl):   upsstats - oparta na WWW przegl±darka stanu UPS-a
+Group:          Applications/Networking
+Requires:       webserver
+
+%description cgi
+upsstats.cgi builds a lightweight web page containing basic UPS status
+information.
+
+%description cgi -l pl
+upsstats.cgi tworzy lekk± stronê WWW zawieraj±c± podstawowe informacje
+o stanie UPS-a.
+
 %prep
 %setup -q
 %patch0 -p1
 
 %build
 cd autoconf
+cp -f /usr/share/automake/config.sub .
 %{__autoconf}
-cp -f ./configure ..
+cp -f configure ..
 cd ..
+
 %configure \
        --with-log-dir=%{_var}/log \
        --with-stat-dir=%{_var}/lib/apcupsd \
-%if %{with usb}
-       --enable-usb \
-       --with-serial-dev=/dev/usb/hiddev[0-15] \
-       --with-upstype=usb \
-       --with-upscable=usb
+%if %{with cgi}
+       --enable-cgi \
+       --with-cgi-bin=/home/services/httpd/cgi-bin \
+%endif
+       %{?with_test:--enable-test} \
+%if %{with net}
+       --enable-net \
+       --enable-master-slave \
 %endif
+       %{?with_snmp:--enable-snmp} \
+       %{?with_usb:--enable-usb}
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/etc/{apcupsd,logrotate.d,rc.d/init.d} \
+install -d $RPM_BUILD_ROOT/etc/{apcupsd,logrotate.d,rc.d/init.d,sysconfig} \
        $RPM_BUILD_ROOT/var/{log,lib/apcupsd}
 
 %{__make} install \
@@ -67,6 +97,7 @@ install -d $RPM_BUILD_ROOT/etc/{apcupsd,logrotate.d,rc.d/init.d} \
 
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/apcupsd
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/apcupsd
+install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/apcupsd
 
 touch $RPM_BUILD_ROOT/var/log/apcupsd.events
 touch $RPM_BUILD_ROOT/var/lib/apcupsd/apcupsd.status
@@ -80,11 +111,9 @@ EOF
 rm -rf $RPM_BUILD_ROOT
 
 %post
-if [ "$1" = "1" ]; then
-       /sbin/chkconfig --add apcupsd
-fi
+/sbin/chkconfig --add apcupsd
 if [ -f /var/lock/subsys/apcupsd ]; then
-        /etc/rc.d/init.d/apcupsd restart >&2
+       /etc/rc.d/init.d/apcupsd restart >&2
 else
        echo "Run \"/etc/rc.d/init.d/apcupsd start\" to start apcupsd daemon."
 fi
@@ -94,26 +123,38 @@ if [ "$1" = "0" ]; then
        if [ -f /var/lock/subsys/apcupsd ]; then
                /etc/rc.d/init.d/apcupsd stop >&2
        fi
-/sbin/chkconfig --del apcupsd
+       /sbin/chkconfig --del apcupsd
 fi
 
 %files
 %defattr(644,root,root,755)
-%doc ChangeLog Developers doc/{README.apcaccess,developers_manual,home-page,logo}
-%{_mandir}/man8/apcupsd.*
+%doc ChangeLog Developers
 %attr(755,root,root) %{_sbindir}/*
-%attr(640,root,root) %config(noreplace) %{_sysconfdir}/apcupsd.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apcupsd.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/apcupsd
 %attr(754,root,root) %{_sysconfdir}/apccontrol
 %attr(754,root,root) %{_sysconfdir}/changeme
 %attr(754,root,root) %{_sysconfdir}/commfailure
 %attr(754,root,root) %{_sysconfdir}/commok
-%attr(754,root,root) %{_sysconfdir}/mainsback
+#%attr(754,root,root) %{_sysconfdir}/mainsback
 %attr(754,root,root) %{_sysconfdir}/masterconnect
 %attr(754,root,root) %{_sysconfdir}/mastertimeout
 %attr(754,root,root) %{_sysconfdir}/onbattery
+%attr(754,root,root) %{_sysconfdir}/offbattery
+%if %{with cgi}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hosts.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/multimon.conf
+%{_sysconfdir}/apcupsd.css
+%endif
 %attr(754,root,root) /etc/rc.d/init.d/apcupsd
 %attr(754,root,root) /etc/rc.d/init.d/halt
-%attr(640,root,root) /etc/logrotate.d/apcupsd
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/apcupsd
+%dir %{_sysconfdir}
 %dir /var/lib/apcupsd
 %attr(640,root,root) %ghost /var/log/apcupsd.events
 %attr(640,root,root) %ghost /var/lib/apcupsd/apcupsd.status
+%{_mandir}/man8/apcupsd.*
+
+%files cgi
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_cgidir}/*.cgi
This page took 0.131726 seconds and 4 git commands to generate.