]> git.pld-linux.org Git - packages/apcupsd.git/blobdiff - apcupsd.spec
- use functions
[packages/apcupsd.git] / apcupsd.spec
index e3d0583c2487631b571da3da967fd134c82b3632..c0990d1fe05c3a9225da58d77d64683ba63e54ec 100644 (file)
@@ -1,35 +1,46 @@
+# TODO
+# - /usr/share/hal/fdi/policy/20thirdparty/80-apcupsd-ups-policy.fdi
 #
 # Conditional build:
-%bcond_without test    # without TEST support
-%bcond_without usb     # without USB support
+%bcond_without cgi     # without CGI program support
+%bcond_without gapcmon # without gapcmon GUI
 %bcond_without net     # without network support
-%bcond_without cgi     # with CGI program support
 %bcond_with    snmp    # with SNMP support
+%bcond_without test    # without TEST support
+%bcond_without usb     # without USB support
 #
 Summary:       Power management software for APC UPS hardware
-Summary(pl):   Oprogramowanie do zarz±dzania energi± dla UPS-ów APC
+Summary(pl.UTF-8):     Oprogramowanie do zarządzania energią dla UPS-ów APC
 Name:          apcupsd
-Version:       3.12.1
-Release:       0.1
+Version:       3.14.10
+Release:       1
 License:       GPL v2
 Group:         Networking/Daemons
-Source0:       http://dl.sourceforge.net/apcupsd/%{name}-%{version}.tar.gz
-# Source0-md5: d2e710176430a28d624500e145d9ffe3
+Source0:       http://downloads.sourceforge.net/apcupsd/%{name}-%{version}.tar.gz
+# Source0-md5: 5928822d855c5cf7ac29655e3e0b8c23
 Source1:       %{name}.init
 Source2:       %{name}.logrotate
 Source3:       %{name}.sysconfig
 Patch0:                %{name}-configure.patch
+Patch1:                %{name}-pcnet-seconds.patch
 URL:           http://www.apcupsd.com/
+%{?with_gapcmon:BuildRequires: GConf2-devel >= 2.0}
 BuildRequires: autoconf
 BuildRequires: automake
+BuildRequires: gd-devel
+%{?with_gapcmon:BuildRequires: gtk+2-devel >= 2:2.4.0}
+BuildRequires: man
 %{?with_snmp:BuildRequires:    net-snmp-devel}
+BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: util-linux
 Requires(post):        fileutils
 Requires(post,preun):  /sbin/chkconfig
 Requires:      rc-scripts
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/apcupsd
-%define         _cgidir        /home/services/httpd/cgi-bin
+%define                _cgidir         /home/services/httpd/cgi-bin
 
 %description
 UPS power management under Linux for APCC Products. It allows your
@@ -38,39 +49,56 @@ time or the life of the batteries in your BackUPS, BackUPS Pro,
 SmartUPS v/s, or SmartUPS, and then properly executes a controlled
 shutdown during an extended power failure.
 
-%description -l pl
-Oprogramowanie do zarz±dzania energi± dla UPS-ów APC. Pozwala
-komputerowi dzia³aæ po awarii zasilania przez okre¶lony czas lub czas
-¿ycia akumulatorów w BackUPS, BackUPS Pro, SmartUPS v/s, SmartUPS oraz
-odpowiednio uruchamia kontrolowany shutdown przy d³u¿szej awarii
+%description -l pl.UTF-8
+Oprogramowanie do zarządzania energią dla UPS-ów APC. Pozwala
+komputerowi działać po awarii zasilania przez określony czas lub czas
+życia akumulatorów w BackUPS, BackUPS Pro, SmartUPS v/s, SmartUPS oraz
+odpowiednio uruchamia kontrolowany shutdown przy dłuższej awarii
 zasilania.
 
-%package cgi 
-Summary:        upsstats - Web-based UPS status viewer
-Summary(pl):   upsstats - oparta na WWW przegl±darka stanu UPS-a
-Group:          Applications/Networking
-Requires:       webserver
+%package cgi
+Summary:       upsstats - Web-based UPS status viewer
+Summary(pl.UTF-8):     upsstats - oparta na WWW przeglądarka stanu UPS-a
+Group:         Applications/Networking
+Requires:      webserver
 
 %description cgi
 upsstats.cgi builds a lightweight web page containing basic UPS status
 information.
 
-%description cgi -l pl
-upsstats.cgi tworzy lekk± stronê WWW zawieraj±c± podstawowe informacje
+%description cgi -l pl.UTF-8
+upsstats.cgi tworzy lekką stronę WWW zawierającą podstawowe informacje
 o stanie UPS-a.
 
+%package gapcmon
+Summary:       Apcupsd GUI monitoring application
+Summary(pl.UTF-8):     Aplikacja GUI monitorowania Apcupsd
+Group:         X11/Applications
+
+%description gapcmon
+GNOME/GTK+ based application which integrates into most desktop panels
+(not just GNOME). It monitors one or more Apcupsd instances using
+Apcupsd's NIS networking server. The status of each UPS is shown with
+a icon.
+
+%description gapcmon -l pl.UTF-8
+Oparta na GNOME/GTK+ aplikacja, która integruje się z panelami (nie
+tylko Gnome). Monitoruje jedną bądź kilka instancji Apcupsd za pomocą
+serwera NIS. Status każdego UPS-a przedstawia ikona.
+
 %prep
 %setup -q
-#%patch0 -p1
+%patch0 -p1
+%patch1 -p1
+for i in configure.in aclocal.m4 config.h.in; do install autoconf/$i .;done
+cp -f %{_datadir}/automake/config.sub autoconf
 
 %build
-cd autoconf
-cp -f /usr/share/automake/config.sub .
 %{__autoconf}
-cp -f configure ..
-cd ..
-
 %configure \
+       APCUPSD_MAIL="/bin/mail" \
+       SHUTDOWN="/sbin/shutdown" \
+       WALL="%{_bindir}/wall" \
        --with-log-dir=%{_var}/log \
        --with-stat-dir=%{_var}/lib/apcupsd \
 %if %{with cgi}
@@ -80,8 +108,8 @@ cd ..
        %{?with_test:--enable-test} \
 %if %{with net}
        --enable-net \
-       --enable-master-slave \
 %endif
+       %{?with_gapcmon:--enable-gapcmon} \
        %{?with_snmp:--enable-snmp} \
        %{?with_usb:--enable-usb}
 
@@ -112,35 +140,30 @@ rm -rf $RPM_BUILD_ROOT
 
 %post
 /sbin/chkconfig --add apcupsd
-if [ -f /var/lock/subsys/apcupsd ]; then
-       /etc/rc.d/init.d/apcupsd restart >&2
-else
-       echo "Run \"/etc/rc.d/init.d/apcupsd start\" to start apcupsd daemon."
-fi
+%service apcupsd restart "apcupsd daemon"
 
 %preun
 if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/apcupsd ]; then
-               /etc/rc.d/init.d/apcupsd stop >&2
-       fi
+       %service apcupsd stop
        /sbin/chkconfig --del apcupsd
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc ChangeLog Developers
-%attr(755,root,root) %{_sbindir}/*
+%attr(755,root,root) %{_sbindir}/apcaccess
+%attr(755,root,root) %{_sbindir}/apctest
+%attr(755,root,root) %{_sbindir}/apcupsd
+%attr(755,root,root) %{_sbindir}/smtp
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apcupsd.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/apcupsd
 %attr(754,root,root) %{_sysconfdir}/apccontrol
-%attr(754,root,root) %{_sysconfdir}/changeme
-%attr(754,root,root) %{_sysconfdir}/commfailure
-%attr(754,root,root) %{_sysconfdir}/commok
-#%attr(754,root,root) %{_sysconfdir}/mainsback
-%attr(754,root,root) %{_sysconfdir}/masterconnect
-%attr(754,root,root) %{_sysconfdir}/mastertimeout
-%attr(754,root,root) %{_sysconfdir}/onbattery
-%attr(754,root,root) %{_sysconfdir}/offbattery
+%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/changeme
+%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/commfailure
+%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/commok
+#%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mainsback
+%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/onbattery
+%attr(754,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/offbattery
 %if %{with cgi}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hosts.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/multimon.conf
@@ -153,8 +176,22 @@ fi
 %dir /var/lib/apcupsd
 %attr(640,root,root) %ghost /var/log/apcupsd.events
 %attr(640,root,root) %ghost /var/lib/apcupsd/apcupsd.status
-%{_mandir}/man8/apcupsd.*
+%{_mandir}/man8/apcupsd.8*
+%{_mandir}/man8/apctest.8*
+%{_mandir}/man8/apcaccess.8*
+%{_mandir}/man8/apccontrol.8*
+%{_mandir}/man5/apcupsd.conf.5*
 
+%if %{with cgi}
 %files cgi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_cgidir}/*.cgi
+%endif
+
+%if %{with gapcmon}
+%files gapcmon
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/gapcmon
+%{_desktopdir}/gapcmon.desktop
+%{_pixmapsdir}/*.png
+%endif
This page took 0.580837 seconds and 4 git commands to generate.