]> git.pld-linux.org Git - packages/apcupsd.git/blobdiff - apcupsd.spec
- added net support
[packages/apcupsd.git] / apcupsd.spec
index 41c44737e1c662e78e32e159376a955e9c8b48be..2e0d0f4b7eadec7691e5810136ce1d7e1b60ffc1 100644 (file)
@@ -1,24 +1,27 @@
 #
 # Conditional build:
+%bcond_without test    # without TEST support
 %bcond_with    usb     # with USB support
+%bcond_with    net     # with network support
 #
 Summary:       Power management software for APC UPS hardware
 Summary(pl):   Oprogramowanie do zarz±dzania energi± dla UPS-ów APC
 Name:          apcupsd
-Version:       3.10.15
-Release:       1
+Version:       3.10.18
+Release:       2
 License:       GPL v2
 Group:         Networking/Daemons
 Source0:       http://dl.sourceforge.net/apcupsd/%{name}-%{version}.tar.gz
-# Source0-md5: 21b2b744ebcaa0010367a403a9c5e66c
+# Source0-md5: 64104a1fface0253e77318ca84948bac
 Source1:       %{name}.init
 Source2:       %{name}.logrotate
+Source3:       %{name}.sysconfig
 Patch0:                %{name}-configure.patch
 URL:           http://www.apcupsd.com/
 BuildRequires: autoconf
 BuildRequires: automake
-Requires(post,preun):  /sbin/chkconfig
 Requires(post):        fileutils
+Requires(post,preun):  /sbin/chkconfig
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/apcupsd
@@ -50,6 +53,8 @@ cd ..
 %configure \
        --with-log-dir=%{_var}/log \
        --with-stat-dir=%{_var}/lib/apcupsd \
+       %{?with_test:--enable-test} \
+       %{?with_net:--enable-net} \
 %if %{with usb}
        --enable-usb \
        --with-serial-dev=/dev/usb/hiddev[0-15] \
@@ -61,7 +66,7 @@ cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/etc/{apcupsd,logrotate.d,rc.d/init.d} \
+install -d $RPM_BUILD_ROOT/etc/{apcupsd,logrotate.d,rc.d/init.d,sysconfig} \
        $RPM_BUILD_ROOT/var/{log,lib/apcupsd}
 
 %{__make} install \
@@ -69,6 +74,7 @@ install -d $RPM_BUILD_ROOT/etc/{apcupsd,logrotate.d,rc.d/init.d} \
 
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/apcupsd
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/apcupsd
+install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/apcupsd
 
 touch $RPM_BUILD_ROOT/var/log/apcupsd.events
 touch $RPM_BUILD_ROOT/var/lib/apcupsd/apcupsd.status
@@ -84,7 +90,7 @@ rm -rf $RPM_BUILD_ROOT
 %post
 /sbin/chkconfig --add apcupsd
 if [ -f /var/lock/subsys/apcupsd ]; then
-        /etc/rc.d/init.d/apcupsd restart >&2
+       /etc/rc.d/init.d/apcupsd restart >&2
 else
        echo "Run \"/etc/rc.d/init.d/apcupsd start\" to start apcupsd daemon."
 fi
@@ -102,7 +108,8 @@ fi
 %doc ChangeLog Developers doc/{README.apcaccess,README.solaris}
 %{_mandir}/man8/apcupsd.*
 %attr(755,root,root) %{_sbindir}/*
-%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/apcupsd.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apcupsd.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/apcupsd
 %attr(754,root,root) %{_sysconfdir}/apccontrol
 %attr(754,root,root) %{_sysconfdir}/changeme
 %attr(754,root,root) %{_sysconfdir}/commfailure
@@ -113,8 +120,8 @@ fi
 %attr(754,root,root) %{_sysconfdir}/onbattery
 %attr(754,root,root) /etc/rc.d/init.d/apcupsd
 %attr(754,root,root) /etc/rc.d/init.d/halt
-%attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/logrotate.d/apcupsd
-%dir /etc/apcupsd
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/apcupsd
+%dir %{_sysconfdir}
 %dir /var/lib/apcupsd
 %attr(640,root,root) %ghost /var/log/apcupsd.events
 %attr(640,root,root) %ghost /var/lib/apcupsd/apcupsd.status
This page took 0.060393 seconds and 4 git commands to generate.