]> git.pld-linux.org Git - packages/apcupsd.git/blob - apcupsd.spec
- added master/slave
[packages/apcupsd.git] / apcupsd.spec
1 #
2 # Conditional build:
3 %bcond_without  test    # without TEST support
4 %bcond_without  usb     # without USB support
5 %bcond_without  net     # without network support
6 %bcond_with     snmp    # with SNMP support
7 #
8 Summary:        Power management software for APC UPS hardware
9 Summary(pl):    Oprogramowanie do zarz±dzania energi± dla UPS-ów APC
10 Name:           apcupsd
11 Version:        3.10.18
12 Release:        3
13 License:        GPL v2
14 Group:          Networking/Daemons
15 Source0:        http://dl.sourceforge.net/apcupsd/%{name}-%{version}.tar.gz
16 # Source0-md5:  64104a1fface0253e77318ca84948bac
17 Source1:        %{name}.init
18 Source2:        %{name}.logrotate
19 Source3:        %{name}.sysconfig
20 Patch0:         %{name}-configure.patch
21 URL:            http://www.apcupsd.com/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 %{?with_snmp:BuildRequires: net-snmp-devel}     
25 Requires(post): fileutils
26 Requires(post,preun):   /sbin/chkconfig
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _sysconfdir     /etc/apcupsd
30
31 %description
32 UPS power management under Linux for APCC Products. It allows your
33 computer/server to run during power problems for a specified length of
34 time or the life of the batteries in your BackUPS, BackUPS Pro,
35 SmartUPS v/s, or SmartUPS, and then properly executes a controlled
36 shutdown during an extended power failure.
37
38 %description -l pl
39 Oprogramowanie do zarz±dzania energi± dla UPS-ów APC. Pozwala
40 komputerowi dzia³aæ po awarii zasilania przez okre¶lony czas lub czas
41 ¿ycia akumulatorów w BackUPS, BackUPS Pro, SmartUPS v/s, SmartUPS oraz
42 odpowiednio uruchamia kontrolowany shutdown przy d³u¿szej awarii
43 zasilania.
44
45 %prep
46 %setup -q
47 %patch0 -p1
48
49 %build
50 cd autoconf
51 cp -f /usr/share/automake/config.sub .
52 %{__autoconf}
53 cp -f ./configure ..
54 cd ..
55 %configure \
56         --with-log-dir=%{_var}/log \
57         --with-stat-dir=%{_var}/lib/apcupsd \
58         %{?with_test:--enable-test} \
59 %if %{?with_net}
60         --enable-net \
61         --enable-master-slave \
62 %endif  
63         %{?with_snmp:--enable-snmp} \
64         %{with usb:--enable-usb}
65
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT/etc/{apcupsd,logrotate.d,rc.d/init.d,sysconfig} \
71         $RPM_BUILD_ROOT/var/{log,lib/apcupsd}
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/apcupsd
77 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/apcupsd
78 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/apcupsd
79
80 touch $RPM_BUILD_ROOT/var/log/apcupsd.events
81 touch $RPM_BUILD_ROOT/var/lib/apcupsd/apcupsd.status
82
83 cat > $RPM_BUILD_ROOT/etc/rc.d/init.d/halt << EOF
84 #!/bin/sh
85 /etc/rc.d/init.d/apcupsd powerdown
86 EOF
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post
92 /sbin/chkconfig --add apcupsd
93 if [ -f /var/lock/subsys/apcupsd ]; then
94         /etc/rc.d/init.d/apcupsd restart >&2
95 else
96         echo "Run \"/etc/rc.d/init.d/apcupsd start\" to start apcupsd daemon."
97 fi
98
99 %preun
100 if [ "$1" = "0" ]; then
101         if [ -f /var/lock/subsys/apcupsd ]; then
102                 /etc/rc.d/init.d/apcupsd stop >&2
103         fi
104 /sbin/chkconfig --del apcupsd
105 fi
106
107 %files
108 %defattr(644,root,root,755)
109 %doc ChangeLog Developers doc/{README.apcaccess,README.solaris}
110 %{_mandir}/man8/apcupsd.*
111 %attr(755,root,root) %{_sbindir}/*
112 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apcupsd.conf
113 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/apcupsd
114 %attr(754,root,root) %{_sysconfdir}/apccontrol
115 %attr(754,root,root) %{_sysconfdir}/changeme
116 %attr(754,root,root) %{_sysconfdir}/commfailure
117 %attr(754,root,root) %{_sysconfdir}/commok
118 %attr(754,root,root) %{_sysconfdir}/mainsback
119 %attr(754,root,root) %{_sysconfdir}/masterconnect
120 %attr(754,root,root) %{_sysconfdir}/mastertimeout
121 %attr(754,root,root) %{_sysconfdir}/onbattery
122 %attr(754,root,root) /etc/rc.d/init.d/apcupsd
123 %attr(754,root,root) /etc/rc.d/init.d/halt
124 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/apcupsd
125 %dir %{_sysconfdir}
126 %dir /var/lib/apcupsd
127 %attr(640,root,root) %ghost /var/log/apcupsd.events
128 %attr(640,root,root) %ghost /var/lib/apcupsd/apcupsd.status
This page took 0.070423 seconds and 3 git commands to generate.