]> git.pld-linux.org Git - packages/apache1.git/commitdiff
- getline patch
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 30 Oct 2009 15:29:54 +0000 (15:29 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache1-getline.patch -> 1.1
    apache1.spec -> 1.209

apache1-getline.patch [new file with mode: 0644]
apache1.spec

diff --git a/apache1-getline.patch b/apache1-getline.patch
new file mode 100644 (file)
index 0000000..ca5c8cd
--- /dev/null
@@ -0,0 +1,78 @@
+--- apache_1.3.41/src/support/logresolve.c~    2009-10-30 17:25:18.000000000 +0200
++++ apache_1.3.41/src/support/logresolve.c     2009-10-30 17:26:43.170695467 +0200
+@@ -73,7 +73,7 @@
+ #include "sa_len.h"
+ static void cgethost(struct sockaddr *sa, char *string, int check);
+-static int getline(char *s, int n);
++static int ap_getline(char *s, int n);
+ static void stats(FILE *output);
+@@ -329,7 +329,7 @@
+  * gets a line from stdin
+  */
+-static int getline (char *s, int n)
++static int ap_getline (char *s, int n)
+ {
+     char *cp;
+@@ -378,7 +378,7 @@
+     for (i = 0; i < MAX_ERR + 2; i++)
+       errors[i] = 0;
+-    while (getline(line, MAXLINE)) {
++    while (ap_getline(line, MAXLINE)) {
+       if (line[0] == '\0')
+           continue;
+       entries++;
+--- apache_1.3.41/src/support/htdigest.c~      2009-10-30 17:25:18.000000000 +0200
++++ apache_1.3.41/src/support/htdigest.c       2009-10-30 17:26:59.554860724 +0200
+@@ -71,7 +71,7 @@
+     while ((line[y++] = line[x++]));
+ }
+-static int getline(char *s, int n, FILE *f)
++static int ap_getline(char *s, int n, FILE *f)
+ {
+     register int i = 0;
+@@ -159,7 +159,7 @@
+ {
+     static char line[MAX_STRING_LEN];
+-    while (!(getline(line, MAX_STRING_LEN, source))) {  
++    while (!(ap_getline(line, MAX_STRING_LEN, source))) {  
+       putline(target, line);
+     }
+ }
+@@ -222,7 +222,7 @@
+     ap_cpystrn(realm, argv[2], sizeof(realm));
+     found = 0;
+-    while (!(getline(line, MAX_STRING_LEN, f))) {
++    while (!(ap_getline(line, MAX_STRING_LEN, f))) {
+       if (found || (line[0] == '#') || (!line[0])) {
+           putline(tfp, line);
+           continue;
+--- apache_1.3.41/src/support/htpasswd.c~      2009-10-30 17:25:18.000000000 +0200
++++ apache_1.3.41/src/support/htpasswd.c       2009-10-30 17:27:11.887151384 +0200
+@@ -98,7 +98,7 @@
+  * Get a line of input from the user, not including any terminating
+  * newline.
+  */
+-static int getline(char *s, int n, FILE *f)
++static int ap_getline(char *s, int n, FILE *f)
+ {
+     register int i = 0;
+@@ -553,7 +553,7 @@
+       char scratch[MAX_STRING_LEN];
+       fpw = fopen(pwfilename, "r");
+-      while (! (getline(line, sizeof(line), fpw))) {
++      while (! (ap_getline(line, sizeof(line), fpw))) {
+           char *colon;
+           if ((line[0] == '#') || (line[0] == '\0')) {
index 546cf61a5390dedfb97428be70bf13b55cbe3d95..529c283124a91d16c9a31b8550607a573b1ea301 100644 (file)
@@ -108,6 +108,7 @@ Patch39:    %{name}-security_htdigest_local_buffer_overflow.patch
 Patch40:       %{name}-security_htpasswd_user_buffer_overflow.patch
 Patch41:       %{name}-security_check_forensic_tempfiles.patch
 Patch42:       %{name}-lingerd.patch
+Patch43:       %{name}-getline.patch
 URL:           http://httpd.apache.org/
 BuildRequires: bash
 BuildRequires: db-devel >= 4.1
@@ -1342,13 +1343,13 @@ Dwa programy testowe/przykładowe cgi: test-cgi and print-env.
 %patch39 -p2
 %patch40 -p2
 %patch41 -p2
-
 %if %{with lingerd}
 mkdir -p lingerd
 cp -a lingerd-*/{README,TUNING,LICENSE,TODO,ChangeLog} lingerd
 cp -a lingerd-*/{apache-1.3/ap_lingerd.c,li_config.h} src/main
 %patch42 -p1
 %endif
+%patch43 -p1
 
 # make manual link with full path
 %{__sed} -i -e 's,href="manual/,href="/manual/,i' htdocs/index.html.*
This page took 0.041847 seconds and 4 git commands to generate.