]> git.pld-linux.org Git - packages/apache1-mod_xslt.git/blame - apache1-mod_xslt.spec
- update config dir macro
[packages/apache1-mod_xslt.git] / apache1-mod_xslt.spec
CommitLineData
da41f258
ER
1# TODO
2# - doesn't build
3# mod_xslt.c:212: warning: passing arg 6 of `SablotRunProcessor' from incompatible pointer type
4# ...
138dba0f 5%define mod_name xslt
7b808378 6%define apxs /usr/sbin/apxs1
3d58c39e 7Summary: Module to serve XML based content
7922c293 8Summary(pl.UTF-8): Moduł do udostępniania dokumentów XML
7b808378 9Name: apache1-mod_%{mod_name}
138dba0f 10Version: 1.1
785649ce 11Release: 1.3
3d58c39e 12License: GPL
078d6d7b
JB
13Group: Networking/Daemons
14Source0: http://dl.sourceforge.net/modxslt/mod_%{mod_name}-%{version}.tar.gz
881b23a4 15# Source0-md5: ce458a48f56cc857c808b71ec27f592d
65f8684c 16Source1: %{name}.conf
17Patch0: %{name}-includes.patch
18Patch1: %{name}-regex.patch
19Patch2: %{name}-make.patch
20Patch3: %{name}-module.patch
078d6d7b 21URL: http://modxslt.userworld.com/
b1548513 22BuildRequires: apache1-devel >= 1.3.39
3a852ba6 23BuildRequires: rpmbuild(macros) >= 1.268
3d58c39e 24BuildRequires: sablotron-devel
785649ce 25Requires: apache1(EAPI)
078d6d7b
JB
26Requires: expat
27Requires: sablotron
3a852ba6 28Obsoletes: apache-mod_xslt <= 1.1
138dba0f 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
3d58c39e 30
da41f258 31%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
405235f2 32%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
3d58c39e 33
34%description
72f23fae
JB
35mod_xslt is a simple Apache module to serve XML based content. Data is
36stored in XML files on the server. The user requests the XML file and
37the translation method via a url such as this:
7ca3f2e3
JB
38http://localhost/sourcefile.html. The module will parse this URL into
39a XML source file and an XSL source file. In the example above, the
40XML file will be sourcefile.xml. The module will open sourcefile.xml
41and determine its DOCTYPE. Based on the DOCTYPE, the XSL file will be
72f23fae
JB
42opened. Should the DOCTYPE be "tutorial", the XSL file opened would be
43tutorial_html.xsl. The content-type returned to the browser is
44text/html. The translation occurs transparently to the user.
3d58c39e 45
2b1fe5af
JR
46%description -l pl.UTF-8
47mod_xslt jest prostym modułem Apache do udostępniania dokumentów XML.
48Dane są zapisane w plikach XML na serwerze. Użytkownik żąda pliku XML
49i tłumaczenia poprzez URL w stylu http://localhost/sourcefile.html.
50Moduł zamienia ten URL na pliki źródłowe XML i XSL. W tym przykładzie
51plikiem XML będzie sourcefile.xml. Moduł otworzy plik sourcefile.xml i
52określi DOCTYPE, na podstawie którego otworzy odpowiedni plik XSL.
53Jeżeli DOCTYPE jest "tutorial", plikiem XSL będzie tutorial_html.xsl.
54Następnie moduł dokona przetwarzania pliku XML za pomocą arkusza XSLT
55i zwróci przeglądarce powstały w ten sposób text/html. Cały proces
56odbywa się w sposób niewidoczny dla użytkownika.
7ca3f2e3 57
3d58c39e 58%prep
138dba0f 59%setup -q -n mod%{mod_name}
60%patch0 -p1
ee54a2b5 61%patch1 -p1
1664a16c 62%patch2 -p1
63%patch3 -p1
3d58c39e 64
65%build
65f8684c 66%{__make} \
67 APXS=%{apxs} \
68 CFLAGS="%{rpmcflags} -DEAPI"
3d58c39e 69
70%install
71rm -rf $RPM_BUILD_ROOT
405235f2 72install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
138dba0f 73
138dba0f 74install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
405235f2 75install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
138dba0f 76
7ca3f2e3
JB
77%clean
78rm -rf $RPM_BUILD_ROOT
79
138dba0f 80%post
3a852ba6 81%service -q apache restart
138dba0f 82
94f9a5c7 83%postun
138dba0f 84if [ "$1" = "0" ]; then
3a852ba6 85 %service -q apache restart
138dba0f 86fi
3d58c39e 87
3d58c39e 88%files
89%defattr(644,root,root,755)
405235f2 90%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
7b808378 91%attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.130526 seconds and 4 git commands to generate.