]> git.pld-linux.org Git - packages/apache1-mod_watch.git/blame - apache1-mod_watch.spec
- converted to UTF-8
[packages/apache1-mod_watch.git] / apache1-mod_watch.spec
CommitLineData
bc94de1d
ER
1# TODO
2# - strange error when accessing "/~watch-info":
3# [Thu Feb 10 03:16:16 2005] [warn] " 1\n\b" concurrency counter went negative; resetting to zero
4
5%bcond_without ipv6 # disable IPv6 support
6
b584562d 7%define mod_name watch
859ff54a 8%define apxs /usr/sbin/apxs1
b584562d 9Summary: Apache module: Monitoring Interface for MRTG
bac4139c 10Summary(pl.UTF-8): Moduł do apache: Interfejs do monitorowania za pomocą MRTG
859ff54a 11Name: apache1-mod_%{mod_name}
12Version: 3.18
a0f01afd 13Release: 4
b584562d
AM
14License: BSD
15Group: Networking/Daemons
859ff54a 16Source0: http://www.snert.com/Software/download/mod_watch%(echo %{version} | tr -d .).tgz
17# Source0-md5: 1409df800f24214bed16ca753b9967ff
b584562d 18Source1: %{name}.conf
38ec6ba3 19Patch0: %{name}-PLD-v6stuff.patch
b584562d
AM
20URL: http://www.snert.com/Software/mod_watch/
21BuildRequires: %{apxs}
4332eeac 22#{?with_ipv6:BuildRequires: apache1(ipv6)-devel}
4d361588 23BuildRequires: apache1-devel >= 1.3.33-2
53eaafcc 24BuildRequires: rpmbuild(macros) >= 1.268
a0f01afd 25Requires: apache1(EAPI)
53eaafcc 26Obsoletes: apache-mod_watch <= 3.18
b584562d
AM
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
bc94de1d
ER
29%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
30%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
b584562d
AM
31
32%description
33This module will watch and collect the bytes, requests, and documents
34in & out per virtual host, file owner, remote-ip address, directory or
35location, and the web server as a whole. This module was designed for
36use with MRTG, which will make nice graphical representations of the
37data, but is general enough that it can be applied to other purposes,
38as the raw data is accessed by a URL. This module supports
39mod_vhost_alias and mod_gzip.
40
bac4139c
JR
41%description -l pl.UTF-8
42Ten moduł kontroluje i zbiera informacje na temat ilości przesłanych
43bajtów (przychodzących i wychodzących) wg. serwera wirtualnego,
44właściciela plików, zdalnego adresu ip, katalogu lub lokacji oraz
45serwera jako całości. Moduł został zaprojektowany do pracy z MRTG,
46dzięki czemu otrzymamy ładną, graficzną reprezentacje danych. Moduł
4d361588 47wspiera mod_vhost_alias oraz mod_gzip.
b584562d
AM
48
49%prep
50%setup -q -n mod_%{mod_name}-%{version}
bc94de1d
ER
51%{?with_ipv6:%patch -p0}
52
53mv mod_watch.html mod_watch_pl.html
b584562d
AM
54
55%build
859ff54a 56%{__make} build-dynamic \
57 APXS=%{apxs}
b584562d
AM
58
59%install
60rm -rf $RPM_BUILD_ROOT
bc94de1d 61install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
b584562d
AM
62
63install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
bc94de1d 64install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
b584562d 65
cf7f9f5c 66sed -e 's/<!--#/<!--/g' index.shtml > mod_watch.html
67
c6f9b392
JB
68%clean
69rm -rf $RPM_BUILD_ROOT
70
b584562d 71%post
53eaafcc 72%service -q apache restart
b584562d 73
7427062a 74%postun
b584562d 75if [ "$1" = "0" ]; then
53eaafcc 76 %service -q apache restart
b584562d
AM
77fi
78
bc94de1d 79%triggerpostun -- %{name} < 3.18-1.1
932ab3fe 80if grep -q '^Include conf\.d/\*\.conf' /etc/apache/apache.conf; then
bc94de1d
ER
81 %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
82 sed -i -e '
83 /^Include.*mod_%{mod_name}\.conf/d
84 ' /etc/apache/apache.conf
85else
86 # they're still using old apache.conf
87 sed -i -e '
88 s,^Include.*mod_%{mod_name}\.conf,Include %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf,
89 ' /etc/apache/apache.conf
90fi
53eaafcc 91%service -q apache restart
bc94de1d 92
b584562d
AM
93%files
94%defattr(644,root,root,755)
38ec6ba3 95%doc CHANGES* *.html
4d361588 96%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
b584562d 97%attr(755,root,root) %{_pkglibdir}/*
This page took 0.09292 seconds and 4 git commands to generate.