]> git.pld-linux.org Git - packages/apache1-mod_throttle.git/blame - apache1-mod_throttle.spec
- changed summary and adapterized
[packages/apache1-mod_throttle.git] / apache1-mod_throttle.spec
CommitLineData
3a912cef 1Summary: Bandwidth & Request Throttling
39868455 2Name: apache-mod_throttle
3Version: 3.1.2
4Release: 1
5License: Anthony Howe
6Group: Networking/Daemons
3a912cef 7Group(de): Netzwerkwesen/Server
8Group(pl): Sieciowe/Serwery
39868455 9Source0: http://www.snert.com/Software/mod_throttle/mod_throttle312.tgz
10URL: http://www.snert.com/Software/mod_throttle/
11BuildRequires: apache-devel
12Requires: apache >= 1.3.1
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15%define _libexecdir %{_libdir}/apache
16%define _htmldocdir /home/httpd/manual/mod
17
18%description
19This Apache module is intended to reduce the load on your server &
3a912cef 20bandwidth generated by popular virtual hosts, directories, locations,
21or users according to supported polices (see below) that decide when
22to delay or refuse requests. Also mod_throttle can track and throttle
23incoming connections by IP address or by authenticated remote user.
39868455 24
25%prep
26%setup -q -n mod_throttle-%{version}
27
28%build
3a912cef 29apxs -D SUEXEC_BIN="\"\\\"%{_sbindir}/suexec\\\"\"" -o mod_throttle.so -c *.c
39868455 30# to don't bother about ssi counter inside
31mv index.shtml index.html
32
33%install
34rm -rf $RPM_BUILD_ROOT
35install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
36
37install mod_throttle.so $RPM_BUILD_ROOT%{_libexecdir}
38install *.html $RPM_BUILD_ROOT%{_htmldocdir}
39
40gzip -9nf *.txt
41
42%post
43%{_sbindir}/apxs -e -a -n throttle %{_libexecdir}/mod_throttle.so 1>&2
44if [ -f /var/lock/subsys/httpd ]; then
45 /etc/rc.d/init.d/httpd restart 1>&2
46else
47 echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
48fi
49
50%preun
51if [ "$1" = "0" ]; then
52 %{_sbindir}/apxs -e -A -n throttle %{_libexecdir}/mod_throttle.so 1>&2
53 if [ -f /var/lock/subsys/httpd ]; then
54 /etc/rc.d/init.d/httpd restart 1>&2
55 fi
56fi
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(644,root,root,755)
63%doc *.gz
64%doc %{_htmldocdir}/index.html
65%attr(755,root,root) %{_libexecdir}/*
This page took 0.079446 seconds and 4 git commands to generate.