]> git.pld-linux.org Git - packages/apache1-mod_suid.git/blobdiff - apache1-mod_suid.spec
- restart apache in %postun rather in %preun as the config file, loading module
[packages/apache1-mod_suid.git] / apache1-mod_suid.spec
index ce8983a27784324e34ecce009ebb04b17edb8f25..9aaf6741513854b1c8dabfd501c3fcc111758aaa 100644 (file)
@@ -1,29 +1,30 @@
 %define                mod_name        suid
-%define                ver             1.1
-%define        apxs            /usr/sbin/apxs
+%define        apxs            /usr/sbin/apxs1
 Summary:       Apache module: execution of scripts under their own uids
-Summary(pl):   Modu³ do apache: wykonywanie skryptow pod wskazanym uidem
-Name:          apache-mod_%{mod_name}
-Version:       %{ver}
-Release:       0.1
+Summary(pl):   Modu³ do apache: wykonywanie skryptów pod wskazanym uidem
+Name:          apache1-mod_%{mod_name}
+Version:       1.1
+Release:       2
 License:       GPL
 Group:         Networking/Daemons
 Source0:       http://www.jdimedia.nl/igmar/mod_%{mod_name}/files/mod_%{mod_name}-%{version}.tar.gz
-URL:           http://www.jdimedia.nl/igmar/mod_%{mod_name}/
+# Source0-md5: 1e47d40d8f0404d9faa3040655df44a2
+URL:           http://www.jdimedia.nl/igmar/mod_suid/
 BuildRequires: %{apxs}
-BuildRequires: apache-devel
+BuildRequires: apache1-devel >= 1.3.33-2
 BuildRequires: zlib-devel
-Requires(post,preun):  %{apxs}
-Requires:      apache
+Requires(triggerpostun):       %{apxs}
+Requires:      apache1 >= 1.3.33-2
+Obsoletes:     apache-mod_%{mod_name} <= %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
 
 %description
-Apache module: execution of scripts under their own uids per-vhost
+Apache module: execution of scripts under their own uids per-vhost.
 
 %description -l pl
-Modu³ do apache: wykonywanie skryptow pod wskazanym uidem per-vhost
+Modu³ do apache: wykonywanie skryptów pod wskazanym uidem per-vhost.
 
 %prep
 %setup -q -n mod_%{mod_name}-%{version}
@@ -33,28 +34,36 @@ Modu
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_pkglibdir}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
 
 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
+echo 'LoadModule %{mod_name}_module    modules/mod_%{mod_name}.so' > \
+       $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
+if [ -f /var/lock/subsys/apache ]; then
+       /etc/rc.d/init.d/apache restart 1>&2
 fi
 
-%preun
+%postun
 if [ "$1" = "0" ]; then
-       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
+       if [ -f /var/lock/subsys/apache ]; then
+               /etc/rc.d/init.d/apache restart 1>&2
        fi
 fi
 
+%triggerpostun -- apache1-mod_%{mod_name} < 1.1-1.1
+# check that they're not using old apache.conf
+if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
+       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+fi
+
 %files
 %defattr(644,root,root,755)
 %doc CHANGES.txt README
+%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.083308 seconds and 4 git commands to generate.