]> git.pld-linux.org Git - packages/apache1-mod_suid.git/blob - apache1-mod_suid.spec
724d796373251e5966f6ff7dee159b19ee0d5fe9
[packages/apache1-mod_suid.git] / apache1-mod_suid.spec
1 %define         mod_name        suid
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        Apache module: execution of scripts under their own uids
4 Summary(pl):    Modu³ do apache: wykonywanie skryptów pod wskazanym uidem
5 Name:           apache1-mod_%{mod_name}
6 Version:        1.1
7 Release:        1
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        http://www.jdimedia.nl/igmar/mod_%{mod_name}/files/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  1e47d40d8f0404d9faa3040655df44a2
12 URL:            http://www.jdimedia.nl/igmar/mod_suid/
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache1-devel
15 BuildRequires:  zlib-devel
16 Requires(post,preun):   %{apxs}
17 Requires:       apache1
18 Obsoletes:      apache-mod_%{mod_name} <= %{version}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
22
23 %description
24 Apache module: execution of scripts under their own uids per-vhost.
25
26 %description -l pl
27 Modu³ do apache: wykonywanie skryptów pod wskazanym uidem per-vhost.
28
29 %prep
30 %setup -q -n mod_%{mod_name}-%{version}
31
32 %build
33 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT%{_pkglibdir}
38
39 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %post
45 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
46 if [ -f /var/lock/subsys/apache ]; then
47         /etc/rc.d/init.d/apache restart 1>&2
48 fi
49
50 %preun
51 if [ "$1" = "0" ]; then
52         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
53         if [ -f /var/lock/subsys/apache ]; then
54                 /etc/rc.d/init.d/apache restart 1>&2
55         fi
56 fi
57
58 %files
59 %defattr(644,root,root,755)
60 %doc CHANGES.txt README
61 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.067661 seconds and 2 git commands to generate.