]> git.pld-linux.org Git - packages/apache1-mod_suid.git/blob - apache1-mod_suid.spec
- apxs1 in apache1-devel now
[packages/apache1-mod_suid.git] / apache1-mod_suid.spec
1 %define         mod_name        suid
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        Apache module: execution of scripts under their own uids
4 Summary(pl.UTF-8):      Moduł do apache: wykonywanie skryptów pod wskazanym uidem
5 Name:           apache1-mod_%{mod_name}
6 Version:        1.1
7 Release:        4
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        http://www.jdimedia.nl/igmar/mod_%{mod_name}/files/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  1e47d40d8f0404d9faa3040655df44a2
12 URL:            http://www.jdimedia.nl/igmar/mod_suid/
13 BuildRequires:  apache1-devel >= 1.3.39
14 BuildRequires:  rpmbuild(macros) >= 1.268
15 BuildRequires:  zlib-devel
16 Requires(triggerpostun):        %{apxs}
17 Requires:       apache1(EAPI)
18 Obsoletes:      apache-mod_suid <= 1.1
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
22 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
23
24 %description
25 Apache module: execution of scripts under their own uids per-vhost.
26
27 %description -l pl.UTF-8
28 Moduł do apache: wykonywanie skryptów pod wskazanym uidem per-vhost.
29
30 %prep
31 %setup -q -n mod_%{mod_name}-%{version}
32
33 %build
34 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
39
40 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
41
42 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
43         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %post
49 %service -q apache restart
50
51 %postun
52 if [ "$1" = "0" ]; then
53         %service -q apache restart
54 fi
55
56 %triggerpostun -- apache1-mod_%{mod_name} < 1.1-1.1
57 # check that they're not using old apache.conf
58 if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
59         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
60 fi
61
62 %files
63 %defattr(644,root,root,755)
64 %doc CHANGES.txt README
65 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
66 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.070589 seconds and 3 git commands to generate.