]> git.pld-linux.org Git - packages/apache1-mod_sqlinclude.git/blame - apache1-mod_sqlinclude.spec
- update config dir macro
[packages/apache1-mod_sqlinclude.git] / apache1-mod_sqlinclude.spec
CommitLineData
9519b0d0 1%define mod_name sqlinclude
25ff2b12 2%define apxs /usr/sbin/apxs1
31e5acd8 3Summary: Apache module: mySQL based "Include"-alike configuration command
6ef8272d 4Summary(pl.UTF-8): Moduł do apache: bazująca na mySQL komenda konfiguracji ala "Include"
25ff2b12 5Name: apache1-mod_%{mod_name}
9519b0d0 6Version: 1.4
1a506566 7Release: 5
9519b0d0
AM
8License: BSD
9Group: Networking/Daemons
30ae6c37 10Source0: http://dl.sourceforge.net/mod-sqlinclude/mod_sqlinclude-%{version}.tgz
3fd78063 11# Source0-md5: ecb1fd5d5a89c55e7dda4a9a456b0c13
c37ea736 12URL: http://sourceforge.net/projects/mod-sqlinclude/
ed371428 13BuildRequires: apache1-devel >= 1.3.39
9519b0d0 14BuildRequires: mysql-devel
5d0d1602 15BuildRequires: rpmbuild(macros) >= 1.268
53a0a5fc 16Requires(triggerpostun): %{apxs}
1a506566 17Requires: apache1(EAPI)
5d0d1602 18Obsoletes: apache-mod_sqlinclude <= 1.4
9519b0d0
AM
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
53a0a5fc 21%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
617e0a33 22%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
9519b0d0
AM
23
24%description
25mod_sqlinclude is an Apache Web server module which implements mySQL
26based "Include"-alike configuration command. This lets you keep your
27httpd config in database (i.e. VHosts etc).
28
da6bd24d
JR
29%description -l pl.UTF-8
30Moduł do serwera Apache implementujący bazującą na mySQL komendę
31konfiguracyjną typu "Include". Dzięki temu możesz trzymać swoją
32konfigurację w bazie SQL.
9519b0d0
AM
33
34%prep
35%setup -q -n mod_%{mod_name}-%{version}
36
37%build
25ff2b12 38%{__make} \
39 APXS=%{apxs}
9519b0d0
AM
40
41%install
42rm -rf $RPM_BUILD_ROOT
617e0a33 43install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
9519b0d0
AM
44
45install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
46
53a0a5fc 47echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
617e0a33 48 $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
53a0a5fc 49
30ae6c37
JB
50%clean
51rm -rf $RPM_BUILD_ROOT
52
9519b0d0 53%post
5d0d1602 54%service -q apache restart
9519b0d0 55
13b3b897 56%postun
9519b0d0 57if [ "$1" = "0" ]; then
5d0d1602 58 %service -q apache restart
9519b0d0
AM
59fi
60
53a0a5fc
ER
61%triggerpostun -- apache1-mod_%{mod_name} < 1.4-1.2
62# check that they're not using old apache.conf
63if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
64 %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
65fi
66
9519b0d0
AM
67%files
68%defattr(644,root,root,755)
75566869 69%doc CHANGE* README* *.sql
617e0a33 70%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
9519b0d0 71%attr(755,root,root) %{_pkglibdir}/*
This page took 0.085485 seconds and 4 git commands to generate.