]> git.pld-linux.org Git - packages/apache1-mod_security.git/blame_incremental - apache1-mod_security.spec
- converted to UTF-8
[packages/apache1-mod_security.git] / apache1-mod_security.spec
... / ...
CommitLineData
1%define mod_name security
2%define apxs /usr/sbin/apxs1
3Summary: Apache module: securing web applications
4Summary(pl.UTF-8): Moduł do apache: ochrona aplikacji WWW
5Name: apache1-mod_%{mod_name}
6Version: 1.8.7
7Release: 0.1
8License: GPL v2
9Group: Networking/Daemons
10Source0: http://www.modsecurity.org/download/modsecurity-%{version}.tar.gz
11# Source0-md5: 0dd48656e451c711358c097dc80e0369
12URL: http://www.modsecurity.org/
13BuildRequires: apache1-devel >= 1.3.33-2
14BuildRequires: rpmbuild(macros) >= 1.268
15Requires: apache1 >= 1.3.33-2
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
19%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
20
21%description
22ModSecurity is an open source intrusion detection and prevention
23engine for web applications. It operates embedded into the web server,
24acting as a powerful umbrella - shielding web applications from
25attacks.
26
27%description -l pl.UTF-8
28ModSecurity jest otwartym silnikiem wykrywania i zapobiegania intruzom
29dla aplikacji WWW. Operuje w ramach serwera WWW, działając jak potężny
30parasol chroniący aplikacje WWW przed atakami.
31
32%prep
33%setup -q -n mod%{mod_name}-%{version}
34
35%build
36cd apache1
37%{apxs} -c mod_%{mod_name}.c
38
39%install
40rm -rf $RPM_BUILD_ROOT
41install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
42
43install apache1/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
44
45echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
46 $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%post
52%service -q apache restart
53
54%postun
55if [ "$1" = "0" ]; then
56 %service -q apache restart
57fi
58
59%files
60%defattr(644,root,root,755)
61%doc README CHANGES modsecurity-manual.pdf httpd.conf*
62%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
63%attr(755,root,root) %{_pkglibdir}/*
This page took 0.096285 seconds and 4 git commands to generate.