]> git.pld-linux.org Git - packages/apache1-mod_rpaf.git/blob - apache1-mod_rpaf.spec
- if compiled without ipv6, then conflict with apache compiled with ipv6
[packages/apache1-mod_rpaf.git] / apache1-mod_rpaf.spec
1 # TODO
2 # - need ipv6 support
3 #
4 %bcond_with     ipv6            # disable IPv6 support
5 #
6 %define         mod_name        rpaf
7 %define         apxs            %{_sbindir}/apxs1
8 Summary:        Reverse proxy add forward module for Apache
9 Summary(pl):    Modu³ Apache'a dodaj±cy przekazywanie dla odwrotnych proxy
10 Name:           apache1-mod_%{mod_name}
11 Version:        0.5
12 Release:        0.15
13 License:        Apache
14 Group:          Networking/Daemons
15 Source0:        http://stderr.net/apache/rpaf/download/mod_%{mod_name}-%{version}.tar.gz
16 # Source0-md5:  471fb059d6223a394f319b7c8ab45c4d
17 Source1:        %{name}.conf
18 URL:            http://stderr.net/apache/rpaf/
19 BuildRequires:  apache1-devel >= 1.3.33-2
20 %{!?with_ipv6:BuildConflicts:   apache1(ipv6)-devel}
21 %{!?with_ipv6:Conflicts:        apache1(ipv6)}
22 Requires:       apache1 >= 1.3.33-2
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
26 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
27
28 %description
29 rpaf is for backend Apache servers what mod_proxy_add_forward is for
30 frontend Apache servers. It does excactly the opposite of
31 mod_proxy_add_forward written by Ask Bjoern Hansen. It will also work
32 with mod_proxy in Apache starting with release 1.3.25.
33
34 %description -l en
35 rpaf is for backend Apache servers what mod_proxy_add_forward is for
36 frontend Apache servers. It does excactly the opposite of
37 mod_proxy_add_forward written by Ask Bjørn Hansen. It will also work
38 with mod_proxy in Apache starting with release 1.3.25.
39
40 %description -l pl
41 rpaf jest dla backendowych serwerów Apache tym, czym
42 mod_proxy_add_forward jest dla frontendowych. Wykonuje dok³adnie
43 przeciwne operacje do mod_proxy_add_forward napisanego przez Aska
44 Bjoerna Hansena. Bêdzie tak¿e dzia³aæ z mod_proxy w Apache'u pocz±wszy
45 od wersji 1.3.25.
46
47 %prep
48 %setup -q -n mod_%{mod_name}-%{version}
49
50 %build
51 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
56
57 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
58 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/99_mod_%{mod_name}.conf
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post
64 if [ -f /var/lock/subsys/apache ]; then
65         /etc/rc.d/init.d/apache restart 1>&2
66 fi
67
68 %postun
69 if [ "$1" = "0" ]; then
70         if [ -f /var/lock/subsys/apache ]; then
71                 /etc/rc.d/init.d/apache restart 1>&2
72         fi
73 fi
74
75 %files
76 %defattr(644,root,root,755)
77 %doc README CHANGES test.pl
78 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
79 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.079554 seconds and 4 git commands to generate.