]> git.pld-linux.org Git - packages/apache1-mod_perl.git/blobdiff - apache1-mod_perl.spec
- plain apache require (it's internals will never change anymore), rel 12
[packages/apache1-mod_perl.git] / apache1-mod_perl.spec
index a5af9bdbce4a682a480eee739fecf240268d49f5..d5a7a218df1ee954277e4c52117af23d8cb4be2d 100644 (file)
@@ -1,8 +1,8 @@
 # TODO:
-# - add devel subpackage
-
-%bcond_without ipv6            # disable IPv6 support
-
+# - orphaned dirs for %{_manualdocdir}/mod/*html
+#
+%bcond_without ipv6            # disable IPv6 support. must match same bcond from apache1-devel
+#
 %include       /usr/lib/rpm/macros.perl
 %define                mod_name        perl
 %define        apxs    /usr/sbin/apxs1
@@ -27,7 +27,7 @@ Summary(uk):  
 Summary(zh_CN):        ÓÃÓÚ Apache web ·þÎñ³ÌÐòµÄ Perl ½âÊͳÌÐò¡£
 Name:          apache1-mod_perl
 Version:       1.29
-Release:       8
+Release:       12
 License:       GPL
 Group:         Networking/Daemons
 Source0:       http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
@@ -38,6 +38,7 @@ Patch1:               mod_perl-v6.patch
 Patch2:                %{name}-optimize.patch
 URL:           http://perl.apache.org/
 BuildRequires: %{apxs}
+%{?with_ipv6:BuildRequires:    apache1(ipv6)-devel}
 BuildRequires: apache1-devel >= 1.3.33-2
 BuildRequires: perl-B-Graph
 BuildRequires: perl-BSD-Resource
@@ -48,21 +49,21 @@ BuildRequires:      perl-URI
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: perl-libwww
 BuildRequires: rpm-perlprov >= 4.1-13
-%{?with_ipv6:BuildRequires:    apache1(ipv6)-devel}
-PreReq:                apache1(EAPI)
-Requires(triggerpostun):       %{apxs}
-%requires_eq   apache1
+BuildRequires: rpmbuild(macros) >= 1.268
+Requires(triggerpostun):       sed >= 4.0
+Requires:      apache1
+Requires:      apache1(EAPI)
 Requires:      perl(DynaLoader) = %(%{__perl} -MDynaLoader -e 'print DynaLoader->VERSION')
-Provides:      perl(mod_perl_hooks)
-Provides:      mod_perl
+Provides:      apache(mod_perl)
 Obsoletes:     mod_perl
 Obsoletes:     mod_perl-common
-Obsoletes:     perl-Apache-Test
+%{!?with_ipv6:Conflicts:       apache1(ipv6)}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
 %define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
 %define                _noautoreqdep   'perl(Apache::.*)' 'perl(mod_perl)'
+%define                _manualdocdir   %{_datadir}/apache1-manual
 
 %description
 Mod_perl incorporates a Perl interpreter into the Apache web server,
@@ -194,6 +195,21 @@ Apache web 
 ½Ó¿Ú¡£ ÓÉÓÚ²»±ØÆô¶¯ÈκÎÍⲿ Perl ½âÊͳÌÐò£¬Òò´Ë»áʹ CGI
 ½Å±¾»Øת¹ý³Ì¸üΪ¿ìËÙ¡£
 
+%package devel
+Summary:       Files needed for building XS modules that use mod_perl
+Summary(pl):   Pliki potrzebne do budowania modu³ów XS korzystaj±cych z mod_perla
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      apache1-devel
+
+%description devel
+The apache1-mod_perl-devel package contains the files needed for
+building XS modules that use mod_perl.
+
+%description devel -l pl
+Ten pakiet zawiera pliki potrzebne do budowania modu³ów XS
+korzystaj±cych z mod_perla.
+
 %prep
 %setup  -q -n mod_perl-%{version}
 %patch0 -p1
@@ -218,14 +234,14 @@ chmod +x apaci/find_source
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d,/home/apache/manual/mod}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d,%{_manualdocdir}/mod}
 
 %{__make} pure_install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install apaci/libperl.so $RPM_BUILD_ROOT%{_pkglibdir}
 install htdocs/manual/mod/mod_perl.html \
-       $RPM_BUILD_ROOT/home/apache/manual/mod
+       $RPM_BUILD_ROOT%{_manualdocdir}/mod
 
 echo 'LoadModule %{mod_name}_module    modules/lib%{mod_name}.so' > \
        $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
@@ -240,31 +256,26 @@ rm -f $RPM_BUILD_ROOT%{_mandir}/man3/Bundle::Apache.3pm*
 rm -rf $RPM_BUILD_ROOT
 
 %post
-if [ -f /var/lock/subsys/apache ]; then
-       /etc/rc.d/init.d/apache restart 1>&2
-else
-       echo "Run \"/etc/rc.d/init.d/apache start\" to start apache HTTP daemon."
-fi
+%service -q apache restart
 
 %postun
 if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/apache ]; then
-               /etc/rc.d/init.d/apache restart 1>&2
-       fi
+       %service -q apache restart
 fi
 
 %triggerpostun -- apache1-mod_%{mod_name} < 1.29-7.1
 # check that they're not using old apache.conf
 if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
-       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/lib%{mod_name}.so 1>&2
+       sed -i -e '/^\(Add\|Load\)Module.*libperl\.\(so\|c\)/d' /etc/apache/apache.conf
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc README INSTALL CREDITS faq/*.html faq/*.txt apache-modlist.html eg
-%doc /home/apache/manual/mod/*html
+# FIXME: parent dirs not owned as the manualdocdir (via apache1-doc) is not in required
+%doc %{_manualdocdir}/mod/*html
 
-%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
 %attr(755,root,root) %{_pkglibdir}/*
 
 %{perl_vendorarch}/*.pm
@@ -282,7 +293,8 @@ fi
 
 %{_mandir}/man3/[Acm]*
 
-# to -devel ?
+%files devel
+%defattr(644,root,root,755)
 %{perl_vendorarch}/auto/Apache/typemap
 %{perl_vendorarch}/auto/Apache/mod_perl.exp
 %{perl_vendorarch}/auto/Apache/include
This page took 0.079485 seconds and 4 git commands to generate.