]> git.pld-linux.org Git - packages/apache1-mod_ometer.git/blob - apache1-mod_ometer.spec
- added BR: gd-devel (by Zbyniu Krzystolik)
[packages/apache1-mod_ometer.git] / apache1-mod_ometer.spec
1 %define         mod_name        ometer
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: Web counter
4 Summary(pl):    Modu³ do Apache: licznik odwiedzin
5 Name:           apache-mod_%{mod_name}
6 Version:        1.2.0
7 Release:        1
8 License:        BSD
9 Group:          Networking/Daemons
10 Source0:        http://www.umich.edu/~umweb/downloads/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  50b7b641409abd5d1a57077422fd444e
12 Source1:        %{name}.conf
13 Source2:        http://www.umich.edu/~umweb/how-to/cgi-scripts/counter.html
14 # Source2-md5:  6d6f56cec95c5fa2a28caf0ecb86b034
15 Patch0:         %{name}-configure.patch
16 Patch1:         %{name}-symbols.patch
17 URL:            http://modometer.org/
18 BuildRequires:  %{apxs}
19 BuildRequires:  apache(EAPI)-devel
20 BuildRequires:  libjpeg-devel
21 BuildRequires:  gd-devel
22 Requires(post,preun):   %{apxs}
23 Requires(post,preun):   grep
24 Requires(preun):        fileutils
25 Requires:       apache(EAPI)
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
29 %define         _sysconfdir     /etc/httpd
30
31 %description
32 mod_ometer is a Web counter implemented as an Apache C module. It uses
33 gd to generate its images. gd has some built-in fonts, but you can use
34 any TrueType font you want for the counter. In addition to allowing
35 font choice, mod_ometer has all sorts of options for customizing the
36 size, width, and color of your counter, as well as the ability to
37 output the counter as JPEG or PNG.
38
39 %description -l pl
40 mod_ometer jest licznikiem odwiedzin dzia³aj±cym jako modu³ Apache'a
41 u¿ywaj±cym biblioteki gd do generowania obrazków. gd posiada kilka
42 wbudowanych fontów, lecz w liczniku mo¿na u¿yæ dowolnych fontów
43 TrueType. Poza mo¿liwo¶ci± wyboru kroju czcionki mod_ometer posiada
44 opcje umo¿liwiaj±ce zmianê szeroko¶ci, wysoko¶ci i kolorów licznika
45 oraz formatu obrazka: JPEG lub PNG.
46
47 %prep
48 %setup -q -n mod_%{mod_name}-%{version}
49 %patch0 -p1
50 %patch1 -p1
51 cp %{SOURCE2} .
52
53 %build
54 export LDFLAGS=" "
55 %configure
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
61
62 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
63 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mod_%{mod_name}.conf
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post
69 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
70 if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*mod_ometer.conf" /etc/httpd/httpd.conf; then
71         echo "Include /etc/httpd/mod_ometer.conf" >> /etc/httpd/httpd.conf
72 fi
73 if [ -f /var/lock/subsys/httpd ]; then
74         /etc/rc.d/init.d/httpd restart 1>&2
75 fi
76
77 %preun
78 if [ "$1" = "0" ]; then
79         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
80         umask 027
81         grep -v "^Include.*mod_ometer.conf" /etc/httpd/httpd.conf > \
82                 /etc/httpd/httpd.conf.tmp
83         mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
84         if [ -f /var/lock/subsys/httpd ]; then
85                 /etc/rc.d/init.d/httpd restart 1>&2
86         fi
87 fi
88
89 %files
90 %defattr(644,root,root,755)
91 %doc *.html
92 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mod_ometer.conf
93 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.033907 seconds and 4 git commands to generate.