]> git.pld-linux.org Git - packages/apache1-mod_ometer.git/blob - apache1-mod_ometer.spec
606cf1f4c18a9a05f57ac511fd278905e2106654
[packages/apache1-mod_ometer.git] / apache1-mod_ometer.spec
1 %define         mod_name        ometer
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module: Web counter
4 Summary(pl):    Modu³ do Apache: licznik odwiedzin
5 Name:           apache-mod_%{mod_name}
6 Version:        1.2.0
7 Release:        1
8 License:        BSD
9 Group:          Networking/Daemons
10 Source0:        http://www.umich.edu/~umweb/downloads/mod_%{mod_name}-%{version}.tar.gz
11 Patch0:         %{name}-configure.patch
12 URL:            http://modometer.org/
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache(EAPI)-devel
15 BuildRequires:  libjpeg-devel
16 Requires(post,preun):   %{apxs}
17 Requires(post,preun):   grep
18 Requires(preun):        fileutils
19 Requires:       apache(EAPI)
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
23 %define         _sysconfdir     /etc/httpd
24
25 %description
26 mod_ometer is a Web counter implemented as an Apache C module. It uses
27 gd to generate its images. gd has some built-in fonts, but you can use
28 any TrueType font you want for the counter. In addition to allowing
29 font choice, mod_ometer has all sorts of options for customizing the
30 size, width, and color of your counter, as well as the ability to
31 output the counter as JPEG or PNG.
32
33 %description -l pl
34 mod_ometer jest licznikiem odwiedzin dzia³aj±cym jako modu³ Apache'a
35 u¿ywaj±cym biblioteki gd do generowania obrazków. gd posiada kilka
36 wbudowanych fontów, lecz w liczniku mo¿na u¿yæ dowolnych fontów
37 TrueType. Poza mo¿liwo¶ci± wyboru kroju czcionki mod_ometer posiada
38 opcje umo¿liwiaj±ce zmianê szeroko¶ci, wysoko¶ci i kolorów licznika
39 oraz formatu obrazka: JPEG lub PNG.
40
41 %prep
42 %setup -q -n mod_%{mod_name}-%{version}
43 %patch0 -p1
44
45 %build
46 export LDFLAGS=" "
47 %configure
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{_pkglibdir}
53
54 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
61 if [ -f /var/lock/subsys/httpd ]; then
62         /etc/rc.d/init.d/httpd restart 1>&2
63 fi
64
65 %preun
66 if [ "$1" = "0" ]; then
67         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
68         if [ -f /var/lock/subsys/httpd ]; then
69                 /etc/rc.d/init.d/httpd restart 1>&2
70         fi
71 fi
72
73 %files
74 %defattr(644,root,root,755)
75 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.055061 seconds and 2 git commands to generate.