]> git.pld-linux.org Git - packages/apache1-mod_ntlm.git/commitdiff
- updated to 0.4
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 25 Oct 2003 21:10:23 +0000 (21:10 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added security patch - heap overflows and format strings (BugTraqID 7388,7393)

Changed files:
    apache-mod_ntlm-security.patch -> 1.1
    apache1-mod_ntlm-security.patch -> 1.1
    apache1-mod_ntlm.spec -> 1.15

apache-mod_ntlm-security.patch [new file with mode: 0644]
apache1-mod_ntlm-security.patch [new file with mode: 0644]
apache1-mod_ntlm.spec

diff --git a/apache-mod_ntlm-security.patch b/apache-mod_ntlm-security.patch
new file mode 100644 (file)
index 0000000..18f81cd
--- /dev/null
@@ -0,0 +1,31 @@
+Fixes vulnerabilities in log() and flog() functions:
+heap overflows (BugTraqID 7388)
+format strings (BugTraqID 7393)
+insecure file access in /tmp
+diff -Nur mod_ntlm-0.4.orig/mod_ntlm.c mod_ntlm-0.4/mod_ntlm.c
+--- mod_ntlm-0.4.orig/mod_ntlm.c       2003-02-21 02:55:13.000000000 +0100
++++ mod_ntlm-0.4/mod_ntlm.c    2003-10-25 23:03:34.470322328 +0200
+@@ -48,9 +48,9 @@
+     if ((s = (char *) malloc(2048)) == NULL)
+         return;
+     va_start(ap, format);
+-    vsprintf(s, format, ap);
++    vsnprintf(s, 2048, format, ap);
+     va_end(ap);
+-    ap_log_rerror(APLOG_MARK, APLOG_NOERRNO | APLOG_NOTICE, r, s);
++    ap_log_rerror(APLOG_MARK, APLOG_NOERRNO | APLOG_NOTICE, r, "%s", s);
+     free(s);
+ }
+ static void
+@@ -63,9 +63,9 @@
+     if ((s = (char *) malloc(2048)) == NULL)
+         return;
+     va_start(ap, format);
+-    vsprintf(s, format, ap);
++    vsnprintf(s, 2048, format, ap);
+     va_end(ap);
+-    if ((f = fopen("/tmp/mod_ntlm.log", "a")) != NULL) {
++    if ((f = fopen("/var/log/mod_ntlm.log", "a")) != NULL) {
+         fputs(s, f);
+         fputs("\n", f);
+         fclose(f);
diff --git a/apache1-mod_ntlm-security.patch b/apache1-mod_ntlm-security.patch
new file mode 100644 (file)
index 0000000..18f81cd
--- /dev/null
@@ -0,0 +1,31 @@
+Fixes vulnerabilities in log() and flog() functions:
+heap overflows (BugTraqID 7388)
+format strings (BugTraqID 7393)
+insecure file access in /tmp
+diff -Nur mod_ntlm-0.4.orig/mod_ntlm.c mod_ntlm-0.4/mod_ntlm.c
+--- mod_ntlm-0.4.orig/mod_ntlm.c       2003-02-21 02:55:13.000000000 +0100
++++ mod_ntlm-0.4/mod_ntlm.c    2003-10-25 23:03:34.470322328 +0200
+@@ -48,9 +48,9 @@
+     if ((s = (char *) malloc(2048)) == NULL)
+         return;
+     va_start(ap, format);
+-    vsprintf(s, format, ap);
++    vsnprintf(s, 2048, format, ap);
+     va_end(ap);
+-    ap_log_rerror(APLOG_MARK, APLOG_NOERRNO | APLOG_NOTICE, r, s);
++    ap_log_rerror(APLOG_MARK, APLOG_NOERRNO | APLOG_NOTICE, r, "%s", s);
+     free(s);
+ }
+ static void
+@@ -63,9 +63,9 @@
+     if ((s = (char *) malloc(2048)) == NULL)
+         return;
+     va_start(ap, format);
+-    vsprintf(s, format, ap);
++    vsnprintf(s, 2048, format, ap);
+     va_end(ap);
+-    if ((f = fopen("/tmp/mod_ntlm.log", "a")) != NULL) {
++    if ((f = fopen("/var/log/mod_ntlm.log", "a")) != NULL) {
+         fputs(s, f);
+         fputs("\n", f);
+         fclose(f);
index 73f85deae50aecf8047e398e1f2f4e7997e585f4..060db350d6de89e7c6139ed64505bfea30b94fe3 100644 (file)
@@ -1,14 +1,15 @@
 %define                mod_name        ntlm
 %define        apxs            /usr/sbin/apxs
 Summary:       This is the NTLM authentication module for Apache
-Summary(pl):   Modu³ autentykacji NTLM dla Apache
+Summary(pl):   Modu³ uwierzytelnienia NTLM dla Apache
 Name:          apache-mod_%{mod_name}
-Version:       0.3
-Release:       3
+Version:       0.4
+Release:       1
 License:       GPL
 Group:         Networking/Daemons
 Source0:       http://dl.sourceforge.net/modntlm/mod_%{mod_name}-%{version}.tar.gz
-# Source0-md5: fff67ce0ddb524588ea01cb4a015890c
+# Source0-md5: 5e9b8d1abf872926d6ff01a05a7deb2a
+Patch0:                %{name}-security.patch
 URL:           http://modntlm.sourceforge.net/
 BuildRequires: %{apxs}
 BuildRequires: apache(EAPI)-devel
@@ -24,12 +25,13 @@ authenticate HTTP clients using samba or windows-like server (using
 NTLM protocol).
 
 %description -l pl
-To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
-klientów HTTP poprzez sambê lub serwer na Windows (z u¿yciem protoko³u
-NTLM).
+To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
+uwierzytelnianie klientów HTTP poprzez sambê lub serwer na Windows (z
+u¿yciem protoko³u NTLM).
 
 %prep
 %setup -q -n mod_%{mod_name}-%{version}
+%patch -p1
 
 %build
 PATH=$PATH:/usr/sbin %{__make}
This page took 0.105943 seconds and 4 git commands to generate.