]> git.pld-linux.org Git - packages/apache1-mod_mp3.git/blob - apache1-mod_mp3.spec
- update to 0.30, STBR
[packages/apache1-mod_mp3.git] / apache1-mod_mp3.spec
1 %define         arname          mod_mp3
2 %define         mod_name        mp3
3 Summary:        MP3 Apache module
4 Summary(pl):    Modu³ MP3 do Apache
5 Name:           apache-mod_mp3
6 Version:        0.30
7 Release:        1
8 License:        distributable
9 Group:          Networking/Daemons
10 Group(de):      Netzwerkwesen/Server
11 Group(pl):      Sieciowe/Serwery
12 Source0:        ftp://ftp.tangent.org/pub/apache/%{arname}-%{version}.tar.gz
13 Source1:        %{arname}.conf
14 URL:            http://media.tangent.org/
15 Requires:       apache >= 1.3.12
16 Prereq:         grep
17 Prereq:         apache(EAPI) >= 1.3.12
18 Provides:       %{arname}
19 BuildRequires:  apache(EAPI) >= 1.3.12
20 BuildRequires:  apache(EAPI)-devel >= 1.3.12
21 BuildRequires:  expat-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _pkglibdir      %(%{_sbindir}/apxs -q LIBEXECDIR)
25 %define         _sysconfdir     /etc/httpd
26
27 %prep
28 %setup -q -n %{arname}-%{version}
29
30 %description
31 This turns apache into your basic RIAA hating, but every college
32 student loving mp3 streaming server. It can play from a list of files,
33 either straight through or randomly. It can also be used to cache
34 mp3's into memory and have the server operate entirely from memory.
35 Enjoy, groove, mp3s not included.
36
37 %description -l pl
38 Ten pakiet zamienia Twojego Apache w znienawidzony przez RIAA, ale
39 uwielbiany przez studentów serwer strumieni MP3. Mo¿e odtwarzaæ listê
40 plików, w kolejno¶ci lub losowo. Mo¿e byæ tak¿e u¿yty do buforowania
41 plików mp3 w pamiêci, pozwalaj±c serwerowi operowaæ wy³±cznie na
42 pamiêci. Baw siê dobrze; pliki mp3 nie s± za³±czone.
43
44 %build
45 ./configure
46 %{__make} APXS=/usr/sbin/apxs
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
51
52 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
53 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
54
55 gzip -9nf README ChangeLog LICENSE
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 /usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
62 if [ -f %{_sysconfdir}/httpd.conf ] && \
63         ! grep -q "^Include.*/%{arname}.conf" %{_sysconfdir}/httpd.conf; then
64                 echo "Include %{_sysconfdir}/%{arname}.conf" >> %{_sysconfdir}/httpd.conf
65 fi
66 if [ -f /var/lock/subsys/httpd ]; then
67         /etc/rc.d/init.d/httpd restart 1>&2
68 fi
69         
70 %preun
71 if [ "$1" = "0" ]; then
72         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
73         grep -E -v "^Include.*%{arname}.conf" %{_sysconfdir}/httpd.conf > \
74         %{_sysconfdir}/httpd.conf.tmp
75         mv -f %{_sysconfdir}/httpd.conf.tmp %{_sysconfdir}/httpd.conf
76         if [ -f /var/lock/subsys/httpd ]; then
77                 /etc/rc.d/init.d/httpd restart 1>&2
78         fi
79 fi
80
81 %files
82 %defattr(644,root,root,755)
83 %doc *.gz faq.html support
84 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mod_mp3.conf
85 %attr(755,root,root) %{_pkglibdir}/mod_mp3.so
This page took 0.068146 seconds and 3 git commands to generate.