]> git.pld-linux.org Git - packages/apache1-mod_mp3.git/blob - apache1-mod_mp3.spec
ad57e21ad6048e82db6d3f919ec5039ed7e1dbdf
[packages/apache1-mod_mp3.git] / apache1-mod_mp3.spec
1 %define         arname          mod_mp3
2 %define         mod_name        mp3
3 %define         apxs            /usr/sbin/apxs
4 Summary:        MP3 Apache module
5 Summary(pl):    Modu³ MP3 do Apache
6 Name:           apache-mod_mp3
7 Version:        0.39
8 Release:        1
9 License:        BSD
10 Group:          Networking/Daemons
11 Source0:        http://software.tangent.org/download/%{arname}-%{version}.tar.gz
12 # Source0-md5:  357f0d7b8d3b5f4ec1baf50dafb0bf24
13 Source1:        %{arname}.conf
14 URL:            http://media.tangent.org/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache(EAPI)-devel >= 1.3.12
17 BuildRequires:  expat-devel
18 PreReq:         apache(EAPI) >= 1.3.12
19 Requires(post,preun):   %{apxs}
20 Requires(post,preun):   grep
21 Requires(preun):        fileutils
22 Provides:       %{arname}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
26 %define         _sysconfdir     /etc/httpd
27
28 %description
29 This turns apache into your basic RIAA hating, but every college
30 student loving mp3 streaming server. It can play from a list of files,
31 either straight through or randomly. It can also be used to cache
32 mp3's into memory and have the server operate entirely from memory.
33 Enjoy, groove, mp3s not included.
34
35 %description -l pl
36 Ten pakiet zamienia Twojego Apache w znienawidzony przez RIAA, ale
37 uwielbiany przez studentów serwer strumieni MP3. Mo¿e odtwarzaæ listê
38 plików, w kolejno¶ci lub losowo. Mo¿e byæ tak¿e u¿yty do buforowania
39 plików mp3 w pamiêci, pozwalaj±c serwerowi operowaæ wy³±cznie na
40 pamiêci. Baw siê dobrze; pliki mp3 nie s± za³±czone.
41
42 %prep
43 %setup -q -n %{arname}-%{version}
44
45 %build
46 ./configure
47
48 %{__make} APXS=%{apxs}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
53
54 install src/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
55 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
62 if [ -f %{_sysconfdir}/httpd.conf ] && \
63         ! grep -q "^Include.*/%{arname}.conf" %{_sysconfdir}/httpd.conf; then
64                 echo "Include %{_sysconfdir}/%{arname}.conf" >> %{_sysconfdir}/httpd.conf
65 fi
66 if [ -f /var/lock/subsys/httpd ]; then
67         /etc/rc.d/init.d/httpd restart 1>&2
68 fi
69
70 %preun
71 if [ "$1" = "0" ]; then
72         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
73         umask 027
74         grep -E -v "^Include.*%{arname}.conf" %{_sysconfdir}/httpd.conf > \
75                 %{_sysconfdir}/httpd.conf.tmp
76         mv -f %{_sysconfdir}/httpd.conf.tmp %{_sysconfdir}/httpd.conf
77         if [ -f /var/lock/subsys/httpd ]; then
78                 /etc/rc.d/init.d/httpd restart 1>&2
79         fi
80 fi
81
82 %files
83 %defattr(644,root,root,755)
84 %doc README ChangeLog LICENSE faq.html support
85 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mod_mp3.conf
86 %attr(755,root,root) %{_pkglibdir}/mod_mp3.so
This page took 0.062068 seconds and 2 git commands to generate.