]> git.pld-linux.org Git - packages/apache1-mod_mp3.git/blob - apache1-mod_mp3.spec
88002ebdd841788cfd195b195426f9f717204c10
[packages/apache1-mod_mp3.git] / apache1-mod_mp3.spec
1 %define         arname          mod_mp3
2 %define         mod_name        mp3
3 Summary:        MP3 Apache module
4 Summary(pl):    Modu³ MP3 do Apache
5 Name:           apache-mod_mp3
6 Version:        0.25
7 Release:        2
8 License:        distributable
9 Group:          Networking/Daemons
10 Group(de):      Netzwerkwesen/Server
11 Group(pl):      Sieciowe/Serwery
12 Source0:        ftp://ftp.tangent.org/pub/apache/%{arname}-%{version}.tar.gz
13 Source1:        %{arname}.conf
14 URL:            http://media.tangent.org/
15 Requires:       apache >= 1.3.12
16 Prereq:         grep
17 Prereq:         apache(EAPI) >= 1.3.12
18 Provides:       %{arname}
19 BuildRequires:  apache(EAPI) >= 1.3.12
20 BuildRequires:  apache(EAPI)-devel >= 1.3.12
21 BuildRequires:  expat-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _pkglibdir      %(%{_sbindir}/apxs -q LIBEXECDIR)
25 %define         _sysconfdir     /etc/httpd
26
27 %prep
28 %setup -q -n %{arname}-%{version}
29
30 %description
31 This turns apache into your basic RIAA hating, but every college
32 student loving mp3 streaming server. It can play from a list of files,
33 either straight through or randomly. It can also be used to cache
34 mp3's into memory and have the server operate entirely from memory.
35 Enjoy, groove, mp3s not included.
36
37 %description -l pl
38 Ten pakiet zamienia Twojego Apache w znienawidzony przez RIAA, ale
39 uwielbiany przez studentów serwer strumieni MP3. Mo¿e odtwarzaæ listê
40 plików, w kolejno¶ci lub losowo. Mo¿e byæ tak¿e u¿yty do buforowania
41 plików mp3 w pamiêci, pozwalaj±c serwerowi operowaæ wy³±cznie na
42 pamiêci. Baw siê dobrze; pliki mp3 nie s± za³±czone.
43
44 %build
45 %{__make} APXS=/usr/sbin/apxs
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
50
51 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
52 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
53
54 gzip -9nf README ChangeLog LICENSE
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 /usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
61 if [ -f %{_sysconfdir}/httpd.conf ] && \
62         ! grep -q "^Include.*/%{arname}.conf" %{_sysconfdir}/httpd.conf; then
63                 echo "Include %{_sysconfdir}/%{arname}.conf" >> %{_sysconfdir}/httpd.conf
64 fi
65 if [ -f /var/lock/subsys/httpd ]; then
66         /etc/rc.d/init.d/httpd restart 1>&2
67 fi
68         
69 %preun
70 if [ "$1" = "0" ]; then
71         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
72         grep -E -v "^Include.*%{arname}.conf" %{_sysconfdir}/httpd.conf > \
73         %{_sysconfdir}/httpd.conf.tmp
74         mv -f %{_sysconfdir}/httpd.conf.tmp %{_sysconfdir}/httpd.conf
75         if [ -f /var/lock/subsys/httpd ]; then
76                 /etc/rc.d/init.d/httpd restart 1>&2
77         fi
78 fi
79
80 %files
81 %defattr(644,root,root,755)
82 %doc *.gz faq.html
83 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/mod_mp3.conf
84 %attr(755,root,root) %{_pkglibdir}/mod_mp3.so
This page took 0.031818 seconds and 2 git commands to generate.