]> git.pld-linux.org Git - packages/apache1-mod_mp3.git/blame_incremental - apache1-mod_mp3.spec
- s/apache/apache(EAPI)/
[packages/apache1-mod_mp3.git] / apache1-mod_mp3.spec
... / ...
CommitLineData
1%define arname mod_mp3
2%define mod_name mp3
3Summary: MP3 Apache module
4Name: apache-mod_mp3
5Version: 0.25
6Release: 1
7License: Distributable
8Group: Networking/Daemons
9Group(de): Netzwerkwesen/Server
10Group(pl): Sieciowe/Serwery
11Source0: ftp://ftp.tangent.org/pub/apache/%{arname}-%{version}.tar.gz
12Source1: %{arname}.conf
13URL: http://media.tangent.org/
14Requires: apache >= 1.3.12
15Prereq: grep
16Provides: %{arname}
17BuildRequires: apache(EAPI) >= 1.3.12
18BuildRequires: apache(EAPI)-devel >= 1.3.12
19BuildRequires: expat-devel
20Prereq: apache(EAPI) >= 1.3.12
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%define _pkglibdir %(%{_sbindir}/apxs -q LIBEXECDIR)
24%define _sysconfdir /etc/httpd
25
26%prep
27%setup -q -n %{arname}-%{version}
28
29%description
30This turns apache into your basic RIAA hating, but every college
31student loving mp3 streaming server. It can play from a list of files,
32either straight through or randomly. It can also be used to cache
33mp3's into memory and have the server operate entirely from memory.
34Enjoy, groove, mp3s not included.
35
36%build
37%{__make} APXS=/usr/sbin/apxs
38
39%install
40rm -rf $RPM_BUILD_ROOT
41install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
42
43install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
44install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
45
46gzip -9nf README ChangeLog LICENSE
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%post
52/usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
53if [ -f %{_sysconfdir}/httpd.conf ] && \
54 ! grep -q "^Include.*/%{arname}.conf" %{_sysconfdir}/httpd.conf; then
55 echo "Include %{_sysconfdir}/%{arname}.conf" >> %{_sysconfdir}/httpd.conf
56fi
57if [ -f /var/lock/subsys/httpd ]; then
58 /etc/rc.d/init.d/httpd restart 1>&2
59fi
60
61%preun
62if [ "$1" = "0" ]; then
63 /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
64 grep -E -v "^Include.*%{arname}.conf" %{_sysconfdir}/httpd.conf > \
65 %{_sysconfdir}/httpd.conf.tmp
66 mv -f %{_sysconfdir}/httpd.conf.tmp %{_sysconfdir}/httpd.conf
67 if [ -f /var/lock/subsys/httpd ]; then
68 /etc/rc.d/init.d/httpd restart 1>&2
69 fi
70fi
71
72%files
73%defattr(644,root,root,755)
74%doc *.gz faq.html
75%config(noreplace) %{_sysconfdir}/mod_mp3.conf
76%attr(755,root,root) %{_pkglibdir}/mod_mp3.so
This page took 0.090672 seconds and 4 git commands to generate.