]> git.pld-linux.org Git - packages/apache1-mod_log_sql.git/blob - apache1-mod_log_sql.spec
- BR: ac,am,lt
[packages/apache1-mod_log_sql.git] / apache1-mod_log_sql.spec
1 # todo: split *.so to subpackages: mysql/dbi/ssl
2 %define         mod_name        log_sql
3 %define         apxs            /usr/sbin/apxs1
4 Summary:        SQL logging module for Apache
5 Summary(pl):    Modu³ logowania zapytañ do Apache do bazy SQL
6 Name:           apache1-mod_%{mod_name}
7 # NOTE: remember about apache-mod_log_sql when updating!
8 Version:        1.99
9 Release:        2
10 License:        Apache (?)
11 Group:          Networking/Daemons
12 Source0:        http://www.outoforder.cc/downloads/mod_log_sql/mod_%{mod_name}-%{version}.tar.gz
13 # Source0-md5:  e246a3d8e96d2d62715eb34f75c7c11d
14 Patch0:         mod_%{mod_name}-acam_libexecdir.patch
15 URL:            http://www.outoforder.cc/projects/apache/mod_log_sql/
16 BuildRequires:  %{apxs}
17 BuildRequires:  apache1-devel >= 1.3.20
18 BuildRequires:  apache1-mod_ssl-devel
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  libdbi-devel >= 0.7.0
22 BuildRequires:  libtool
23 BuildRequires:  mysql-devel >= 3.23.30
24 Requires(post,preun):   %{apxs}
25 Requires(post,preun):   grep
26 Requires(preun):        fileutils
27 Requires:       apache1
28 Obsoletes:      apache-mod_log_sql <= 1.13
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _sysconfdir     /etc/apache
32 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
33
34 %description
35 mod_log_sql is a logging module for Apache 1.3 and 2.0 which logs all requests
36 to a database.
37
38 %description -l pl
39 mod_log_sql jest modu³em loguj±cym dla Apache 1.3 i 2.0, który pozwala na
40 logowanie wszystkich zapytañ do bazy danych.
41
42 %prep
43 %setup -q -n mod_%{mod_name}-%{version}
44 %patch0 -p0
45
46 %build
47 %{__libtoolize}
48 %{__aclocal}
49 %{__autoconf}
50 %configure \
51         --with-apxs=%{apxs}
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pkglibdir}}
57
58 install *.so $RPM_BUILD_ROOT%{_pkglibdir}
59 #install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
60
61 rm docs/Makefile* docs/*.xml contrib/Makefile*
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post
67 %{apxs} -e -a -n %{mod_name} %{_libexecdir}/mod_%{mod_name}.so 1>&2
68 if [ -f /var/lock/subsys/apache ]; then
69         /etc/rc.d/init.d/apache restart 1>&2
70 fi
71
72 %postun
73 if [ "$1" = "0" ]; then
74         %{apxs} -e -A -n %{mod_name} %{_libexecdir}/mod_%{mod_name}.so 1>&2
75         if [ -f /var/lock/subsys/apache ]; then
76                 /etc/rc.d/init.d/apache restart 1>&2
77         fi
78 fi
79
80 %files
81 %defattr(644,root,root,755)
82 %doc AUTHORS CHANGELOG TODO contrib docs LICENSE
83 %attr(755,root,root) %{_pkglibdir}/*
84 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
This page took 0.054835 seconds and 3 git commands to generate.