]> git.pld-linux.org Git - packages/apache1-mod_log_sql.git/blob - apache1-mod_log_sql.spec
- regenerated autocrap
[packages/apache1-mod_log_sql.git] / apache1-mod_log_sql.spec
1 # todo: split *.so to subpackages: mysql/dbi/ssl
2 %define         mod_name        log_sql
3 %define         apxs            /usr/sbin/apxs1
4 Summary:        SQL logging module for Apache
5 Summary(pl):    Modu³ logowania zapytañ do Apache do bazy SQL
6 Name:           apache1-mod_%{mod_name}
7 # NOTE: remember about apache-mod_log_sql when updating!
8 Version:        1.99
9 Release:        2
10 License:        Apache (?)
11 Group:          Networking/Daemons
12 Source0:        http://www.outoforder.cc/downloads/mod_log_sql/mod_%{mod_name}-%{version}.tar.gz
13 # Source0-md5:  e246a3d8e96d2d62715eb34f75c7c11d
14 URL:            http://www.outoforder.cc/projects/apache/mod_log_sql/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache1-devel >= 1.3.20
17 BuildRequires:  apache1-mod_ssl-devel
18 BuildRequires:  libdbi-devel >= 0.7.0
19 BuildRequires:  mysql-devel >= 3.23.30
20 Requires(post,preun):   %{apxs}
21 Requires(post,preun):   grep
22 Requires(preun):        fileutils
23 Requires:       apache1
24 Obsoletes:      apache-mod_log_sql <= 1.13
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _sysconfdir     /etc/apache
28 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
29
30 %description
31 mod_log_sql is a logging module for Apache 1.3 and 2.0 which logs all requests
32 to a database.
33
34 %description -l pl
35 mod_log_sql jest modu³em loguj±cym dla Apache 1.3 i 2.0, który pozwala na
36 logowanie wszystkich zapytañ do bazy danych.
37
38 %prep
39 %setup -q -n mod_%{mod_name}-%{version}
40
41 %build
42 %{__libtoolize}
43 %{__aclocal}
44 %{__autoconf}
45 %configure \
46         --with-apxs=%{apxs}
47 %{__make}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pkglibdir}}
52
53 install *.so $RPM_BUILD_ROOT%{_pkglibdir}
54 #install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
55
56 rm docs/Makefile* docs/*.xml contrib/Makefile*
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 %{apxs} -e -a -n %{mod_name} %{_libexecdir}/mod_%{mod_name}.so 1>&2
63 if [ -f /var/lock/subsys/apache ]; then
64         /etc/rc.d/init.d/apache restart 1>&2
65 fi
66
67 %postun
68 if [ "$1" = "0" ]; then
69         %{apxs} -e -A -n %{mod_name} %{_libexecdir}/mod_%{mod_name}.so 1>&2
70         if [ -f /var/lock/subsys/apache ]; then
71                 /etc/rc.d/init.d/apache restart 1>&2
72         fi
73 fi
74
75 %files
76 %defattr(644,root,root,755)
77 %doc AUTHORS CHANGELOG TODO contrib docs LICENSE
78 %attr(755,root,root) %{_pkglibdir}/*
79 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
This page took 0.094943 seconds and 3 git commands to generate.