]> git.pld-linux.org Git - packages/apache1-mod_log_sql.git/blob - apache1-mod_log_sql.spec
0ebd06efd4e2d41fb974f4726c290f1a11b11956
[packages/apache1-mod_log_sql.git] / apache1-mod_log_sql.spec
1 # todo: split *.so to subpackages: mysql/dbi/ssl
2 %define         mod_name        log_sql
3 %define         apxs            /usr/sbin/apxs1
4 Summary:        SQL logging module for Apache
5 Summary(pl):    Modu³ logowania zapytañ do Apache do bazy SQL
6 Name:           apache1-mod_%{mod_name}
7 Version:        1.99
8 Release:        1
9 License:        Apache (?)
10 Group:          Networking/Daemons
11 Source0:        http://www.outoforder.cc/downloads/mod_log_sql/mod_%{mod_name}-%{version}.tar.gz
12 # Source0-md5:  e246a3d8e96d2d62715eb34f75c7c11d
13 URL:            http://www.outoforder.cc/projects/apache/mod_log_sql/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apache1-devel >= 1.3.20
16 BuildRequires:  apache1-mod_ssl-devel
17 BuildRequires:  libdbi-devel >= 0.7.0
18 BuildRequires:  mysql-devel >= 3.23.30
19 Requires(post,preun):   %{apxs}
20 Requires(post,preun):   grep
21 Requires(preun):        fileutils
22 Requires:       apache1
23 Obsoletes:      apache-mod_log_sql <= 1.13
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _sysconfdir     /etc/apache
27 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
28
29 %description
30 mod_log_sql is a logging module for Apache 1.3 and 2.0 which logs all requests
31 to a database.
32
33 %description -l pl
34 mod_log_sql jest modu³em loguj±cym dla Apache 1.3 i 2.0, który pozwala na
35 logowanie wszystkich zapytañ do bazy danych.
36
37 %prep
38 %setup -q -n mod_%{mod_name}-%{version}
39
40 %build
41 %configure \
42         --with-apxs=%{apxs}
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pkglibdir}}
48
49 install *.so $RPM_BUILD_ROOT%{_pkglibdir}
50 #install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
51
52 rm docs/Makefile* docs/*.xml contrib/Makefile*
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 %{apxs} -e -a -n %{mod_name} %{_libexecdir}/mod_%{mod_name}.so 1>&2
59 if [ -f /var/lock/subsys/apache ]; then
60         /etc/rc.d/init.d/apache restart 1>&2
61 fi
62
63 %postun
64 if [ "$1" = "0" ]; then
65         %{apxs} -e -A -n %{mod_name} %{_libexecdir}/mod_%{mod_name}.so 1>&2
66         if [ -f /var/lock/subsys/apache ]; then
67                 /etc/rc.d/init.d/apache restart 1>&2
68         fi
69 fi
70
71 %files
72 %defattr(644,root,root,755)
73 %doc AUTHORS CHANGELOG TODO contrib docs LICENSE
74 %attr(755,root,root) %{_pkglibdir}/*
75 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
This page took 0.047891 seconds and 2 git commands to generate.