]> git.pld-linux.org Git - packages/apache1-mod_iptos.git/blame - apache1-mod_iptos.spec
- new
[packages/apache1-mod_iptos.git] / apache1-mod_iptos.spec
CommitLineData
e8c35283
ER
1%define mod_name iptos
2%define apxs %{_sbindir}/apxs1
3Summary: Apache module: assign IPTOS bits to different vhosts or directories.
4Name: apache1-mod_%{mod_name}
5Version: 1.1
6Release: 0.1
7License: Apache 1.1
8Group: Networking/Daemons
9Source0: http://www.arctic.org/~dean/mod_iptos/libapache-mod-%{mod_name}_%{version}.orig.tar.gz
10# Source0-md5: 1e5582acf63b6fabf567ecb79e57bdd5
11URL: http://www.arctic.org/~dean/mod_iptos/
12BuildRequires: apache1-devel >= 1.3.33-2
13BuildRequires: rpmbuild(macros) >= 1.228
14Requires: apache1 >= 1.3.33-2
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
18%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
19
20%description
21Modify IPTOS bits on outbound data for fine-tuned traffic shaping
22mod_iptos is a module for apache 1.3.x which allows the admin to
23assign different IPTOS bits to different vhosts or directories. This
24can be used in combination with traffic shaping to give much better
25control (than other userland-only solutions such as mod_bandwidth)
26over the bandwidth for various portions of a website.
27
28%prep
29%setup -q -n libapache-mod-%{mod_name}-%{version}
30
31%build
32%{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so
33
34%install
35rm -rf $RPM_BUILD_ROOT
36install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
37
38install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
39echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
40 $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
41
42%clean
43rm -rf $RPM_BUILD_ROOT
44
45%post
46%service apache restart
47
48%postun
49if [ "$1" = "0" ]; then
50 %service -q apache restart
51fi
52
53%files
54%defattr(644,root,root,755)
55%doc README debian/changelog
56%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
57%attr(755,root,root) %{_pkglibdir}/*
This page took 0.072803 seconds and 4 git commands to generate.