]> git.pld-linux.org Git - packages/apache1-mod_hosts_access.git/blob - apache1-mod_hosts_access.spec
- use apache1(EAPI) for runtime dep
[packages/apache1-mod_hosts_access.git] / apache1-mod_hosts_access.spec
1 %define         mod_name        hosts_access
2 %define         apxs            /usr/sbin/apxs1
3 Summary:        Apache module: access defined by hosts.allow/hosts.deny
4 Summary(pl.UTF-8):      Moduł do apache: dostęp na podstawie hosts.allow/hosts.deny
5 Name:           apache1-mod_%{mod_name}
6 Version:        1.0.0
7 Release:        0.4
8 License:        BSD
9 Group:          Networking/Daemons
10 Source0:        http://www.klomp.org/mod_hosts_access/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  3720e303cfde50e94586f484a903aa41
12 URL:            http://www.klomp.org/mod_hosts_access/
13 BuildRequires:  apache1-devel >= 1.3.39
14 BuildRequires:  libwrap-devel
15 BuildRequires:  rpmbuild(macros) >= 1.268
16 Requires:       apache1(EAPI)
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
20 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
21
22 %description
23 Mod_hosts_access allows you to use the hosts.allow and hosts.deny
24 files to configure access to your apache webserver.
25
26 %description -l pl.UTF-8
27 Mod_hosts_access pozwala używać plików hosts.allow i hosts.deny do
28 określania dostępu do zasobów serwera WWW apache.
29
30 %prep
31 %setup -q -n mod_%{mod_name}-%{version}
32
33 %build
34 %{apxs} -c mod_%{mod_name}.c -lwrap
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
39
40 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
41
42 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
43         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %post
49 %service -q apache restart
50
51 %postun
52 if [ "$1" = "0" ]; then
53         %service -q apache restart
54 fi
55
56 %files
57 %defattr(644,root,root,755)
58 %doc README INSTALL
59 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
60 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.090103 seconds and 3 git commands to generate.