]> git.pld-linux.org Git - packages/apache1-mod_gzip.git/blame_incremental - apache1-mod_gzip.spec
- tabs in preamble
[packages/apache1-mod_gzip.git] / apache1-mod_gzip.spec
... / ...
CommitLineData
1%define mod_name gzip
2%define apxs /usr/sbin/apxs1
3Summary: Apache module: On-the-fly compression of HTML documents
4Summary(pl.UTF-8): Moduł do apache: kompresuje dokumenty HTML w locie
5Name: apache1-mod_%{mod_name}
6Version: 1.3.26.1a
7Release: 3
8License: Apache
9Group: Networking/Daemons
10Source0: http://dl.sourceforge.net/mod-gzip/mod_gzip-%{version}.tgz
11# Source0-md5: 080ccc5d789ed5efa0c0a7625e4fa02d
12Source1: %{name}.conf
13Source2: %{name}.logrotate
14Patch0: %{name}-name_clash.patch
15Patch1: %{name}-security.patch
16URL: http://www.schroepl.net/projekte/mod_gzip/
17BuildRequires: %{apxs}
18BuildRequires: apache1-devel >= 1.3.33-2
19BuildRequires: rpmbuild(macros) >= 1.268
20BuildRequires: zlib-devel
21Requires(triggerpostun): %{apxs}
22Requires(triggerpostun): grep
23Requires(triggerpostun): sed >= 4.0
24Requires: apache1(EAPI)
25Obsoletes: apache-mod_gzip <= 1.3.26.1a
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
29%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
30%define _pkglogdir %(%{apxs} -q PREFIX 2>/dev/null)/logs
31
32%description
33Apache module: On-the-fly compression of HTML documents. Browser will
34transparently decompress and display such documents.
35
36%description -l pl.UTF-8
37Moduł do apache: kompresuje dokumenty HTML w locie. Przeglądarki w
38sposób przezroczysty dekompresują i wyświetlają takie dokumenty.
39
40%prep
41%setup -q -n mod_%{mod_name}-%{version}
42%patch0 -p1
43%patch1 -p1
44
45%build
46%{apxs} -Wc,-Wall,-pipe -c mod_%{mod_name}.c mod_%{mod_name}_debug.c mod_%{mod_name}_compress.c -o mod_%{mod_name}.so
47
48%install
49rm -rf $RPM_BUILD_ROOT
50install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d,/etc/logrotate.d,%{_pkglogdir}}
51
52install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
53install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
54install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
55
56> $RPM_BUILD_ROOT%{_pkglogdir}/mod_gzip.log
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%post
62%service -q apache restart
63
64%postun
65if [ "$1" = "0" ]; then
66 %service -q apache restart
67fi
68
69%triggerpostun -- %{name} < 1.3.26.1a-1.1
70if grep -q '^Include conf\.d/\*\.conf' /etc/apache/apache.conf; then
71 %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
72 sed -i -e '
73 /^Include.*mod_%{mod_name}\.conf/d
74 ' /etc/apache/apache.conf
75else
76 # they're still using old apache.conf
77 sed -i -e '
78 s,^Include.*mod_%{mod_name}\.conf,Include %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf,
79 ' /etc/apache/apache.conf
80fi
81%service -q apache restart
82
83%files
84%defattr(644,root,root,755)
85%doc docs/manual/english/*
86%lang(de) %doc docs/manual/deutsch
87%attr(755,root,root) %{_pkglibdir}/*
88%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
89%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
90%attr(640,root,root) %ghost %{_pkglogdir}/*
This page took 0.345674 seconds and 4 git commands to generate.